Variador de frecuencia y PWM

Buenas tardes,
Estoy trabajando en un proyecto y tengo un problema, estoy moviendo un motor jaula de ardilla con un variador de frecuencia, de la marca salicru CV10, el cuál tiene entradas digitales para poder controlarlo con un microcontrolador, estoy usando un PWM, mi problema es el siguiente, si giro hacia la derecha el PWM funciona correctamente, sin envargo, si invierto el sentido de giro, es decir, invierto las fases según el variador de frecuencia, ya el PWM no me funciona correctamente.

No se si a alguien le ha pasado o si sabeis como puedo solucionarlo.

Muchas gracias de antemano.
Un saludo.
 
Me imagino que metes la señal pwm a la entrada analógica del variador y que eso es lo que regula la velocidad de giro.
Me imagino que esa señal de pwm está convenientemente filtrada o que por el contrario tu ya sabes que tu variador admite señal pwm sin filtrar
Me imagino que el variador está convenientemente configurado
Me imagino que has verificado el variador sin el microcontrolador y que va bien
Me imagino que has verificado que el código del microconrolador está bien y que no hace pwm en un sentido y todo-nada en el otro

Si haces el favor, aclara todos esos meimagiinos para saber a ciencia cierta y no imaginar nada, porque ahora mismo no tengo claro que has hecho y como. Me imagino que en alguno de esos meimaginos está el problema, seguramente mal filtrado, mala programación del variador o del microcontrolador.

Así desde la ignorancia absoluta yo intentaría controlar lo que hace el variador mediante algún protocolo digital, através del modbus rs485 que lleva ese variador (creo) u otro sistema semejante, y no metiendo enmedio de dos cosas digitales una señal analógica que solo te va a traer problemas como ya te está pasando ahora mismo.
Podria ser que lo que tengas sea una interferencia en la señal analógica, no me parece probable pero tampoco lo puedo descartar.
 
Última edición:
Buenas tardes Scooter, muchas gracias por tu rápida respuesta.

Lo que estoy haciendo exactamente es introducir, a partir de las señales digitales que tiene este variador la señal PWM, he visto que sin el microcontrolador el variador funciona, y con la señal PWM también funciona, lo que pasa que no hace caso al PWM, la señal entra limpia al variador, lo compruebo con un osciloscopio, y lo curioso de todo esto es que si le introduzco la señal PWM por la entrada digital S1, el motor que es un jaula de ardilla, gira hacia la derecha haciendo caso a la señal PWM, el problema es cuando yo cambio de entrada, e introduzco la señal PWM por la entrada digital del variador S2, que he de decir que previamente la he configurado para que mueva el motor en sentido inverso, creo que lo que hace es invertir las fases, y en este caso, la señal entra exactamente igual que la otra, pero el motor gira sin tener en cuenta la señal PWM.

Todos tus me imagino están corroborados, he probado a invertir los cables que salen del micro, para ver si el PWM estaba hecho de forma correcta, y efectivamente, lo que conecto a la entrada del variador S2, es decir, la que está invertida es la que no funciona de forma correcta.

También tengo que decir que yo del variador al motor no controlo absolutamente nada, no puedo ir viendo como se convierte la señal ni lo que le acaba llegando al motor ni nada porque no sabría como hacerlo.

Muchas gracias de nuevo.
Un saludo.
 
Vale, entonces es que el variador "lee" señales pwm como analógicas. Eso me parece mas coherente.
Por lo que estás contando está mal configurado el variador, o eso o lee algo raro de la señal "no usada", es decir, cuando metes el pwm en S2 ¿Que haces con S1? ¿Lo dejas al aire, lo tiras a masa, a positivo...?

Prueba cambiando el conexionado, es decir. Si con el microcontrolador va bien "a derechas", intercambia el conexionado de S1 y S2 y sigue mandando lo mismo desde el microcontrolador, ahora debería de ir "a izquierdas". Si va bien, es problema de programación del microcontrolador, si va mal es problema de programación del variador.
Por ejemplo, se me ocurre que estás usando como pwm un pin del microcontrolador que no lo permite si es el primer caso. O quie ese pin va a otra frecuencia diferente que el primero.
Si es el segundo a lo mejor es que S2 no admite PWM o que te liaste en la programación y le enviaste que mire en S1 y no en S2...


Se me ocurre que reprogrames todo para que S1 haga de control de velocidad y S2 haga de control de sentido de giro, así S2=0 + pwm da velocidad de giro a derechas y S2=1 + pwm da velocidad de giro a izquierdas...
 
He probado a hacerlo, y solo funciona hacia la izquierda, cambiando el PWM, quiero decir, si tengo un pwm1 y un pwm2 ambos funcionan sólo cuando los meto por la entrada S1, en cuanto utilizo la S2 no funciona. Me he puesto en contacto con el soporte técnico del variador de frecuencia y me han dicho que si que lee perfectamente señales PWM sin importar si la fase está o no está invertida, que no necesito ponerle ningún tipo de protección ni nada para que funcione.

Muchas gracias de nuevo.
Mensaje automáticamente combinado:

He pensado que puede ser problema del transistor, estoy usando un 2N2222, nose si es el más adecuado para esto, era lo que tenía.
 
Última edición:
Hola, sube un esquema eléctrico sobre cómo has hecho las conexiones!
Así sin más es adivinar.
Buenas tardes, gracias por tu respuesta, es que no sabría muy bien como dibujarlo y creo que va a ser muy poco explicativo, yo lo cuento a ves si así me entendeis, yo programo dos pines del microcontrolador que tienen una salida en PWM, y esos pines los mando a las entradas digitales del variador de frecuencia a partir de cables, al variador le meto las dos señales del PWM y la masa tomada del micro, y ya el variador hace su trabajo, no sabría decirte cómo se comunica con el motor, supongo que convertira la señal PWM en senoidal y lo mandará al motor que está conectado el triángulo.
 
las salidas del micro controlador son ttl me imagino, y de ser asi van de 5V a 0V, en la entrada del inverter, los valores de tension son esos?
No usé un inverter por ese lado, siempre los usé con las entrada de control analogicas por eso no tengo experiencia por el lado digital.
 
Parece, eso es lo que creo , que falla algo en la programación del variador. Si conectando en "=" va bien a la derecha y conectando en "X" sigue funcionado bien a la derecha es que está "mal" el variador.
Mal programado, mal conectado, no necesariamente averiado.
Por descartar cambia el motor y/o su conexionado. es decir, invierte el motor a ver si cambia algo aparte del sentido de giro.
 
Hablé con los del soporte técnico del variador, y me dijeron que la programación era la correcta.

He descubierto otra cosa, he cambiado el sentido de las entradas, para cerciorarme de si es la inversión de fases lo que no funciona como yo quiero, o ver si es esa entrada en concreto, he descubierto que no se trata de tener las fases invertidas o en su estado normal, (todo esto lo programo por el variador), si no que se trata de la propia entrada, todo lo que entra por la entrada S1, esté o no esté invertida la fase no funciona correctamente, ayer me confundí, dije que no funcionaba, y si funciona, el motor gira , pero no lo hace en relación al PWM, la entrada que funciona bien se nota que va pulso a pulso, y puedo variar la velocidad, en la entrada en la que no funciona bien el motor gira, pero no va pulso a pulso, es un movimiento no constante, como si leyera 3 pulsos, luego 2, luego 5, no entiendo muy bien el porqué.

He cogido otras entradas, S2 y S3 y ya aparentemente y por el momento parece que funciona, la única explicación que le veo es que la entrada S1, sea más lenta conmutando o sea más sensible al tema de los ruidos.
Si alguién tiene alguna teoría estaré encantada de leerla.

No se si me estoy explicando bien, perdonad por el jaleo.
Muchas gracias.
 

capitanp

Miembro irreconocible
Pero hombres, desde cuando podemos meter un PWM por las entradas digitales y que desde ahí podamos variar la velocidad, estan locos
Lo mas probable es que el variador arranque y se pare dependiendo el filtrado de la entrada digital, por eso lo errático


Pagina 41

 
Pero hombres, desde cuando podemos meter un PWM por las entradas digitales y que desde ahí podamos variar la velocidad, estan locos
Lo mas probable es que el variador arranque y se pare dependiendo el filtrado de la entrada digital, por eso lo errático


Pagina 41

Yo pensaba que no iba a poder, pero hablé con el técnico y me dijo que sin ningún problema aceptaba entrabas PWM.
 
Por eso mismo aclaré, en los usos que les damos a los variadores es controlar la velocidad por la entrada analogica y el uso de on-off externo, como asi tambien del sentido de giro, ademas para variar la velocidad se varia la frecuencia no el pwm, en todo caso con ese pwm integrandolo tendrás la tensión analogica para poder controlar la velocidad del motor.
 
No he leído las especificaciones. Como poder, podría ser que leyera pwm y lo interpretara. Lo poco que he leído dice que 1kHz la entrada máximo. Si el pwm es más lento pues puede que lo intérprete.
Pero tampoco sabemos cómo lo hace el micro porque no lo han dicho
 
Ya, por el momento parace que funciona, nose si todo lo fino que debería funcionar, pero para la aplicación que quiero usar me vale, porque lo único que necesitaba es que cuando fuera a parar desacelerara un poco para evitar un poco temas de inercia, y creo que con esto lo puedo solucionar.

Muchas gracias!!
 
Arriba