Algo no me cuadra con circuito amplificador.

#1
Hola buenas tardes, espero alguien me pueda ayudar con este circuito.
El propósito del circuito es amplificar una señal triangular de un microcontrolador con DAC y pasarla de valores positivos a algo parecido a una señal triangular AC, por eso diseñe este circuito que tiene la entrada X14-1 como entrada de la señal que va de 0 a 3.3v, la entrada X14-2 es un voltaje de referencia de 3.3v que dividire a la mitad para poderselo restar a la señal del DAC y asi obtener a la salida una señal triangular de +-1.65 volts aproximadamente. El circuito funciona pero tuve que cambiar R21 por un potencimietro debido a que en la salida se podia ver un OFFSET de 150mV y con el potencionmetro podria mover el OFFSET, al momento de ver la salida con mi osciloscopio, se puede ver que el offset se arreglo pero al momento de meter esta señal de salida a un sumador de voltaje para poder sumarle una señal externa. Esta señal triangular me aparece con un offset de -2 volts. Ya revise todas las conecciones de los opamps y revise si podria estar mal conectado algun componente pero no se como solucionar esto.
Captura1.JPG
 
#2
No caben dudas que al conectar la carga del sumador, esté modifica las condiciones originales de funcionamiento, por las dudas conectala una carga resistiva a las salida del ultimo op, simlando la carga de tu sumador el cual genera ese corrimiento, si de esa manera aparace el problema tendrías que recalibrar todo con la carga del sumador o reformzar la corriente de salida del ultimo op, en cambio si no se modifica con una carga resistiva la cosa estaría en el sumador propiamente dicho.
 

Dr. Zoidberg

Well-known-Papá Pitufo
#3
.... al momento de ver la salida con mi osciloscopio, se puede ver que el offset se arreglo pero al momento de meter esta señal de salida a un sumador de voltaje para poder sumarle una señal externa. Esta señal triangular me aparece con un offset de -2 volts. Ya revise todas las conecciones de los opamps y revise si podria estar mal conectado algun componente pero no se como solucionar esto.
Y que te parece si completás el circuito que estás usando y agregás el sumador y demás cosas????
La unica forma de que un sumador te desplace el offset en -2V es que estés sumando una tensión que, multiplicada por la ganancia del sumador, te produzca esa desviación.
 

Temas similares

Arriba