Amplificador AB con Mosfet N y P no funciona.

Hola compañeros, necesito vuestra ayuda, tengo esta simulacion hecha con idea de llevar a la practica este circuito, pero resulta que a la salida del operacional la señal sale mal y a partir de ahi nada funciona correctamente, ¿seriais tan amables de decirme donde esta el error de este circuito que yo no alcanzo a entender por que esto no funciona? entiendo que los dos transistores T1 y T2 son los que polarizan la alimentacion del operacional y lo estan haciendo mal, muchas gracias de antemano.
 

Adjuntos

  • 2.gif
    2.gif
    66.6 KB · Visitas: 44
Muchas gracias dosmetros, echale un vistazo porfa.

Estoy intentando entender el funcionamiento de este circuito, he buscado informacion sobre esta configuracion de alimentarse el operacional atraves de dos transistores y el diodo zener polarizado inversamente en la base y bueno, despues de probar y estudiarlo como he podido dentro de mis posibilidades y escasos conocimientos he llegado a algunas conclusiones, si estoy equivoado o me podeis echar un cable para entender el funcionamiento se agradece un monton, mil gracias de nuevo.
Este es casi igual. Mira a ver si este te funciona:

probare a simularlo, la cosa es que yo creo que la diferencia entre el tuyo el mio es exactamente lo que esta fallando, la alimentacion del operacional.

Por otro lado tambien esta la realimentacion de la salida al operacional vuelve a entrar por la entrada inversora y creo que deberia ir por la no inversora, ya me vais diciendo, mil gracias.
 

Adjuntos

  • amplificador mosfet.rar
    1.5 KB · Visitas: 7
  • putiad.PNG
    putiad.PNG
    51 KB · Visitas: 19

Fogonazo

"Qualified exorcist approved by the Vatican"
Muchas gracias dosmetros, echale un vistazo porfa.

Estoy intentando entender el funcionamiento de este circuito, he buscado informacion sobre esta configuracion de alimentarse el operacional atraves de dos transistores y el diodo zener polarizado inversamente en la base y bueno, despues de probar y estudiarlo como he podido dentro de mis posibilidades y escasos conocimientos he llegado a algunas conclusiones, si estoy equivoado o me podeis echar un cable para entender el funcionamiento se agradece un monton, mil gracias de nuevo.

probare a simularlo, la cosa es que yo creo que la diferencia entre el tuyo el mio es exactamente lo que esta fallando, la alimentacion del operacional.

Por otro lado tambien esta la realimentacion de la salida al operacional vuelve a entrar por la entrada inversora y creo que deberia ir por la no inversora, ya me vais diciendo, mil gracias.

Ese tipo de amplificador se llama "Current dumping amplifier" y a pesar de lo extraño que parezca funciona aunque NO me inspira amor.

Simplificando el concepto:
Se emplea la caída de tensión sobre las resistencias de 3k3 debidas al consumo del operacional para excitar los MOSFET.
La fuente de corriente constante T1 & T2 ajustan la corriente de polarización de los MOSFET de acuerdo a la temperatura, deben estar acoplados térmicamente a los MOSFET
 
Aquí hay uno parecido, creo que funciona con el mismo principio.
Y en la siguiente pagina se explica muy por encima su funcionamiento.
 
sebsjata, he estado mirando la pagina, pero no veo el lugar donde se explica un circuito de estos la mision de cada componente y como funciona.

Lo de la simulacion lo he podido arreglar, la solucion ya la habia hecho otras veces, fue cambiar el operacional por uno de precision, se ve que el TL071 de lt spice pusieron una version falsificada de esas de ebay y aliexpress, yo lo he cambiado por un operacional de precision y mano de santo, una maravilla.
 
Esos circuitos (los dos, llevan el grafismo de Elektor, o sea, una garantía.... Lo que no entiendo es que en los simuladores haya también componentes "truchos" como decís por allí...... creía que lo habías montado y el IC era falso, pero que lo que sea falso es el IC del simulador ¡¡¡¡¡¡¡¡ Increíble ¡¡¡¡¡¡¡
 
jajajajaja, pues eso parece, hay replicas de operacionales y de circuitos integrados que en circuitos mas exigentes funcionan realmente mal, ya me ha pasado con un clase D que simule hace un mes mas o menos, puse un IR2110 y no funcionaba el circuito, lo cambie por un IR2110A y salio andando de lujo.
Tambien es cierto que por lo que se ve, los operacionales de precision en la simulacion funcionan muchisimo mejor que los TL71, jrc4558 etc.
 

Fogonazo

"Qualified exorcist approved by the Vatican"
Aquí hay uno parecido, creo que funciona con el mismo principio.
Y en la siguiente pagina se explica muy por encima su funcionamiento.
Nop, "No se igual"
 
Arriba