Analizando circuito amplificador no inversor

hola a todos tengo una duda con respecto a los amplificadores operacionales en modo no inversor, resulta que estaba diseñando un circuito para lo cual quise ocupar la configuracion no inversora hice el circuito corri la simulacion pero cuando llegue a hacerlo de manera practica no hubo forma de que funcionara lo volvi a hacer 3 veces hasta que en el protoboard encontre porque no funcionaba y era una resistencia que marque en el diagrama como R1,he leido bastante en libros sobre OAMP no inversor pero no he encontrado mension de esta resistencia menos que funcion cumple y como calcular su valor si alguien con mas conocimiento del tema me puede aclarar esta duda se lo agradeceria.

El adunto que dice OAMP NO INV es el tipico que sale en los libros y el OAMP NO INV2 es el que incluye la resistencia que sin ella no me funcionaba el OAMP
 

Adjuntos

Fogonazo

"Qualified exorcist approved by the Vatican"
La configuración no inversora con fuente simple es bastante mas complicada que lo que dibujaste.

1) Debes establecer un punto de trabajo del operacional para CC, generalmente a Vcc/2
2) Debes desacoplar la realimentación a la CC
 
La configuración no inversora con fuente simple es bastante mas complicada que lo que dibujaste.

1) Debes establecer un punto de trabajo del operacional para CC, generalmente a Vcc/2
2) Debes desacoplar la realimentación a la CC
gracias Fogonazo por responder, el circuito final no es ese, tengo los capacitores de desacople y todo lo necesario lo puse asi para hacer mas simple el circuito la duda es que funcion cumple R1 y porque si no esta conectado al punto medio no amplifica?
adjunto un diagrama mas realista
 

Adjuntos

Fogonazo

"Qualified exorcist approved by the Vatican"
Sigue faltando lo que te indique

La configuración no inversora con fuente simple es bastante mas complicada que lo que dibujaste.

1) Debes establecer un punto de trabajo del operacional para CC, generalmente a Vcc/2
2) Debes desacoplar la realimentación a la CC
 

Fogonazo

"Qualified exorcist approved by the Vatican"

Esto:

Ver el archivo adjunto 142696

NO es lo mismo que esto otro:

Ver el archivo adjunto 142697


Ese capacitor de 100nF dará una frecuencia de corte algo alta.

En este esquema estás creando una tierra virtual mediante un divisor, lo cual sirve, pero yo te comentaba hacer el divisor y con este polarizar la entrada (+) a Vcc/2
a ver si estoy entendiendo el R1 es para polarizar la entrada (+) y el capacitor aparte de aislar la continua situa la frecuencia de funcionamiento del OAMP, que valor tiene que tener R1?
 
Para que no te compliques con la configuración no inversora, sigue estos consejos:
1. No coloques resistencias tan altas del orden de los megas.
2. No coloques resistencias muy bajas del orden de los cientos de ohmios.
3. Utiliza resistencias entre 1k y 500k.
4. Utiliza dos fuentes una para VCC(positiva) y otra para VDD(negativa). Entre 5 y 12 V.
5. No coloques voltajes tan altos en la entrada, porque la salida sera saturada y solo veras VCC o VDD.
 
Para que no te compliques con la configuración no inversora, sigue estos consejos:
1. No coloques resistencias tan altas del orden de los megas.
2. No coloques resistencias muy bajas del orden de los cientos de ohmios.
3. Utiliza resistencias entre 1k y 500k.
4. Utiliza dos fuentes una para VCC(positiva) y otra para VDD(negativa). Entre 5 y 12 V.
5. No coloques voltajes tan altos en la entrada, porque la salida sera saturada y solo veras VCC o VDD.
gracias por tomarte la molestia de contestar, todo eso lo entiendo pero mi duda es que valor tiene que llevar R1 y como se calcula
por ejemplo la gancia seria para este caso = R4/R2+1
pero donde entra R1 o no importa el valor??????:confused::confused:
 

Dr. Zoidberg

Well-known-Papá Pitufo
R1 define el valor de la impedancia de entrada del amplificador, y ese es un parametro de diseño ==> tenes que definirlo vos en base a la aplicacion del ampli (ojo que te va a cambiar el offset de salida)
 
gracias por tomarte la molestia de contestar, todo eso lo entiendo pero mi duda es que valor tiene que llevar R1 y como se calcula
por ejemplo la gancia seria para este caso = R4/R2+1
pero donde entra R1 o no importa el valor??????:confused::confused:
Si polarizas el operacional con dos fuentes, solo colocas dos resistencias, las mismas que se muestran en todos los esquemas de operacional no inversor.

En caso que quieras usar una sola fuente debes hacer que la señal de salida este montada en VCC/2 tal como dice Fogonazo. Y también se complica mas el diseño.
 
R1 define el valor de la impedancia de entrada del amplificador, y ese es un parametro de diseño ==> tenes que definirlo vos en base a la aplicacion del ampli (ojo que te va a cambiar el offset de salida)
gracias por la respuesta, como lo que estoy haciendo es para un buffer de entrada para guitarra electrica que el voltaje maximo PP seria menor a 1 Voltio y una corriente diminuta la resistencia tendria que ser del orden de 1MΩ, lo voy a probar a ver que tal anda
 
Hola tengo esta duda con un amplificador no inversor cuando alimento con los 5 voltios "lo hago con un arduino" la tensión de salida se me fija en un valor cercano a los (3-3.2) V lo que me impide amplificar cualquier entrada de tensión que quiera ponerle simplemente no se mueve. En la simulación funciona pero en la practica ya no, use resistencias fijas y luego cambie a un trimmer para comprobar si variaba la salida "que no me sirvió de nada por que tengo que medir entre las 2 patas externa y el común va al negativo" pero no varia nada, intente con un LM324N y un LM358 y obtuve el mismo resultado.
Gracias al que me pueda sacar de mi ignorancia. ...
 
Última edición:
Saludos

Circuito por delante.
Aunque te comento porque sucede eso, no has comentado que matrícula usas en particular salvo los otros dos modelos; eso sucede porque un operacional "común" no tiene una salida "rail to rail" concepto que se refiere a que su salida puede incursionar en valores muy cercanos a los de alimentación.

Para tu caso, cerca de 0V y de +5V.

Comenta cuál es la aplicación general y veremos que alternativas se pueden dar.
 




Esta seria la conexión que realice me entrega 3 V a la salida sin conectar nada a la entrada. en lugar de laalimentación de 5V también intente alimentar una fuente dc de 3V que hice con 2 pilas y me da a la salida 1.5V en este caso si conecto algo a la entrada se me cae la tensión de salida a casi 0.



Saludos


Comenta cuál es la aplicación general y veremos que alternativas se pueden dar.
quiero medir la corriente que entrega un panel solar para eso le conecte una resistencia shunt de 0.3 ohms y mido la tensión que cae sobre la resistencia, el problema es que es una tensión muy pequeña y necesito que la lea un arduino pero apenas y me entrega 0.2 mV colocándole una lampara y la unidad mas pequeña que lee el arduino es 4mv por eso necesito amplificar hasta cerca de 5V que es el tope del arduino. estaba pensando en un LT6231 pero no se si lo consiga.
 
Última edición:
Cuando digo circuito eléctrico, me refiero al circuito teórico, con símbolos de componentes, pues así no se aprecia.
Pero veo, que sólo usas una entrada del op-amp.:eek:
Y ahí está el problema.
 
Última edición:
Cuando digo circuito eléctrico, me refiero al circuito teórico, con símbolos de componentes, pues así no se aprecia.
Pero veo, que sólo usas una entrada del op-amp.:eek:
Y ahí está el problema.
creo que te refieres con una sola entrada a que no tengo nada conectado al positivo del amplificador, no tengo conectado nada a la entrada por que me daría lo mismo "como te comento la salida se fija sin importar que conecte a la entrada", creo que me interpretaste mal "fue culpa mía por no pintar el dibujo con la fuente entre positivo y tierra que es la que me hace falta. Lo deje así a propósito por que no se por que diablos tengo 3 V a la salida si a la entrada no tengo nada. o sea en la teoria 0V*R1/R2= 0, pero en mi caso 0V*R1/R2=3
No coloque el teórico por que es el que sale cuando buscas en google, que no dice absolutamente nada, te dejo el circuito en todo caso
 

Adjuntos

Última edición:
creo que te refieres con una sola entrada a que no tengo nada conectado al positivo del amplificador, no tengo conectado nada a la entrada por que me daría lo mismo "como te comento la salida se fija sin importar que conecte a la entrada", creo que me interpretaste mal "fue culpa mía por no pintar el dibujo con la fuente entre positivo y tierra que es la que me hace falta. Lo deje así a propósito por que no se por que diablos tengo 3 V a la salida si a la entrada no tengo nada. o sea en la teoria 0V*R1/R2= 0, pero en mi caso 0V*R1/R2=3
No coloque el teórico por que es el que sale cuando buscas en google, que no dice absolutamente nada, te dejo el circuito en todo caso


Espera, no tener nada conectado a la entrada no es lo mismo que 0 volts. Una entrada flotada es susceptible a ruido.

Por otro lado, en el pcb tienes separadas las referencias a GND del operacional y la de señal, eso no puede ser. La señal a amplificar y el operacional deben compartir referencia a GND.

Saludos


 
Eso era! que vergüenza no me había dado cuenta gracias. Me convencí de que el problema era otro por que había probado con unas pilas que si había conectado bien. y no se veía nada pero era por que la irradian era muy bajita.
 

Temas similares


Arriba