[Aporte] Puente H para Motores.

#41
Bueno, me fije en lo de los transistores y dos tenian el patillaje al reves cosa muy rara, los di vuelta y el puente anduvo unos segundos pero un solo lado y luego no anduvo mas, nada calienta pero tampoco funciona, ya no se que tocar. Les dejo un PDF con el esquema y el PCB del Altium a ver si encuentran algo.

Saludos y gracias!!
 

Adjuntos

#42
una duda como conectas los colectores de los transistores? y pues de ahi a simple vista parece q no hay problema pero pues honestamente te recomendaria que lo hicieras como lo posteo thenot, asi seguro que jala de una... los transistores que utilizaste son los q tienes ahi??
no se pudiste conseguir los que estan en el diagrama original?, por que pues los que utilice fueron los tip120 y tip 125, con los driver 2n2222
 
#44
bueno eso si entonces si habria que checar muy bien y sigo con la duda como conectas el colector de los transistores por pues en el impreso se ve que quedan en el aire...
 
#45
Haaa si me olvide de ese detalle, lo colectores los agarre con cables atornillandolos en el encapsulado de los transistores (que son los colectores) conectando cada par cruzado junto.

Saludos
 
#48
A quien le interese, le paso otro tipo de puente H, que usa tanto relés como transistores:



La idea básica es usar un transistor para lograr el apagado y prendido del motor (y poder usar PWM y un lazo para controlar su velocidad) y usar un relé para invertir la marcha.

Características:
Relativamente simple, quizás sea más barato que comprar los 6 transistores que requiere un puente H estándar.
No hay casos que rompan los transistores.
Consume un poco más de corriente extra (por el relé)
La potencia entregada al motor es mejor que en un puente H (solamente una caída VCE)

Pueden ver más información en mi sitio web: http://gzaloprgm.com.ar/puenteh

Díganme sus opiniones y cómo se podría mejorar.

Un saludo,
Gonzalo
 
#49
Esta muy bueno ese circuito con rele ademas de que se aisla completamente el circuito de control del de potencia a través de la bobina del relé. El diodo ese que función cumple? La FEM del motor?

Saludos
 
#52
hola thenot. gracias por el aporte. me hice socio en el foro para hacerte una pregunta, espero que puedas ayudarme.
construí el punte H que dejaste y funciona perfectamente cuando lo conecto a 5V de una fuente de tension. mi problema se sucede cuando conecto los dos cables de control del punte h a un microcontrolador (16f84a)
lo que ocurre es que cae la tension de 5V en el micrcontrolador cuando alimento el puente h. pense que se debia a que el consumo de corriente está por encima de los 20mA que puede entregar el micro, pero el consumo de corriente es menor.
de todo modos decidi intercalar un seguidor de tension en el circuito. pero cuando alimento el puente H desde los cables de control, la tension del A.O. tambien cae.
coloque resistencia pull down la salida del Amplificador O., pero esto sigue sucediendo.
 
#53
Hola, sorry que no te pueda contestar de buena forma, pero es que me pillaste en mal momento.. tengo solo unos minutos para conectarme y ando en plan de trabajo, asi que por algunas semanas no podre tampoco hacerlo.. solo te puedo decir, que si usas para los motores la misma fuente de alimentacion que la que usas para el pic, separalas, usa una para el pic y otra para alimentar los motores, claro debes juntar los negativos de ambas fuentes para que funcione. Yo lo e usado con pic, basic stamp, etc.. y no e tenido problemas con este puente H, pero lo de la alimentacion es algo que debes ver ya que por lo general genera "interferencias" o si no tienes el suficiente amperaje, el motor te los consume y dejas sin corriente al pic, y estos con un poco de "interferencia" en la corriente se reinician o empiezan a hacer cosas raras. Asi que prueba con ello.

Saludos!
 
#55
Thenot, gracias por responder, solucione mi problema. NO es que la tension caia en el PIC cuando queria alimentar el motor, sino que el motor produce ruido (interferencias) que hacian que el programa el salte y no siga la logica programada.
Como lo solucione? simplemente agregando un capacitor ceramico en paralelo con el motor. El programa responde perfectamente y el puente H tambien.
gracias saludos
 
#58
Que tal thenot, sabes que estoy necesitando un PH que maneje 24 Volt y 3A queria saber si este me sirve ya que intente hacer uno con Tip 41 y 42 pero volaron. En el caso de que pueda manejar esa tencion las resistencias que utilizo son de 1/4W o deberia aumentarlas.-
 
#59
ese voltaje y amperaje no es nada (si es algo.. pero lo soportan bien) para lo que soportan los tip que nombras, asi que tienes que haber hecho algo mal, ya que no debiesen por que haber salido volando.. y la resistencias depende de donde la usas, si es para excitar los transistores no tienes para que poner de mas..

yo e usado este ph con tip 122 y sus complementos a un voltaje de 36 y 5 amperes y no tuve problema alguno, solo que debí ponerle un disipador, aunque no gran cosa.
 
#60
Muchas felicitaciones por este tema. El caso es que quiero aportar esta imagen de su PBC, en la cual le coloco la iniciales a los transistores (B=Base, E=Emisor, C=Colector). Espero sea de gran ayuda.
 

Adjuntos

Temas similares

Arriba