Arduino+Bluetooth

Muy buena noche amigos del foro, continúe haciendo el robot el cual ya he comprendido mejor el lenguaje ARDUINO, y lo estoy controlando mediante voz en Android, ahora bien, tengo esa plataforma de robot que les mencioné anteriormente, y mi programación funciona correctamente con los motores sueltos, pero al ponerlo todo junto siento como que si le falta fuerza o potencia.

Me pueden ayudar a decir cómo puedo aumentar la fuerza o potencia de un motor DC de 5v o 9v mediante ARDUINO?

Estoy además utilizando el adaptador de puentes H compatible con ARDUINO.... Espero sus respuestas y ayuda... Muchas gracias
 
Solo son motores conectados directamente o son motorreductores?

También tengo curiosidad por lo de la programación si aun planeas usar iOS, La ultima ves que intente programas para eso fue como hace 3 años, el programa iba en el simulador pero para pasarlo al teléfono de necesitaba licencia de desarrollador para desbloquearlo, creo que eran 20 o 25USD mensuales la cuota.
 
Gracias por tu respuesta @Nuyel, te comento lo estoy realizando con Android y los motores están conectados al Shield de L293 de ARDUINO y la programación utilizó la librería para este módulo L293 y luego le indicó que salidas deseo utilizar, el problema es que mueve los motores si están fuera, pero al momento de colocarlos en la base del carrito solo hacen el intento de moverse pero no mueven el carrito. Espero me comprendas, le tomare foto a la progra y a el carro para que te tomes una idea, Gracias por tu tiempo

Me he percatado que es de 12 v que debo hacer?

Aquí la programacion

Gracias por la ayuda brindada
 

Adjuntos

Última edición por un moderador:
Necesitarás un elevador de voltaje (step-up) de 5V a 12V. Mide también la intensidad que necesite para comprarlo con suficiente potencia. Otra opción es tener una batería de 12V y controlar la alimentación de los motores con transistores (pero si te da miedillo usa el elevador)
¿Para iOS no necesitas Bluetooth tipo BLE (Low Energy)?
No te sirven los modulillos HC-05/06 tan famosos para arduino...
Me interesa la programación del Bluetooth para iOS por lo que estaré al loro
 
Hola, yo estoy aprendiendo a utilizar Atmega8 + modulo bluetooth HC-06. Realice una APP sencilla y de prueba en APP INVENTOR del MIT junto con ARDUINO UNO para verificar el funcionamiento.
Te adjunto los documentos para que realices las pruebas, estan testeados fisicamente y funcionan, tambien te adjunto la programacion en bloque hecha en APP INVENTOR y el codigo fuente de ARDUINO UNO.



Codigo fuente, Arduino UNO:

PHP:
/*

  Archivo: Comunicacion Bluetooth
  Autor:   Gustavo

*/ 
 
 // Declaracion de variables
 int led13 = 13;
 int estado = 0;
 
 void setup()
 {
   // Comunicacion serial a 9600 baudios
   Serial.begin(9600);
   // PIN 13 de Arduino como salida
   pinMode(led13,OUTPUT);
   // Inicia PIN 13 apagado
   digitalWrite(led13,LOW);
   // Retardo 200ms, para que el modulo bluetooth inicie correctamente
   delay(200);
 }
 
 void loop(){
   // Almaceno dato recibido por puerto serial en la variable "estado"
   estado = Serial.read();
   
   // Comparo "estado"
   if(estado == 'a')
   {
     // Y si es igual al caracter "a", enciendo led 
     digitalWrite(led13,HIGH);
   }
   
   // Comparo "estado"
   if(estado == 'b')
   {
     // Y si es igual al caracter "b", apago led
     digitalWrite(led13,LOW);
   }
 }

Programacion en bloque APP INVENTOR:




Interfaz APP:



Espero ayude de algo, Saludos!
 
Última edición:
Much as gracias por sus respuestas y por su apoyo, les comento el problema que tengo es que tengo una plataforma deSainSmart comprada en Amazon y poseen motores de 12v de 266RPM y si conecto los motores directo a 5v o una batería de 9v, el motor se mueve junto con su cinta, pero al utilizar mi programación solo hace el intento.

No obstante si desarmo la estructura y dejó solo el motor funciona de manera adecuada, no sé qué pueda estar sucediendo, porque si el Shield De Arduino puede mover hasta motores de 24v creo , no es capaz de mover uno de 12v hay algo que no estaré haciendo?


En el Shield estoy alimentándolo con 9v y al ARDUINO con 5v, puesto que lo estaba alimentando solo con el ARDUINO y pasaba lo mismo, y pensé que eso lo solucionaría.....Ayuda porfavor!!!

 
Hola, deberías subir el diagrama esquemático incluyendo las fotos/datos de tu fuente de alimentación, ya que aunque todo pinta para una insuficiencia de energía, con esta información que nos proporcionaras podríamos ayudarte mas certeramente con respecto a la fuente de alimentación.

Saludos
 
Buenos días grupo,espero estén bien.
Escribo a ver si alguien ha tenido un problema similar, resulta que tengo un proyecto con 3 modulos Bluetooh tengo configurados dos como slave y uno como master, hasta ayer la comunicación y el proyecto funcionaba como si nada, pero ahora uno de los modulos (hc-05) como slave, no logra conectarse si quiera con el master, y solo queda el led "blinqueando" esperando conexión. he pensado en que se me debió haber dañado el modulo como tal. El problema radica en que hice un intento conectando mi celular con el modulo, y funciona perfectamente. No sé si se haya desconfigurado de alguna forma. Por los momento me estoy intentando comunicar solamente usando comandos AT con el IDE de arduino
 
Pues no tengo ni idea de la programacion de iOS. Lo que si que se es que el bluetooth esta ultra súper capado así que es posible que no se pueda.
Como el Tito Estéfano decidió que era útil y que no lo era del bluetooth...
En clase nos pasamos unos apuntes por bluetooth, TODOS hasta los que tenían teléfonos súper simples. Todos menos el que llevaba su flamante iPhone de 700€ de bluetooth capado. Después de ese episodio ya decidí que iOS iba a ser que no me compraba. Gratis tampoco.
Cierto, el BT de IPhone no siempre funciona. En algún sitio se sugiere usar Wi-Fi
G.
 
Te confirmo que hacer funcionar el BT del iPhone con este tipo de proyectos es una pesadilla, un amigo lo intentó y no lo consiguió.

Los de Apple son unos cachondos; Chiste/parodia:

-Buenos días, vengo a comprar una bicicleta
-No, no, no de ninguna manera, a usted le interesa una moto
-Ya pero yo es que soy mayor de edad y sé lo que quiero, el médico me ha recomendado hacer ejercicio y por dentro del campus de la universidad se puede ir en bici pero no en moto, vivo en un segundo y la subo por la escalera...
-De ninguna manera, ir en bicicleta es inseguro y a usted no le conviene, nosotros vendemos bicicletas pero obligamos a ponerle un motor
- [Aducción] Anda, pues es verdad que lo que quiero es una moto; si es claramente lo que necesito
------- Mensaje actualizado: -------

Buenos días grupo,espero estén bien.
Escribo a ver si alguien ha tenido un problema similar, resulta que tengo un proyecto con 3 modulos Bluetooh tengo configurados dos como slave y uno como master, hasta ayer la comunicación y el proyecto funcionaba como si nada, pero ahora uno de los modulos (hc-05) como slave, no logra conectarse si quiera con el master, y solo queda el led "blinqueando" esperando conexión. he pensado en que se me debió haber dañado el modulo como tal. El problema radica en que hice un intento conectando mi celular con el modulo, y funciona perfectamente. No sé si se haya desconfigurado de alguna forma. Por los momento me estoy intentando comunicar solamente usando comandos AT con el IDE de arduino
Por lo que comentas se ha descongigurado el HC05, o quizás se ha averiado
 
Saludos colegas, espero que esten bien; Tengo un par de dudas.

Hice un programa modificando un poco un sketch que encontre para adaptarlo a mis necesidades, pero tengo un problema que no eh resuelto.
En el sketch original se menciona que cuando yo mando un comando, el programa en arduino me debe regresar una respuesta y ademas realizar la operacion.Ejemplo.
En el sketch original menciona que al enviar el numero 1 desde el telefono hacia el arduino, el arduino debe regresarme el mensaje "Led On", cosa que no sucede.
Tambien menciona que al establecer conexion me deberia arrojar el mensaje "Send 1 to turn on the LED. Send 0 to turn Off", cosa que tampoco sucede.
Las funciones las realiza bien, con eso no tengo problema, el detalle es que si quisiera una confirmacion por parte de arduino hacia el telefono, pero la verdad no se mucho de esta plataforma, en teoria deberia suceder pues esa parte del sketch original no esta modificada, adjunto imagenes del sketch original, el modificado por mi, y de las capturas de pantalla del telefono.
 

Adjuntos

Sube el codigo en modo texto (copiar y pegar) usando las etiquetas [ CODE=cpp ] el codigo aqui [ /CODE ]
O subelo como archivo .pde o .ino comprimido en un archivo ZIP o RAR
 

Temas similares


Arriba