como saturar un transistor con una corriente exacta?

#1
Estoy haciendo un sensor de temperatura de agua, que al sumergirlo se prende solo y comienza a medir mostrando un led verde.........cuando el agua llega a 80 grados de temperatura suena una alarma y prende un led rojo.....

el problemita que tengo es que para que el sensor al sumergirlo se encienda tiene un transistor que funciona como saturado cuando el agua se interpone entre la base del mismo y una resistencia conectada a positivo....

al usar el circuito en la práctica, cualquier humedad ambiente sin sumergirlo en ningun liquido hace circuilar una pequeña corriente y el circuito funciona incorrectamente ya que el transistor no satura por completo. ademas de no cumplir el cometido de encender el circuito solamente cuando está sumergido en agua....

he probado de aumentar la resistencia pero no sensa el agua.

espero se entienda ! je je...adjunto unas imagenes del inventillo ;)

ahhh todo funciona a 4,5 volt y tengo poco lugar para meter circuitos tipo comparador...
 

Adjuntos

#2
Hola, y si alejas un poco los electrodos entre si para que no afecte la humedad, o si es que no entendí mal en la foto el sensor es la barra blanca y los dos círculos naranja que tiene en la punta son los electrodos, tendrían que estar mas alejados de la barra y aislados en los costados, ya que la humedad se deposita en la punta y te va a dar continuidad siempre. Saludos
 
#3
¿Cual es el IC y a que pin esta conectado el transistor?
Intenta colocar una resistencia entre base y emisor del transistor para reducir su sensibilidad y darle una polarización.
 
#4
Probá con una resistencia de gran valor, como 1 MOhm, entre base y masa (0V, tierra, etc)...
Y como dijeron, separá un poquito los electrodo del sensor...
 
#7
buenas ideaasssss !! ahora mismo me pongo a probar

1) resistencia, base - masa
2) zener en la base....(me imagino que ANODO para la base)

veremos los resultados....graciasss
 
Última edición:
#8
con el zener no me funciona....será que tengo un zener de 3,9volt ? y una vcc de 4.5 volt....
quedarían 0.6 volt para saturar el transistor, eso suponiendo que el agua no tiene resistencia (que no es cierto jeje) !! sera por eso ???

Otra pregunta como calculo la resistencia que va a masa ?
 
Última edición:
#10
con el zener no me funciona....será que tengo un zener de 3,9volt ? y una vcc de 4.5 volt....
quedarían 0.6 volt para saturar el transistor, eso suponiendo que el agua no tiene resistencia (que no es cierto jeje) !! sera por eso ???
prueba con un zener de menor valor
el agua si tiene resistencia
por que no mides que voltaje tiene la base en el agua
eso te dara una idea cual es el valor del zener
para probar


y si no tiennes zeners
usa diodos 1n4007 esos necesitan 0,7V para funcionar
ejemplo: 3 en serie son 2,1V

de todos modos el otro circuito del mensaje de arriba parece mas simple de hacer
 
#11
Y en vez de un trasistor NPN, ¿por qué no usas un FET?, creo que tiene mas sensibilidad...

Sino, lo que dijeron arriba, con zener, o diodos...
 
#12
GRACIAS !! ya está solucionado.
El tansistor se volvía "loco" porque le faltaba la resistencia que va de base a masa.
comprobé qie en algunos lugares andaba bien y en otros mal...supongo que donde funcionaba mal se inducían interferencias por la base.
ahora funciona a la perfeción.....ya aprendí---cuando un transistor funciona como switch, la base con una Resistencia (1/10 de la r de entrada)a masa (obiamente npn).-

agradezco tambien a "nilrebud otreboR oniduG" pero como puse en mi primer pregunta...un comparador no entraba fisicamente...solo me entraba un transistor y una o dos resistencias....

Saludos !
 
Arriba