Control MOC 3041 y triac para motor AC

#1
Buenas a toda la comunidad. Les comento lo siguiente. Antes que nada busque en el buscador y encontre post que hablaban de mi tema pero a nadie le pasaba lo que a mi me pasa.

Mi problema es simple. Por medio de un microcontrolador quiero Prender/apagar (no variar) un motor de AC, que consume 80W (tiene 3 cables, se lo conecta a un capacitor) (Este mismo fue sacado de una maquina de pan o horno de pan).

Implemente en circuito que se encuentra en el datasheet del MOC3041 sin obtener resultados. Con ese diceño el motor gira todo el tiempo sin importar si alimento el led del opto o no.

Tambien implemente el circuito que se encuentra en la pagina de pablin, el cual es el mismo que el del datasheet pero le sacan una resistencia que va conectada desde un terminal del moc a una pata del triac. En este diceño el motor no arranca, prenda o no prenda el led del moc. Solo hace el intento de comenzar a girar cuando habilito o deshabilito los 220V.

Tendran idea de que puede estar pasando? Estoy mas cerca de comprar un rele y dejarme de inchar que otra cosa pero queria que fuera una llave electronica.

Desde ya muchas gracias!!
 
#2
Tu solución se llama "red snubber", los triacs se llevan mal con las cargas inductivas.
 
#3
y como es posible que utilizando el esquema del datasheet el motor gire permanentemente? A que se debe?

Tenes algun diceño que sepas que funcione?



Bueno logre que funcione implementando el circuito que adjunto. Es diria yo, igual al de pablin pero cortando en otro lado con el opto...no entiendo porque el de pablin no me anda. En fin. Este anda y soy feliz jaja.
 

Adjuntos

Última edición:
#4
Si buscas información de las redes snubber y las cargas inductivas controladas por triacs lo entenderás. Es por no repetir otra vez lo mismo.
 

Fogonazo

Exorcista & Moderador eventual
#5
En los ejemplos del datasheet del MOC3041 siempre le colocan una red de Snubber 39Ω en serie con 10nF.

Si NO conectas la entrada del MOC a tu aplicación ¿ El motor gira ?

Caso afirmativo: TRIAC mal conectado
 
#6
En el ultimo esquema que publique (que es como esta armado ahora) funciona perfectamente. Respeta en su totalidad el funcionamiento.

El esquema que no me andubo nunca fue el del datasheet. Que tiene una resistencia de 330 entre el gate y una pata del triac. Yo sacaba el opto y el motor seguia girando. Creo que es logico, gate esta siempre activado.
 

Fogonazo

Exorcista & Moderador eventual
#7
..........El esquema que no me andubo nunca fue el del datasheet. Que tiene una resistencia de 330 entre el gate y una pata del triac. Yo sacaba el opto y el motor seguia girando. Creo que es logico, gate esta siempre activado.
¿ Este es el esquema ?

MOC3041.gif


Caso afirmativo TRIAC mal conectado, invertido A1 con A2
 
#9
Buenas tardes.
No entiendo porque en el esquema del circuito se conecta una resistencia de 330 ohmnios entre la puerta y una patilla del triac. ¿sin ella funcionaría igual? lo estoy simulando con proteus y sí que funciona.
Gracias
un saludo
 

Fogonazo

Exorcista & Moderador eventual
#10
Buenas tardes.
No entiendo porque en el esquema del circuito se conecta una resistencia de 330 ohmnios entre la puerta y una patilla del triac. ¿sin ella funcionaría igual? lo estoy simulando con proteus y sí que funciona.
Gracias
un saludo

Sip, hasta el momento en que reviente algo.

1) Mira en el datasheet del TRIAC cual es el valor de corriente máxima que se puede aplicar a GATE del TRIAC.
2) Calcula el pico de corriente de disparo del TRIAC sin esa resistencia.
3) Saca tus deducciones.
 
#11
Y veo que en la hoja de datos especifican que para cargas inductivas se reemplaza la resistencia de 39 ohm por una de 360 ohm. Yo deseo alimentar una cantonera o destrabador electromecánico que es una bobina que funciona a 110V por un periodo corto de entre 0.5 y 1.5 segundos. Yo utilizaría la resistencia de 360 ohm, porque se supone que las bobinas son cargas inductivas. Estará bien mi apreciación?
 
#12
Un error que se está arrastrando en varios post sobre triacs activados por optos es el siguiente : Se está confundiendo el A1(MTI) con el A2(MT2) , si observamos el diagrama del "conexionado" del DATASHEET del opto y lo comparamos con el de PABLIN asumiríamos que el terminal del GATE es el que está del lado del terminal MT2 y es lo contrario : El GATE está del lado de MT1 " el triac de PABLIN " está mal dibujado, pero las referencias G, MT1 y MT2 si son correctas; el diagrama del datasheet no indica los terminales yá que se "supone" que los electrónicos saben cuales son los terminales ( y me parece que se está trasladando el error de Pablin).
 
#13
No encontré el MOC3041, tengo el MOC3031 ya que utilizaré 110V, solo que no encuentro resistencias de 360 ohm, puedo utilizar de 390 ohm como reemplazo de la de 39ohm que va en serie al capacitor, ya que lo utilizaré en una bobina? hay algun problema en esto?
 

Adjuntos

Última edición:
#15
Si, la de 180 ohm y la de 1K ya las poseo, pero como necesito activar un destrabador electromagnético supongo que es una reactancia inductiva y en la hoja de datos proponen el uso de un resisitor de 360 ohm en vez de 39 ohm en serie al capacitor. Yo por mi parte poseo resistencias de 330 ohm y de 390 ohm, no de 360 ohm como se propone... cuál sería la más indicada entre las que tengo? gracias
 
#16
Muchachos???... ¿330 ohm ó 390 ohm? para reemplazar resistencia de 360 ohm que va en serie a capacitor de 0.01uF (ya que utilizaré bobina como carga para MOC3031 que trabaja a 110V).
 
#18
Como indica Scooter la red R-C dependerá de la I de la carga , dV/dt tolerable por tu triac ( en el mercado existen triacs snubberless, conocidos como alternistor) , de V de red.
La red snubber es una protección para las conmutaciones de tu triac( de On a OFF ) ,además facilita el disparo de cargas altamente inductivas( debido al retardo en el establecimiento de la I de carga) , siendo el condensador el que ayuda a "inyectar" corriente a traves de R llegando a superar la ILatching que requiere tu triac.
 

Temas similares

Arriba