controlador de motor step por medio de interruptores

#1
Hola: soy nuevo en este foro y tengo pocos conocimientos de electrónica ( espero aprender mucho aquí). Tengo un diagrama de un controlador que utiliza un pic 12c509 y un integrado uln2803, uso una fuente de alimentación de una computadora vieja con voltajes de 5 y 12 volts, y lo he probado con motores de 5 alambres. El asunto es que no ocurre nada. Quiero saber que estoy haciendo mal o que me esta faltando para hacerlo funcionar. Agradezco de antemano la ayuda que me puedan brindar.
sean felices. Saludos
 
#3
Aristides dijo:
¿Revisaste el motor PAP con una pila, para ver que funcione?
Hola Aristides: gracias por responderme. Ya he probado el motor con corriente y con voltaje de 5 y de 12 volts en sus bobinasy si trabaja en un paso. Lo he probado tamben invirtiendo las puntas y ni siquiera da un paso el motor. No se me ocurre que mas hacer. Nuevamente agradezco la ayuda. Saludos
 
#4
OK Bernardo, deberías ubicar el terminal de alimentación midiendo la resistencia, si es de 5 terminales, es el que tiene la misma resistividad, con respecto a los otros cuatro.
 
#7
Se debe tener precaución al abrir algún componente que tenga imanes, estos se pueden desimantar al sacarlo de sus piezas polares, para poder determinar donde se encuentra el problema, podrías poner algunos LEDS (con su correspondiente resistencia en serie) en el circuito.
 
#8
Hola Aristides. ya conecté los leds en las puntas de salida del uln2803 y no enciende ninguno. ¿será que el pic 12C509 o el uln 2803 no sirve?, ¿tiene algo que ver el que el pic instalado sea el 12C509A y el otro, ULN2803NP, cuando en el diagrama los integrados no tienen letras al final se su numeración?.
 
#11
Hola capitanp: Agradezco tu comentario. Me apena mi falta de conocimientos básicos en electrónica. Desconocia que el pic se tiene que programar. Si no abuso de tu gentileza, me podrías decir ¿con que y como lo programo?.
 
Arriba