Duda con un amplificador de instrumentacion

#1
Buenas a todos!

Estoy usando un amplificador de instrumentacion, concretamente el AD627An de analog devices. Y me ha surgido un problema.

Con este amplificador, del cual adjunto su data sheep, quiero amplificar una tensión, concretamente aplicarle esta transformadorrmación lineal (y=5X+2.5). El amplificador tiene una ganancia de 5.
para ello alimento el amplificador entre +2.5V y -2.5V, meto la señal de entrada entre In+ y in-, le doy la referencia a 0 (entre 2.5 y -2.5) en el pin de ref y mido la salida entre OUTPUT y -Vs, por ahora todo está perfecto y pensado que funcionaría, pero cuando pongo, por ejemplo, 0V en la entrada la medida en la salida deberia ser (enrte OUTPUT y -2.5) 2.5 y es 2.3V, comprobando pines me doy cuenta de que enter la OUTPUT y REF tengo los 0.2V de diferencia y eso me pasa en todas las medidas. po ejemplo si pongo +0.25V en la entrada, la salida que deberia tener es Y=0.24*5+2.5=3.7 y entre OUTPUT y -Vs tengo 3.02 y entre OUTPUT y ref tengo 0.54, Los valores no son los correctos

Cúal puede ser mi error, debo alimentarle a más tensión?

No puedo adjuntar el datasheep porque ocupa mucho
dejo el enlace

http://docs-europe.electrocomponents.com/webdocs/076a/0900766b8076a271.pdf



Un saludo a todos
 
#2
Hola Daoíz,

no se si será lo que está pasando pero podría ser un voltaje de offset que te aparece a la entrada el cual se amplifica por 5, el voltaje de offset es aquel presente en todo OPAMP que hace que a pesar de tener 0V a la entrada se tenga a la salida un valor ligeramente distinto al esperado. Si ese es el caso puede solucionarse con un corrector de offset (son muy sencillos) por lo general con un potenciómetro y un OPAMP como buffer tienes suficiente (lo puedes mejorar con un pequeño condensador para eliminar el rizado), no tengo ningún esquemático a la mano pero debes conseguirlos en la web.

Ojalá te ayude,

Saludos.
 
#4
Daoíz dijo:
Buenas a todos!

Estoy usando un amplificador de instrumentacion, concretamente el AD627An de analog devices. Y me ha surgido un problema.

Con este amplificador, del cual adjunto su [size=18[b]]data sheep[/b][/size], quiero amplificar una tensión, concretamente aplicarle esta transformadorrmación lineal (y=5X+2.5). El amplificador tiene una ganancia de 5.
para ello alimento el amplificador entre +2.5V y -2.5V, meto la señal de entrada entre In+ y in-, le doy la referencia a 0 (entre 2.5 y -2.5) en el pin de ref y mido la salida entre OUTPUT y -Vs, por ahora todo está perfecto y pensado que funcionaría, pero cuando pongo, por ejemplo, 0V en la entrada la medida en la salida deberia ser (enrte OUTPUT y -2.5) 2.5 y es 2.3V, comprobando pines me doy cuenta de que enter la OUTPUT y REF tengo los 0.2V de diferencia y eso me pasa en todas las medidas. po ejemplo si pongo +0.25V en la entrada, la salida que deberia tener es Y=0.24*5+2.5=3.7 y entre OUTPUT y -Vs tengo 3.02 y entre OUTPUT y ref tengo 0.54, Los valores no son los correctos

Cúal puede ser mi error, debo alimentarle a más tensión?


No puedo adjuntar el datasheep porque ocupa mucho
dejo el enlace

http://docs-europe.electrocomponents.com/webdocs/076a/0900766b8076a271.pdf



Un saludo a todos
Oye daoíz, cuando escribas, no utilices términos o palabras que no entiendes completamente. Se da el caso de que pones data sheep. El término correcto es "DATA SHEET" que traducido al español significa: "HOJA DE DATOS"; sheet = hoja o lámina y data = datos.

Sheep, cómo sustantivo se traduce cómo "OVEJA". En forma de adjetivo seria: pusilánime o papanatas. Así que podríamos entender el asunto cómo "Hoja de oveja" u "Hoja de papanatas".

En todo caso, cuidate de estos errores que, a veces, en vez de rsultar graciosos, cómo en este caso, pueden resultar grotescos.

Saludos:
 
#5
mcrven dijo:
Daoíz dijo:
Buenas a todos!

Estoy usando un amplificador de instrumentacion, concretamente el AD627An de analog devices. Y me ha surgido un problema.

Con este amplificador, del cual adjunto su [size=18[b]]data sheep[/b][/size], quiero amplificar una tensión, concretamente aplicarle esta transformadorrmación lineal (y=5X+2.5). El amplificador tiene una ganancia de 5.
para ello alimento el amplificador entre +2.5V y -2.5V, meto la señal de entrada entre In+ y in-, le doy la referencia a 0 (entre 2.5 y -2.5) en el pin de ref y mido la salida entre OUTPUT y -Vs, por ahora todo está perfecto y pensado que funcionaría, pero cuando pongo, por ejemplo, 0V en la entrada la medida en la salida deberia ser (enrte OUTPUT y -2.5) 2.5 y es 2.3V, comprobando pines me doy cuenta de que enter la OUTPUT y REF tengo los 0.2V de diferencia y eso me pasa en todas las medidas. po ejemplo si pongo +0.25V en la entrada, la salida que deberia tener es Y=0.24*5+2.5=3.7 y entre OUTPUT y -Vs tengo 3.02 y entre OUTPUT y ref tengo 0.54, Los valores no son los correctos

Cúal puede ser mi error, debo alimentarle a más tensión?


No puedo adjuntar el datasheep porque ocupa mucho
dejo el enlace

http://docs-europe.electrocomponents.com/webdocs/076a/0900766b8076a271.pdf



Un saludo a todos
Oye daoíz, cuando escribas, no utilices términos o palabras que no entiendes completamente. Se da el caso de que pones data sheep. El término correcto es "DATA SHEET" que traducido al español significa: "HOJA DE DATOS"; sheet = hoja o lámina y data = datos.

Sheep, cómo sustantivo se traduce cómo "OVEJA". En forma de adjetivo seria: pusilánime o papanatas. Así que podríamos entender el asunto cómo "Hoja de oveja" u "Hoja de papanatas".

En todo caso, cuidate de estos errores que, a veces, en vez de resultar graciosos, cómo en este caso, pueden resultar grotescos.

Saludos:
 
#7
hola

tengo problemas con la amplificacion del sensor mpxm 2102, ya que este sensor tiene una variacion en mV y no e podidor dar con un circuito que amplifique esta salida para poderla trabajar con un pic

agradezco los que me puedan colaborar
 
Arriba