Duda: Convertidor de códigos (corriente insuficiente)

#1
Hola a todos.

Este es mi primer post en la comunidad, y primeramente les agradezco, ya que he tenido muchas respuestas a mis circuitos gracias al foro.

Mi caso es el siguiente.

Tengo un convertidor de códigos usando compuertas lógicas de la familia TTL siendo de Binario a BCD, Gray y Exceso a 3, con 4 variables de entrada (0 - 15 en binario) y 16 salidas distribuidas:

- 5 para binario a BCD
- 4 para binario a código Gray
- 7 para binario a Exceso a 3 (tomando en base el BCD obviamente).



El circuito ya está armado y se usaron 11 TTL.

El detalle no está en el armado, ya que individualmente funciona perfectamente (haciendo binario a BCD, binario a Exceso a 3 y binario a Gray separado). El caso es, que al juntar los 3 convertidores en uno solo (como necesito entregarlo), los LEDs de las señales de salida ya no tienen la suficiente intensidad para encender.

Mi duda es ¿cuántos amperes requiero para satisfacer dicho circuito? ya que la fuente que uso es de 5V a 1A.

Gracias
 
#2
Tendrias que postear tu circuito... pero imagino que con la fuente que mencionas no deberias tener problema para encender los leds ya que cada led consume maximo 20mA.... y con unos 5mA ya empieza a verse bien iluminado

Otro problema es que algunas familias TTL soportan corrientes de salida de 20mA pero otras no y eso podria ser la causa del problema, puedes intentar revisando los siguientes puntos...

1.- Conecta los 3 circuitos y mide el voltaje de salida de la fuente, si por alguna razon se cae quiere decir que hay un corto, la causa mas probable es que alguna alimentacion este invertida

2.- Verifica la corriente de salida de la fuente con un amperimetro de cada circuito individual para saber si excedes la corriente de salida maxima, a ojo de buen cubero podria decir que el consumo deberia andar entre los 100 a 300mA por cada circuito con todos los leds encendidos

3.- Le estas poniendo resistencias a los leds? Verifica que todas sean del valor adecuado por que es facil confundir el codigo de colores... me ha pasado que pongo una resistencia pensando que es de 1K y resulta ser de 10 ohms o algo asi... es simple confundir un color con distintas tonalidades de luz

4.- Verifica que los switches de entrada no se cortocircuiten entre si... aveces es facil que al poner uno en cero y otro en uno se produzca un corto que haga que todo falle

5.- Revisa tus circuitos y verifica si todos son de la misma familia (LS, ALS, F etc... ) y revisa que corriente de salida puede otorgar esa familia sin echarse a perder

6.- Es posible que uses una salida de led para alimentar la entrada de otro TTL.. eso es malo y se debe evitar poniendo un buffer exclusivamente para alimentar el led de salida
 

Temas similares

Arriba