Encender led al conectar una carga a una fuente D.C

#1
Hola,

Agradecería alguna orientación sobre una idéa a la que llevo toda la semana dandole vueltas y no avanzo. El tema es simple, tengo una fuente de 12V a la que al conectarle una carga de 12V y 10, 15 o 20 A, se encienda un led y que al desconectarla se apague. La fuente tiene otras salidas: 3.3 de 5V por si es de utilidad

Lo primero que se me ocurrió fue conectar el led en serie, pero la intensidad sería demasiado grande.
He pensado en un relé, pero están pensados para lo contrario de lo que necesito: activarlo con corrientes grandes para conectar una carga pequeña.
Despues lo puse en paralelo a la fuente, y sí se enciende, pero no se apaga... :(
Se me ocurrió utilizar un transistor PnP, conectando la base en serie a la carga, y el led al colector con una resistencia y alimentado con 5V. Cuando no circula corriente está apagado, pero al conectar la carga, tengo 15 o 20 A en la base y creo que no existe un transistor que lo soporte. Además si no he entendido mal, tendría una caída de tensión de al menos 0.7v entre base y el emisor.
Podría intentar utilizar un microcontrolador, pero para algo aparentemente tan sencillo, me parece demasiado.

Cómo podeis ver, mis conocimientos de electrónica son básicamente los del instituto. Intento aprender en el proceso.
Mis cuestiones:
¿Es posible hacer lo que intento?.
¿Con qué componentes?

Gracias

Grrr, el tema está repetido... Perdón
 
#4
Gracias a los dos. Sí lo de resistencia shunt tiene buena pinta y además está explicado en otro hilo. El relé de corriente lo pensé y el sensor hall voy a buscarlo ya que no tengo ni idéa de lo que es.
 
#5
Allegro vende sensores hall ya encapsulados de todas las formas y colores.
Calibrados para medir corriente y mil aplicaciones más.

Habrá más marcas, supomgo
 

DOSMETROS

High 2m Modereitor
#7
El relé de corriente tiene usas pocas espiras de alambre grueso e iría en serie con la carga , o lo comprás hecho o modificás algún relé que tengas . . . a probar :D
 
#9
Hola de nuevo,

Al final me he decido por la resistencia shunt y el comparador. Lo he simulado y parece funcionar, pero no entiendo el voltaje de salida. Se supone que cuando la entrada inversora es mayor que la no inversora, la salida debería de ser Vcc-, y al revés debería de ser Vcc+. Pero cuando lo simulo en vez de tener 0V en el primer caso, tengo 1.198V y en el segundo 10.446 en la salida del comparador. ¿Qué estoy haciendo mal?
 

Adjuntos

Última edición:
#10
El resultado es correcto, no entiendo que esperas obtener.
Si obtienes 1.1.... en lugar de 0V es más que generoso el simulador. Porque intenta recrear lo que realmente ocurriría.
Yo honestamente utilizaría otra configuración de comparación del op-amp.
Ya que tú referencia de la entrada inversora es la tensión de fuente, y nunca será mayor que la entrada no inversora. Entonces puede suceder que según que op-amp utilices, en reposo el LED, pueda quedar encendido o no.
Así que mejor sería, que la referencia no sea la máxima tensión que entrega la fuente.
 

Dr. Zoidberg

Well-known-Papá Pitufo
#11
Por que no usas un comparador en lugar de un amplificador operacional?? Algo como el LM393, que estan preparados para trabsjar con fuente de simple polaridad y tienen salida open-collector ????
 
#12
El resultado es correcto, no entiendo que esperas obtener.
Si obtienes 1.1.... en lugar de 0V es más que generoso el simulador. Porque intenta recrear lo que realmente ocurriría.
Yo esperaba obtener 0V y 16V. Por lo que me dices, creo que esto sería en condiciones ideales y no en la práctica. ¿Esto viene especificado de alguna manera en el datasheet?. Lo he estado estudiando y la verdad es que no me entero y aunque he buscado no he encontrado nada que me lo aclare un poco.
Yo honestamente utilizaría otra configuración de comparación del op-amp.
Ya que tú referencia de la entrada inversora es la tensión de fuente, y nunca será mayor que la entrada no inversora. Entonces puede suceder que según que op-amp utilices, en reposo el LED, pueda quedar encendido o no.
Así que mejor sería, que la referencia no sea la máxima tensión que entrega la fuente.
Entiendo. ¿Pero entonces cuál?. La única forma que tengo de saber si la carga está conectada en por la caída de tensión en la resistencia shunt. Esta caída intento que seá mínima, ya que está en serie con la carga que necesita 12V. Voy a darle otra vuelta..

Hummm. Lo usé pensando que este también era un comparador.:silbando: No lo he elegido por nada en concreto. Buscando información en internet hablaban de este como un comparador común y barato, y como también aparecía en el simulador no me lo pensé ...
 

Arriba