Encender led con un boton y apagar otros con flip flop

#22
No, pues no te asegura que se apague el LED, además en el encendido del circuito lo más probable es que aparezcan encendidos más de uno y en forma aleatoria, para ello conviene realizar un auto-reset, durante el arranque.
 
#23
poniendo un diodo en la salida de R5 en la posicion correcta no solucionaria el tema?

PD:hace varios años que no le presto atencion a la electronica por eso me he olvidadO de muchas cosas XD
 
#24
Supongo que te refieres al esquema que publicó el compañero MrCarlos, siendo así, R5 es una resistencia limitadora, no cambiará el funcionamiento del sistema en absoluto cualquier modificación en esa área.
 
#25
Bueno, si no se puede conseguir el 374 por ningun lado y es carisimo, te propongo este esquema con componentes muy fáciles conseguir y muy baratos:

selector.png

Funciona de la siguiente forma, es un contador funcionando a modo de chaser, y sigue contando hasta que la salida que comunica con la patilla 13 (/enable) del contador pasa a nivel alto, donde se detiene. La salida que no tiene led es la que apaga al resto de leds... La cuenta es tan rápida que ni siquiera se notaría la transición de una conmutación de audio a otra. Se puede expandir hasta 9 salidas + off, o 10 salidas sin off.
 
Última edición:
#26
excelente, el lunes voy a ir a comprar los ic, iba a ir hoy pero me dormi XD

palurdo, gracias por el circuito pero no me funciona en el proteus y la protoboard no la encuentro, es lo unico que tengo para probar, nose si le podras pegar un vistazo
 

Adjuntos

Última edición:
#27
En este equipo no tengo programas de diseño electrónico, el circuito he pillado uno similar y lo he modificado con el paint para hacer lo que quería que hiciera. Es raro que no te tire con el proteus ya que no tiene ningún misterio. Igual lo monto mañana en protoboard si tengo un rato, pero no debe fallar. Un saludo.

Edit:

Me he instalado en un momento el LiveWire, he construido el circuito y simulandolo funciona perfectamente. Te lo subo para que le eches un vistazo. Son 10 minutos instalarse el livewire y probarlo...

Selectorsim.png
 

Adjuntos

Última edición:
#30
bueno, hoy compre todo, resulta que no tengo tension en las patas 1 y 8 del 555 y tampoco en la 8 y 16 del 4017, en primer suceso tuve un cortocircuito que recalentaba el integrado entre las patas 1 y 8 del 555 pero lo solucione, de todas formas el integrado no calento como para que se arruinara, el problema es que tomo la tension de la bateria y si tengo, me marca 3 (2 en serie) mañana voy por una de 9v aver si puede ser eso

edit, lo solucione, era una pata que no hacia contacto
 
Última edición:
#32
bueno, todo soldado pero se me mantiene siempre determinado led prendido, hago contacto con los otros y se prenden y cuando dejo de hacer contacto se apaga y el determinado siempre sigue prendido, nose que puede ser, esta todo bien conectado

edit:me guie por el circuito del livewire, los diodos van antes que los switchs en tu diagrama y en el livewire van despues, es lo mismo?
 
Última edición:
#33
pues los diodos estan simplemente para que no se queme el integrado si accidentalmente se pulsan dos botones a la vez, pero al estar en serie con los pulsadores da igual que vayan antes o despues que los switches, de hecho ni me habia dado cuenta hasta que me lo has dicho, jejeje.

Puede que el pulsador que enciende ese led que siempre se queda encendido no abra del todo el circuito al soltar y mantega a nivel bajo la entrada /enable del 4017 mientras no pulses otro boton. Intercambia los pulsadores o directamente quita el que enciende ese led a ver que pasa...
 
#35
Bueno, mañana lo montare yo en protoboard y vere que puede pasar... De todas formas si quieres suelda en paralelo al condensador del 555 un electrolitico de 47 o de 100uF para ver cómo va pasando la conmutación de los leds una a una.

Por cierto, en estado estable deberias tener Vcc en la patilla 13 del 4017. Puedes deshacer el puente que va de la 1 a la 15 y llevar la 15 (reset) a masa, de esa forma el chip no se reseteara y pasará que o bien está siempre contando o se detendrá en la salida que lleve a /enable a Vcc.

Por cierto, no se si te has fijado que las salidas numeradas 1,2,3,4... del 4017 del livewire no se corresponden con los numeros de las patas del 4017 sino con el orden en el que se activan dichas salidas. Aquí tienes el esquema interno del 4017:

 
Última edición:
#37
Pues revisa todas las conexiones bien y mide bien los voltajes porque el circuito en protoboard funciona de lujo:


Lo único que cambia es que he colocado 6 leds en lugar de 4, uso 2 diodos en lugar de 7 porque no uso interruptores sino un cable (dos cables para probar el efecto de pulsar 2 pulsadores a la vez, como veras en el video) con el que voy haciendo contacto con las salidas del integrado, y la resistencia de los leds como no tenía de 1k la he puesto de 820ohm pero eso da lo mismo. El circuito funciona igual de bien tanto con 5V como con 12V (En el video lo muestro funcionando con 5V porque con 12V los leds brillan tanto que enmascaran el circuito ante la camara del movil).

Si pulsas con 2 pulsadores a la vez se encienden todos los leds y se queda encendido el último pulsador que se haya soltado. Si llevas a masa (patilla 8 del integrado) uno de los pulsadores en lugar de a una salida del integrado, se encienden todos los leds y cuando se libera de masa o bien se quedan los leds apagados o se enciende un led cualquiera (función random, jejeje)

Revisa bien todo tu montaje porque ya has visto que es muy sencillo de montar y tendría que funcionar a la primera a menos que te hayan echado una maldición gitana...

Saludos.

Edit: Como veo que tienes zócalos en la placa, prueba a encender el circuito quitando el 4017. Si el led que siempre se queda encendido sigue encendido, eso es que tienes un cortocircuito en algun lado de la placa y te esta haciendo que funcione mal. Haz también lo que te he dicho del condensador así verás como poco a poco van conmutando las salidas hasta que se queda parada en la que tienes pulsada (si es que funciona como debería)
 
Última edición:
#39
Buenas noches.

Aunque, al parecer, ya está solucionado el problema, posteo otra forma de hacerlo.

Esta otra forma de hacerlo es por medio de Básculas realizadas con Transistores.

Son cuatro pulsadores más uno que apaga todos los Led.


Pulsadores.jpg


Sal U2
 
Y

Yetrox

#40
homerosimpson2008, veo que necesitas un circuito simple y eficiente, has preguntado también si se puede con transistores, mira yo te dejo este circuito que uso mucho, es un secuenciador de 4 canales con un solo pulsador que se puede ampliar a 10 canales, lo uso mucho para mis luces de discoteca con Triac, funciona de la siguiente manera, cada que pulsas el pulsador cambia de canal, en este caso se enciende el primero, al pulsar nuevamente este mismo se apaga el primero y se enciende el segundo y así con los demás led, ahorras mucho ya que con un solo pulsador cambias los 4 canales, en cambio con otro circuito necesitas mas pulsadores, mas componentes, Flip-Flop y circuitos Timer, este solo usa 2 IC, 1 resistencia, 1 pulsador y 4 Led que los consigues fácilmente, este circuito lo uso mucho para prender y apagar un led con un solo pulsador, también le puedes conectar otro pulsador para que la secuencia se devuelva.

La simulación esta en Proteus 7 por si no la puedes abrir te dejo el diagrama, espero que este circuito te sea de ayuda:apreton:
 

Adjuntos

Última edición:
Arriba