Falla en arduino por alta tension

Buenas noches amigos. Necesito de su ayuda. Hace rato que no puedo dar con la solucion.

El arduino cerca de mi moto falla!
Hice un contador de RPM por sensor hall... este se encarga de mover un servomotor que actua sobre una valvula. El problema es que la alta tension de la bujia me hace ruido en la entrada digital donde usa interrupciones para contar.
Probé poner todo a ground... alejarlo... el cable tiene un aislante de aluminio tambien a ground y sigue contando desde lejos jaja
Quise comprar nucleo de ferrita y no encontre ahora voy a sacar de una fuente pero no creo que funcione

20200521_184301.jpg20200521_184401.jpg
Tambien probé mallar el cable de la bujia... pero tampoco.
Hoy con lluvia parece que empeora ya que antes lo alejaba un poco y funcionaba.
Que me pueden aconsejar? Le voy a agregar velocimetro y mas cosas.
Screenshot_2020-05-21-19-10-36.png
Tambien posee un modulo bluetooth y envia la info al celu. Pero eso funciona bien
Desde ya mil gracias!!!
 

DOSMETROS

High 2m Modereitor
El aluminio del cable debería ir a masa.

Y una caja metálica conectada a masa para la plaqueta ?
 
Gracias por sus prontas respuestas. Voy a analizar lo de optoacoplar.
¿Si cambio todo por un STM32 es lo mismo?
¿El ruido es típico de arduino?
Me dijeron que no pasa eso en los PLC, pero no lo voy a usar para esto.
 
Hola, te puedo sugerir agregar un filtro pasivo RC en la alimentación tu circuito ademas agregar un capacitor de pocos pF en la salida de tu sensor.
 
Hola, te puedo sugerir agregar un filtro pasivo RC en la alimentación tu circuito ademas agregar un capacitor de pocos pF en la salida de tu sensor.
Hola gracias por tu sugerencia. La fuente es una pila. Bateria de 9v. Necesitará filtro? El capacitor a ground o en serie con la salida? Gracias!!
Hola, hay que optoacoplar la señal de entrada a ARDUINO.
Gracias por tu respuesta. El optoacoplador necesitaria otra alimentacion o podria compartir la misma bateria de 9v.?
 
Última edición:
¿Y un esquema de lo que has montado?

Yo empezaría por lo sencillo y poco a poco a lo complicado.

1° Colocar una resistencia a negativo en el pin de entrada, ¿Valor? El más bajo posible.
Miras que corriente es capaz de.manejar el sensor hall y, para no pasarte, calculas una resistencia de ½ de esa corriente.

Si eso no va, seguimos hablando
 
¿Si cambio todo por un STM32 es lo mismo?
¿El ruido es típico de arduino?
El ruido es típico del mundo en que vivís, junto con las leyes de inducción electromagnética que actúan a sus anchas cada vez que se activa la bujía.

Me dijeron que no pasa eso en los PLC, pero no lo voy a usar para esto.
Porque en un PLC las entradas no van alegremente al pin del microcontrolador sino que pasan por una pequeña protección contra sobretensiones y descargas estáticas.
 
típico de arduino
hola, explicame por que ??
arduino es un ATMEL, antes criticaban a los PIC ahora a los ATMEL ?? que son de otra tecnologia?

o te estas refiriendo mas bien a quienes usan arduino ??

<<<<<<<<<<<<<<<<<<
<<<<<<<<<<<<<<<<<<<<<<<<
nada, deja, ya lo explico bien claro EDUARDO.
 
El ruido es típico del mundo en que vivís, junto con las leyes de inducción electromagnética que actúan a sus anchas cada vez que se activa la bujía.


Porque en un PLC las entradas no van alegremente al pin del microcontrolador sino que pasan por una pequeña protección contra sobretensiones y descargas estáticas.
Entiendo... osea que el problema soy yo nomás jaja
Recien probé reemplazar el sensor por un pulsador como se ve en la foto...
Y a menos de 50cm me hace ruido al acercar la plaqueta.
Ya compre los optoacopladores pero me va a hacer la interferencia igual.
Ahora voy a probar hacerle una jaula de faraday.
Graciad a todos por sus comentarios
 

Adjuntos

Envolvi el arduino en la tela metalica de aluminio e increiblemente no hace ruido.
No se si es casualidad o que porq la tela no hace maza a nada
- Cuando el ruido es de origen electrostático el blindaje debe ser un conductor conectado a masa.
- Cuando el ruido es de origen electromagnético el blindaje debe ser en elemento ferromagnético que no necesita estar a masa , pero como normalmente es tambien conductor, se lo conecta por el ítem enterior.

- También tenés como fuente de ruido todas las corrientes inducidas en los cables por el pulso de corriente en la bujía.
 
Ese no puede ser el esquema porque no usas un contacto. ¿O si?
¿El sensor hall no tiene tres pines?

Lo primero de todo es bajar el valor de la resistencia de pullup al mínimo admisible por el "contacto", que en tu caso me imagino que es el transistor interno de tu sensor hall.


Cuando eso no funcione... Sigues probando cosas.



Antes de eso iba quitar todos los conectores y soldar soldar todas las conexiones, es es probable que las vibraciones de la moto te estén afectando.

Es un prueba y descarte y casi siempre lo más obvio es la causa del problema.
 
Ese no puede ser el esquema porque no usas un contacto. ¿O si?
¿El sensor hall no tiene tres pines?

Lo primero de todo es bajar el valor de la resistencia de pullup al mínimo admisible por el "contacto", que en tu caso me imagino que es el transistor interno de tu sensor hall.


Cuando eso no funcione... Sigues probando cosas.



Antes de eso iba quitar todos los conectores y soldar soldar todas las conexiones, es es probable que las vibraciones de la moto te estén afectando.

Es un prueba y descarte y casi siempre lo más obvio es la causa del problema.
Ese esquema que subí lo estoy probando para ver las interferencias y descartar que sea el sensor... al poner un cable en el pin digital hace de antena
Este es el esquema original...
Conclusión logre aislar el arduino con la tela metalica. Sin cables a los sensores.
Ahora me quedaria conectar los cables del sensor y que no entren en la "caja de faraday"
 

Adjuntos

- Cuando el ruido es de origen electrostático el blindaje debe ser un conductor conectado a masa.
- Cuando el ruido es de origen electromagnético el blindaje debe ser en elemento ferromagnético que no necesita estar a masa , pero como normalmente es tambien conductor, se lo conecta por el ítem enterior.

- También tenés como fuente de ruido todas las corrientes inducidas en los cables por el pulso de corriente en la bujía.
Bueno les cuento. He obtoacoplado...
El arduino dentro de la tela metalica funciona sin problemas pero cuando pongo el cable del sensor hasta el arduino empieza a fallar... con opto y todo.
Es como que el ruido aprovecha el cable y lo usa de puerta a la jaula.
No se como llevar la señal jaja
 

Adjuntos

Si optocaoplas, el optoacoplador se queda dentro del Arduino, y el otro lado se alimenta con otra fuente.
Si pones la misma fuente ahórrate el optoacoplador.
Si sigues usando la misma impedancia también te lo podrás ahorrar seguramente.
 

Temas similares


Arriba