Flowcode 4

bueno, primero gracias a todos porque hasta ahora es el primer foro que encuentro tan claro, les cuento yo estaba con niple pero me enredaba mucho y por curiosidad inicie con el flowcode, y de verdad que es mejor, no solo por los recursos sino por lo que se puede encontrar en Internet sobre el. espero poder hacer mis proyectos y si no me pues aquí estaré buscando ayuda.
 
Hola a todos los amigos del foro saludos, queria saber si alguien sabe porque cuando quiero grabar un pic 16f629 en mi grabadora me da un error y no me deja grabarlo yo tengo una grabadora k150 y el software es el microbrn con los 16 f que tienen 18 pines no tengo problemas a y algo mas hago el programa en flowcode uso el oscilador intermo y no me funcionan los tiempos me graba lento vale muchas gracias de antemano saludos.
 
Hola a todos,
quisiera saber si alguien del foro a utilizado con el flowcode el protocolo I2C. y a ver si me pueden orientar sobre este tema, quiero controlar un modulo MPU6050 con el flowcode, y este utiliza el protocolo I2C.

gracias
 
bueno señores tengo una pregunta, como se maneja el teclado matricial en flowcode, he visto ejemplos pero no me queda claro como es que sabe que tecla se pulso, esto para poder usar las demas teclas como las letras. gracias
 
Hola, estoy realizando un contador de RPM, de momento tengo una parte que cuenta los pulsos, (lo simulo con un pulsador), otra parte que cuenta las vueltas. Pero ahora me falta contar estas vueltas por unidad de tiempo, minutos, pero estoy atascado en esta tarea, no se como hacerlo, podria ser con el TMR0?
Se que el calculo es contar las vueltas que da en 10 seg, (por ejemplo) y el resultado multiplicarlo por 6 para que de las vueltas en un minuto. El problema es como cuento estos 10 seg?
Todo lo presento en un LCD, (de momento los pulsos y las vueltas, cuando sepa hacer las RPM en el LCD se presentaran las RPM

adjunto el programa realizado, no se si se podria realizar de una manera más simple
 

Adjuntos

Hola, a ver si alguien me puede ayudar.

Resulta que estoy usando el Flowcode4 para hacer una transmion TX, RX con dos 16f873, simulando en el isis. El ejercicio es encender un led mientras esta pulsado el boton del emisor.

En la simulacion del flow funcionan las dos partes perfectamente, pero al cargar el programa en el isis el receptor no enciende el led, poniendo el virtual terminal del isis se ve como emite al pulsar, pero como digo el receptor no hace su trabajo. Lo que estoy haciendo es enviar un caracter la letra "a" y recivirla con if(letra='a') cuando vea una "a" pues que encienda el led, no se que puede pasar, os dejo los archivos a ver si veis algo raro, os agradeceria mucho una ayudita.

saludos
 

Adjuntos

Empieza por conseguir la tabla de acaracteres ASCII; NO puedes enviar caracteres como cadenas, en otras palabras, no puedes enviar "a", en dado caso, lees o envias el valor en hexadecimal o decimal (de acuerdo con la tabla ASCII).

Por otro lado, el timeout NO puede ser de 1, no le estas dando tiempo a leer nada, ponlo al menos de 50.

en la decisión, no preguntes por "a", pregunta por el valor hexadecimal o decimal que le corresponde.

En ese mismo punto, el macro de led apagado NO puede estar despues del brazo de SI, ya que asi como lo estas encendiendo, al mismo tiempo lo estas apagando -NUNCA lo veras encender-

Debes meter el macro led apagado exactamente debajo de NO.

Por otro lado, no estoy seguro si es correcta tu palabra de configuración. chécala.
la velocidad en baudios debe ser igual en ambos, por ej, 9600.

En cuanto a la simulación, la terminal virtual sale sobrando.
recuerda los capacitores en los cristales.

saludos!
 
Para nada es complejo. Solo tienes que tener a la mano la tabla ASCII.
De ahi en fuera, solo recordar que string, se refiere a cadena de caracteres (palabras), y character se refiere a los dígitos (en valor hexadecimal).

En realidad, es muy sencillo.

Saludos!
 
Empieza por conseguir la tabla de acaracteres ASCII; NO puedes enviar caracteres como cadenas, en otras palabras, no puedes enviar "a", en dado caso, lees o envias el valor en hexadecimal o decimal (de acuerdo con la tabla ASCII).

Por otro lado, el timeout NO puede ser de 1, no le estas dando tiempo a leer nada, ponlo al menos de 50.

en la decisión, no preguntes por "a", pregunta por el valor hexadecimal o decimal que le corresponde.

En ese mismo punto, el macro de led apagado NO puede estar despues del brazo de SI, ya que asi como lo estas encendiendo, al mismo tiempo lo estas apagando -NUNCA lo veras encender-

Debes meter el macro led apagado exactamente debajo de NO.

Por otro lado, no estoy seguro si es correcta tu palabra de configuración. chécala.
la velocidad en baudios debe ser igual en ambos, por ej, 9600.

En cuanto a la simulación, la terminal virtual sale sobrando.
recuerda los capacitores en los cristales.

saludos!
Hola, gracias por tu tiempo, te lo agradezco:)

Acabo de probar lo que me dices, por pasos:

1- baje la tabla ascii para la letra "a" => ascii=97 hex= 61 simbolo= a

Lo siguiente fué en el emisor selecionar en la macro rs232, sendRS232Char y en los parametros nChar(INT) pusé la letra "a", despues en el receptor cambié lo que me comentaste del apagado del led y puse un if preguntando por el hex del caracter "a", es decir, if(char='61'), (char es la variable en donde se almacena lo que viene del emisor) pero no me deja poner '61' en el receptor, entonces cambié y puse "61" en el emisor y 'a' en el receptor, pero sigue sin funcionar, no se que puede pasar :confused:
 
Vamos por partes, sale?
Primero, en el codigo de envio; la palabra de configuración es correcta?, ahi no sé, solo chécalo y ten la seguridad de que lo es; la velocidad del reloj es correcta?, igual chécalo y ten la seguridad; en las propiedades del RS232, la velocidad en baudios por default esta en 9600, lo demás ni lo toques, está bien como aparece por defecto.

ahora, para darle un número hex al programa, le tienes que decir que es un hex, por lo tanto escribes 0x antes del número, en tu caso escribes 0x61 que es la letra a minúscula, ojo, que es solo minúscula, la mayúscula cambia su valor.

en nChar no va la letra a, ahí es el tiempo de espera entre pulsaciones de las teclas, (digámoslo así), coloca el numero 50.

En el receptor, al preguntar, escribes todo juntito sin espacios: char=0x61

sigue las pruebas.

saludos!
 
Vamos por partes, sale?
Primero, en el codigo de envio; la palabra de configuración es correcta?, ahi no sé, solo chécalo y ten la seguridad de que lo es; la velocidad del reloj es correcta?, igual chécalo y ten la seguridad; en las propiedades del RS232, la velocidad en baudios por default esta en 9600, lo demás ni lo toques, está bien como aparece por defecto.

ahora, para darle un número hex al programa, le tienes que decir que es un hex, por lo tanto escribes 0x antes del número, en tu caso escribes 0x61 que es la letra a minúscula, ojo, que es solo minúscula, la mayúscula cambia su valor.

en nChar no va la letra a, ahí es el tiempo de espera entre pulsaciones de las teclas, (digámoslo así), coloca el numero 50.

En el receptor, al preguntar, escribes todo juntito sin espacios: char=0x61

sigue las pruebas.

saludos!
Ya funciona, simplemente era enviar 0x61 y preguntar por 'a' :D

Ahora lo que quería hacer es aplicarle la salida TX del micro a un emisor de radio frecuencia de 434MHz con una velocidad de hasta 4800bps, y en el receptor conectar la entrada RX para que codifique la señal, lo que pasa es que no se que velocidad de baudios es correcta para este módulo y tampoco que crystal usar...gracias por la ayuda:)
 
EN la hoja de datos dice la velocidad, deben andar por lo 4.8HHz.

Por lo otro, debes ser homogeneo, si mandas 0x61, preguntas por 0x61. cuestion de orden. de no ser así, en un programa grande se te hace un chilaquil.

saludos!
 
Hola a todos,
estoy realizando un programa muy simple que con un potenciometro pueda regualar un tiempo de unos 2 seg aprox. hay una entrada de un sensor(será un interruptor),cuando esta este a nivel 1 se ha de encender un led durante el tiempo que hayamos seleccionado con el potenciometro.
el programa en flowcode funciona, pero al simularlo en proteus no regula el tiempo que esta encendido el led.
Alguien sabe que puede pasar, adjunto archivos flowcode, proteus y el hex que me da proteus

gracias
 

Adjuntos

Temas similares

Arriba