Fuente de 1kW a 20kHz

#1
Hola a todos,

La situación es la siguiente, estoy diseñando un circuito de medio puente H, y esto se conectara a un Sonotrodo, para convinar substancias, el problema que estoy teniendo, es el siguiente:

La alimentación de los mosfets es en CD y al Sonotrodo hay que alimentarlo con CA, entonces nesecitamos alimentar en la parte superior (en este ejemplo que estoy realizando, para posteriormente pasarlo ha los voltajes que necesito), con +12, y en la parte baja con -12, el problema es que el mosfet de la parte baja, no se esta habriendo, estoy utilizando el IRF540N, alguien sabe o tiene alguna idea de como puedo conectar el mosfet, para que se habra y deje fluir el voltaje hacia la carga, ya inverti el mosfet y la señal de salida del mosfet sigue siendo continua.

Adjunto el circuito general que estoy utilizando, asi como imagenes del osciloscopio y definiendo las partes del Mosfet, segun fue conectado.

No tengo idea de como hacerlo funcionar, de antemano muchas gracias
 

Adjuntos

DOSMETROS

High 2m Modereitor
#2
Esos transistores BC557 son PNP y deberían ser NPN , buscá el BC547.

Saludos !
 
#3
si miras bien y mas detenidamente tu circuito el mosfet de abajo el q8 no recive una tension entre grilla y surtidor apropiada para conmutar , Para conmutar un mosfet necesitas aplicar una tension entre grilla y surtidor mayor de 5 vdc ; no se si observas que debido a que el surtidor esta conectado a -12 vdc y tu transistor driver para Q8 esta cierra circuito por tierra , no existe una Vgs adecuada ( comparalo con el mosfet de arriba , en este caso ambos estan referenciados a tierra ) ;) ,no te dejes llevar por el osciloscopio porque el toma las mediciones respecto a tierra , en el caso de q8 necesitas medir entre grilla y surtidor ( -12Vdc) , no entre grilla y tierra

OJO si lo conectas al revez solo lograras que el diodo interno del mosfet condusca en modo directo permanentemente
saludos
 
Última edición:
#4
si miras bien y mas detenidamente tu circuito el mosfet de abajo el q8 no recive una tension entre grilla y surtidor apropiada para conmutar , Para conmutar un mosfet necesitas aplicar una tension entre grilla y surtidor mayor de 5 vdc ; no se si observas que debido a que el surtidor esta conectado a -12 vdc y tu transistor driver para Q8 esta cierra circuito por tierra , no existe una Vgs adecuada ( comparalo con el mosfet de arriba , en este caso ambos estan referenciados a tierra ) ;) ,no te dejes llevar por el osciloscopio porque el toma las mediciones respecto a tierra , en el caso de q8 necesitas medir entre grilla y surtidor ( -12Vdc) , no entre grilla y tierra

OJO si lo conectas al revez solo lograras que el diodo interno del mosfet condusca en modo directo permanentemente
saludos
jllvmicrostar muchas gracias por tu respuesta, en la imagen a parece el Vgs, es de 18.28 VCD, tiene que estar con respecto a tierra por que la señal que me interesa en la resistencia es con respecto a tierra, y los -12VCD que alimentan al S de Mosfet son para que al momento en que se habra o conmute el mosfet en la carga sean reflejados, y en conjunto con los +12 del mosfet superior me formen una señal de -12 a +12, para depues convertirla a senoidal. Bueno esa es la idea jajaja, y se me hace raro que no este habriendo o conmutando, un saludo.

Esos transistores BC557 son PNP y deberían ser NPN , buscá el BC547.

Saludos !
Y eso en que me beneficiaria al circuito:confused: , si estoy alimentando con +V en esas areas, en donde estoy introduciendo -V es en el S del Mosfet, saludos y gracias. :)
 

Adjuntos

Última edición:
#5
nuevamente , el voltaje entre G y S Vgs tiene que variar entre cero y mas de 5 Vdc ( 0 a 12V por ejemplo) em Vgs que mira q8 es el voltaje de R5 , pero R5 esta conectada contra tierra , no contra -12VDC , , tu tension Vgs en el supuesto caso que la tesion del surtidor sea 5 Vdc es de +5 -(-12) = 17 vdc, osea oscilara entr 12 y 17 , no se si me dejo entender.
busca diagramas de amplificadores de audio complementarios con mosfets y te dasras cuenta saludos
PD.. deberias usar un mosfet canal p;)
 
#6
muchas gracias jllvmicrostar, lo voy a provar y comento que sucedio, gracias por tu tiempo.

Asi fue como lo conecte, y por separado si me esta cambiando, al unir las dos partes, oscila de +12 V a -8.53V, si lo estoy conectando bien o en que esta mal?

le coloque uno de canal p y no me funcionaba, en la carga solo se veian -11.4V, conectado asi como esta
 

Adjuntos

Última edición:
#7
hola nuevamente ; lamentablemente la cosa no estan sencilla como cambiar r5 y el emisor de bc557 a -12vdc, ; como estas tratando de trabajar los dos mosfet de canal N en forma comlementaria ( es decir con fuente simetrica con tierra ) exactamente como lo hacen cualquier amplificador de audio complementario que no tenga desacoplo a la salida ----date una checada a https://www.forosdeelectronica.com/f31/amplificador-hi-fi-200w-rms-dos-mosfet-16229/ , lo que pasa es que si quieres usar 2 mosfet canal n uno siempre te quedara referido contra tierra ( el mosfet que esta trabajando en tu caso ) y el otro te quedara "flotando" con respecto a tierra y la otra alimentacion ; SOLO TE QUEDA UNA OPCION si persistes en usar dos mosfet canal N : usar un driver llamado LOW and High side driver como el ir2110 como en este caso -- https://www.forosdeelectronica.com/...-clase-d-25w-1250wrms-solo-2-mosfets-n-24854/ --auq complicarias tu diagrama.

Si quieres salir airoso facilmente de tu problema te recomiendo usar el mosfet complementario IRF9540 y rehacer la conexiones apropiadas del driver del vgs ( OJO no es igual que en el caso esl canal P , el surtidor te quedara referenciado a tierra que es lo que buscas).
busca amplificadores complementarios con mosfets y te daras cuenta.
saludos
 
#8
Otra cosa, alguna idea de por que me da solo un voltaje positivo (cuando deveria pasar a negativo), esto es de forma aleatoria, muchas gracias.

bueno creo q con lo que publicase antes has respondido a lo que puse del voltaje positivo
 

Adjuntos

Última edición:
#9
mira que recien mire que estas usando optoacopladores , sacal ventaja puesto que puedes usarlo para simular un lowside driver de esta forma :
1.- desconecta la union de r14 y q6 de pos12 y conectalos a tierra.
2--r5 y el emisor del bc557 ponlos a -12 como antes ..
3. el emisor del opto tambien a -12vdc


saludos y espero q ahora si funcione
 
Última edición:
#10
y bueno no es que me este aferrando a los de canal N, de echo entre mas sencillo mejor, por lo que deduzco seria cuestión de trabajar con un canal N en la parte superior y con un canal P en la parte inferior verdad?

Haciendo los cambios que me propones queda de la siguiente forma.

Cabe mencionar que cambiaron un poco la nomenclatura por los cambios que he estado haciendo con los transistores y demas, pero sigue siendo lo mismo.
 

Adjuntos

Última edición:
#11
y bueno no es que me este aferrando a los de canal N, de echo entre mas sencillo mejor, por lo que deduzco seria cuestión de trabajar con un canal N en la parte superior y con un canal P en la parte inferior verdad?

Haciendo los cambios que me propones queda de la siguiente forma.

Cabe mencionar que cambiaron un poco la nomenclatura por los cambios que he estado haciendo con los transistores y demas, pero sigue siendo lo mismo.
solo falta el emisor del opto a -12vdc
no lo olvides
 
#12
perdon no había cambiado el emisor del opto, también funciona, lo que he estado observando es que el voltaje me sigue llegando solo a los -8.57, voy a intentar realizarlo con el mosfet de canal p en la parte baja haber si ese detalle se corrige, alguna información que tengas para el canal p, se agradecería bastante.
 

Adjuntos

#13
bueno deberia funcionar en teoria ,:LOL: la asimetria se puede deber a varias cosas
1.- tu fuente de aliemntacion es +12 , 0V , -12 ?????, tengo esta duda porque en el circuito se ve pos 24 , pos 12 y neg 12 ( o tu fuente es + 24 , +12 , 0v y usas +12 como tierra????)
2.- porque la parte alta la alimentas con +24 , cual es el sentido , tendrias que buscar hacer ambos drivers para los mosfet lo mas identicos posible para que no haya asimetrias , osea, estas usando +24 en la parte alta y (con los cambios realizados ) usas +12 en la parte baja , deberias usar +12 en la parte alta y usar los mismos valores que en la parte inferior.
3.- que optos estas usando???? recuerda que los optos tienen un porcentaje de acoplamiento que varia segun el opto ( si estas usando optos con menos del 100% de acoplamiento de corriente ) puede que no va a funcionar bien
4.- a diferencia del canal alto que va directo al generador de funciones el canal bajo usa un inversor 7404, la de corriente de este limitada a 1 mA cuando conduce y 10 ma cuando esta en estado bajo , puede ser la poca corriente no este saturando correctamente al opto produciendo la diferencia entre canales

bien amigo , espero haber ayudado en algo
me despido por ahora a una reunion , solo quisiera que me expliques mas que hace el equipo en cuestion

saludos
 
#14
calro, mira al investigar sobre los medio punte H me tope con este blog (http://josh-disenio.blogspot.com/2010/08/medio-puente-h-con-mosfet-modular.html) en donde viene ese circuito, segun se explica ahi, "solo es para que se pueda establecer un voltaje lo suficientemente grande entre el gate y el source del mosfet superior, ya que si no ponemos esto, el mosfet superior disipará mucha potencia mas que el inferior llevandolo a su destrucción."

la aplicación es para convinar substancias, y para eso es la frecuencia y la potencia, ya seria cuestion de conectarlo a un sonotrodo, para que convierta dicha frecuencia y potencia a energia mecanica y poder convinar substancias :D
 

DOSMETROS

High 2m Modereitor
#15
Esos transistores BC557 son PNP y deberían ser NPN , buscá el BC547.
O están puestos al revés, lo vi a vuelo de pájaro y no miré el resto de la configuración.

Si vas a usar dos N hacele un bootstrap al de arriba , ahí te dejo el circuito explicado.

Bootstrapped-Mosfet.png

Saludos !
 
#16
Esos transistores BC557 son PNP y deberían ser NPN , buscá el BC547.

O están puestos al revés, lo vi a vuelo de pájaro y no miré el resto de la configuración.

Si vas a usar dos N hacele un bootstrap al de arriba , ahí te dejo el circuito explicado.

Ver el archivo adjunto 62323

Saludos !
Interesante...pero perdona la ignorancia, y bueno supongo que el PAD1 es la señal que le estoy mandando, pero esa señal me esta dando alrededor de 11.4 V y 13mv (este valor oscila mas), de igual forma lo voy a intentar, te digo como me fue, muchisimas graicas,

un Saludo tmb!!
 
#17
Probé el bootstrap y asi fue como respondio el circuito, ademas de las oscilaciones de los voltajes y de las frecuencias.

Es un retenedor del pulso para el G del mosfet, segun lo que yo veo jaja, pero que es lo que hace, o en que me beneficiaria esta circuito?. gracias por tu tiempo.
 

Adjuntos

#18
hola amigo, veo que te la complicaste otra vez; el circuito que mencionan no es ni bootstrap ni nada.

la funcion de Q3 y Q7 es la siguiente:

El circuito driver de los mosfet lo realizan los transistores pnp (Q2 y Q6) y las resistencia (r6 y R5) , de hecho la VGS es el valor de tension en r6 y R5 cuando conducen ; lamentablemente la impedancia de VGS es muy alta ya que cuando el transistor pnp q2 y q6 esta abierto , r6 y r5 tiene un valor alto de resistencia , la tension VGS tardaria un mundo para conmutar ( recuerda que estas trabajando a alta frecuencia y la capacitancia interna del mosfet actua como un capacitor almacenando tension que tiene que desaparecer rapidamente para conmutar al mosfet a estado abierto ) ya que dicha tension solo encuentra camino a tierra por la resistencia r6 o r5 el circuito no funcionaria correctamente; los pnp de la puerta de los mosfet q3 Y q7 esta PRESISAMENTE PARA ESO ( parecen estar sin sentido pero no ) cuando se polarizan en forma inversa el transistor conduce y la tension VGS remanente desaparece casi instantaneamente ya que estos los desvia a tierra

SALUDOS
 
#19
jllvmicrostar bárbaro hombre, la verdad me gustaría algún día tener todo ese conocimiento, pero bueno para eso estamos aquí, para aprender, agradezco mucho tu conocimiento, voy a realizar cambios, según se me valla ocurriendo, y te comento que sucede, un abrazo men, gracias por tu tiempo, estamos al pendiente.
 
#20
jllvmicrostar ya cheque eso que comentabas y tanto los transistores como el diodo estan haciendo bien su funcion y trabajan a esa frecuencia (incluso mayor), la duda que me sigue quedando es en la perturvación que derrepente aparece y en que en la señal de salida solo se ven -8V cuando en teoria deveria haber -12V, alguna idea de por que pueda estar pasando esto?, te lo agradesco mucho, que estes muy bien men.
 

Temas similares

Arriba