Interruptor 2 canales con mosfets en paralelo

Buenas,

Antes de nada, decir que soy autodidacta y muy novato en estos temas :)
Estoy diseñando una placa para controlar tiras led por 2 canales.
Para ello voy a usar dos GPIOs en modo PWM de unas Raspberry Pi.
He probado en una protoboard 1 solo mosfet y parece que funciona correctamente.
Las tiras led son de 24v y consumen 1.7a.
Mi idea es usar 3 mosfets IRLB8721PBF en paralelo para cada 4 tiras led.
Los mosfets van a ir todos refrigerados con un radiador único (he leído que es importante que estén a la misma temperatura).
¿Qué opináis del esquema? ¿tendrá suficiente potencia? ¿sería mejor usar un mosfet por cada led?
Por otro lado, me he planteado usar un optoacoplador para aislar la pi, pero no tengo claro si sería necesario en este caso. Además, las puertas de los mosfets (que ya los tengo comprados) necesitan de 1,35v a 2,35v y solo tendría 24v para jugar… ¿Qué opináis?

mosfet-board.jpg


Gracias.
 

Fogonazo

"Qualified exorcist approved by the Vatican"
Considerando la pobre calidad de los componentes a los que los aficionado tienen acceso MOSFET en paralelo NO siempre es "Buena idea"
Te diría que emplees un MOSFET independiente por cada tira.
Optoacoplador NO me parece necesario,

Habrá que hacer pruebas para ver si la conmutación de los MOSFET´s NO afecta el comportamiento de tus GPIOs
 
Gracias Fogonazo,

Si los mosfet son chinazos :)
El primer diseño que hice fue con mosfets para cada led. No tenia muy claro lo de ponerlos en paralelo, he leído muchos pros y contras para tomar una decisión.

En principio con las pruebas que he hecho no afecta a los GPIOs, claro que solo he probado con 1, en cuanto me lleguen los componentes que me faltan probaré con todos.

Saludos,
 
Gracias Sebsjata,

He estado haciendo pruebas hoy y la cosa es que se calentaba mucho el mosfet con un solo led. Y como has mencionado, debería de tener fuerza para mucho más, al final he encontrado el fallo, llega poco voltaje a la puerta (VGS). Ahí me pierdo un poco la verdad... con otro mosfet que tengo funciona sin problemas, ¿estarán defectuosos o no es correcta la resistencia que uso (1k)? ¿Qué voltaje me recomendáis para VGS?

Menudo cacao tengo con los mosfets...


Saludos,
 

Fogonazo

"Qualified exorcist approved by the Vatican"
Gracias Sebsjata,

He estado haciendo pruebas hoy y la cosa es que se calentaba mucho el mosfet con un solo led. Y como has mencionado, debería de tener fuerza para mucho más, al final he encontrado el fallo, llega poco voltaje a la puerta (VGS). Ahí me pierdo un poco la verdad... con otro mosfet que tengo funciona sin problemas, ¿estarán defectuosos o no es correcta la resistencia que uso (1k)? ¿Qué voltaje me recomendáis para VGS?

Menudo cacao tengo con los mosfets...


Saludos,
Tal ves necesites un circuito que amplifique la tensión de tus GPIOs
 
Gracias Sebsjata,

He estado haciendo pruebas hoy y la cosa es que se calentaba mucho el mosfet con un solo led. Y como has mencionado, debería de tener fuerza para mucho más, al final he encontrado el fallo, llega poco voltaje a la puerta (VGS). Ahí me pierdo un poco la verdad... con otro mosfet que tengo funciona sin problemas, ¿estarán defectuosos o no es correcta la resistencia que uso (1k)? ¿Qué voltaje me recomendáis para VGS?

Menudo cacao tengo con los mosfets...


Saludos,
Por eso te comenté lo del driver, lo que está pasando es que tú PI no puede hacer conmutar por completo el MOSFET haciendo que el MOSFET se caliente de más (zona lineal) además esa resistencia de 1k está muy alta para un MOSFET, usa algo como 10-100 Ohms.
Para el driver, un push pull con transistores TO-92 está bien, busca en Internet que hay bastantes ejemplos.
 
Buenas,

Al final, después de empaparme bien como funciona un mosfet (ya se que es zona lineal :)), he hecho otro diseño, a ver si os parece correcto.
He usado un optoacoplador en vez de un transistor como me propones sebsjata mas que nada porque la tenia de otro proyecto y no quería invertir la lógica.
En el divisor de voltaje (R2 y R3) he puesto resistencias de 2k2 pero no se si son correctas… ¿os parece bien? En teoría para que llegue a unos ~10v en VGS punto de saturación recomendado, el LTV-817 da como máximo 50mA.

Muchas gracias,
 

Adjuntos

  • mosfet.jpg
    mosfet.jpg
    49.2 KB · Visitas: 10
Arriba