Led parpadea al conectar a optoacoplador

pandacba

Rocker Bear
Pon fotos como se te ha pedido, no sabemos de que tipo es tu optoacoplador, algo no esta bien en la práctica porque esos son elementos muy sencillos que funcionan a la primera, muchas veces cuando se empieza del papel a la práctica se cometen pequeños errores, y todos los que intentamos ayudarte necesitamos examinar el circuito armado para ver donde está el error, aún con muchos años de práctica solemos cometer errores en el armado, y lo primero que revisamos es eso si no hay errores.
Pon algunas fotos como se ta ha pedido, a fin de examinar tu proyecto y poder darte las indicaciones necesarias, sabemos lo frustrante que es cuando uno arma algo y no sale como debiera, sobre todo en los primeros tiempos
 
hola, mira, lo primero que te recomiendo es que no te pongas nervioso.
es mas, hasta te diría que es interesante, por que estas logrando una oscilación sin usar un oscilador, es un tema para intentar descubrirlo en vez de ponerse nadie nervioso, como dije, es interesante.

Lo primero que debes hacer es probar fehaciente mente cada parte por separado:

prueba el led solo, con su resistencia.
lo habias colocado con una resistencia de alto valor ¿ y te encendia bien ??
luego prueba LA FUENTE, si, conecta 2 o 3 leds a esa fuente, para cargarla un poco mas, a ver que pasa, deberian de quedar prendidos fijos.

y recien luego conecta el opto, a ver que pasa .

la resistencia de el led de el opto, prueba a ver que pasa si la bajas, puedes bajarla hasta 100 ohms, a ver que pasa .

una pregunta: la oscilacion es continua?? estable como si fuese un oscilador de un 555 a un ritmo constante ?? o es erratica ?
 
Última edición:
asi lo tengo armado el circuito, la verdad me parece raro, no creo a ver hecho algo mal
Lo que estas usando segun tu fotografía, es un sensor de barrera infraroja o optointerruptor, un tipo de optoacoplador, pero es para detectar cuando algo cruza en medio de la barrera, no para activar algo directamente desde otro lado del circuito... y se usa la misma fuente...

En el caso de un optoacoplador, se usan fuentes separadas que no deberian mezclarse pero necesitan una de la otra para funcionar...

debes poner que funcion cumplira o que quieres hacer exactamente, asi seguimos a ciegas

mira las fotos para que te des cuenta realmente de que hablamos, no es lo mismo Patatas que Batatas...

Saludos...
 

Adjuntos

Última edición:

pandacba

Rocker Bear
Ah tuve que ampliar para darme cuenta que se trata de un optoacoplador abierto, también llamado de ranura, esos se utilizan de otra manera.

No obstante debería quedar encendido el led lo mismo,
El diodo emisor, se encuentra donde dice E terminales 1 y 2, el fototransistor se encuentra donde dice D terminales 3 y 4

E1= Anodo
E2= Cátodo

D3= Colector
D4= Emisor

De acuerdo a tu foto, esta conectado al revés, estas utilizando la salida como entrada, y la entrada como salida

Donde esta el chaflan esta el receptor(foto transistor)
H21A1.jpg
 
Última edición:
Haré cada una de las recomendaciones que me han dado, escribiré cualquier resultado al respecto y la posible solución de ser posible, muchas gracias a todos
 
Haré cada una de las recomendaciones que me han dado, escribiré cualquier resultado al respecto y la posible solución de ser posible, muchas gracias a todos
No deberia oscilar, tal vez conectas mal la parte del fototransistor, en algunos casos viene invertido...

Saludos...
 

Adjuntos

Última edición:

Temas similares


Arriba