No incia microcontrolador 16f877A

#1
Hola amigos del foro,
yo he trabajado con PIC 16f84 sin problemas, ahora intentamos hacer un proyecto con un PIC 16F877A, tengo mi codigo probado en proteus eso no es problema, estoy utilizando el compilador MikroC alli estoy configurando lo sig: LVP=off, WDT off, HS OSC= on, XT=on, asi genero el archivo .hex, lo quemo con un programador de STEREN pic-600 (siempre lo he utilizado con el otro pic) pues logico que alli solo se le indica que tipo de Pic es... todo bien sin embargo en las pruebas fisicas no corre, para confirmar si corre solo hize un programa sencillo que active una salida en cada puerto y no lo hace, pienso que algo falta en la configuracion de los fusibles, alguien tiene algun consejillo que me pueda ayudar.?? Nota: queda descartado lo del reset MCLR esta bien configurado...
Saludos..!!!
 
#3
a mi me parece raro los fuses del oscilador....
HS OSC= on, XT=on,
creo que es o HS Osc o XT

yo los pongo asi...
Código:
 XT_OSC ' utilizar oscilador externo
 WDT_Off 'watch dog off
 PWRT_On 'PWRT On
 BOD_Off 
 LVP_OFF 'Low Voltaje Program 
 WRT_OFF 'Write Off o On deperendiendo de si lo utilizas
 DEBUG_OFF ´debug off
 CPD_OFF  'Protecion de data off a tu gusto
 PROTECT_OFF' proteccion de codigo off a tu gusto
 
Última edición:
#4
Gracias amigos, les comento que estas opciones ya las había intentado, y por si se lo preguntan, ya intente con otros 2 micros 16f877 y con otro programador,,,,,, sigo pensando que algo esta mal en la configuración de los fusibles o la velocidad de 4Mhz a la que lo estoy programando....
 
#6
Muchas gracias amigos, efectivamente, le hize un circuito con una placa fenolica y soldadura quedo separado del resto del circuito, y funciono a la perfeccion!! Saludos...
 
Arriba