Placa madre Easy8051_V6

Hola ,
Compre una placa madre de Mikroelektronika para desarrollar con la familia 8051 y todo es correcto a excepcion que no me carga los programas cuando tengo insertado el micro-controlador AT89LP214 y la falla me dice, no sincroniza el micro-controlador con el Flash Program , configure un par de Fuses que me dijeron , pero sigue cargándose los micro-controlador que le pongo, adjunto una captura de pantalla con el problema , alguien conoce la solución y haya tenido el mismo problema ? Gracias por su tiempo.
 

Adjuntos

  • Captura_AT89LP214.PNG
    Captura_AT89LP214.PNG
    136.4 KB · Visitas: 22
Por lo que veo, dice claramente que no estaria detectando el dispositivo, no se si se refiere al microcontrolador o al programador (parece lo primero)
Estas seguro que colocaste bien el microcontrolador y que éste es soportado?
 
Si esta bien puesto , lo que dice es que no puede sincronizar el Program Flash con el microcontrolador, tienes tu kla misma placa ?
 
Los croatas de Mikroelektronika pasan de darme la solucion , ya queme mas de 10 micro controladores y aun no he resuelto el problema, la empresa escurre el bulto y no quieren dar informacion y me resulta muy extraño su comportamiento porque viven de vender placas y compiladores.
 

Dr. Zoidberg

Well-known-Papá Pitufo
Los croatas de Mikroelektronika pasan de darme la solucion , ya queme mas de 10 micro controladores y aun no he resuelto el problema, la empresa escurre el bulto y no quieren dar informacion y me resulta muy extraño su comportamiento porque viven de vender placas y compiladores.
Has puesto correctamente todos los jumpers según lo que especifica el manual???
 
Gracias por tu comentario , les envíe varios mensajes y son reticentes a decir cual es el problema y es algo que no comprendo , pues viven de vender placas y si no se puede cargar un programa en un controlador de que sirve la placa ? son un poco miserables en cuanto a decir la verdad, porque mensajee con ellos y no saque nada en claro y queme mas de 10 chips.
 
La verdad no entiendo como llegaste a quemar 10 chips... Eso es por mal conexion, sobretension, sobrecorriente, inversion de polaridad, etc.
Si hay un problema simplemente de programacion o fusibles, entonces es imposible quemar un chip.
 
Es casi imposible quemar microcontroladores en la actualidad y menos ese que es de memoria tipo flash y no OTP. Incluso si fue programado con el bit de protección de escritura en la memoria, con un borrado se puede volver a dejar el micro como vino de fábrica.

Puede pasar que no este bien instalados los drivers de la placa y el error es que Windows no se puede comunicar con la misma.

Con un vistazo por arriba al manual, supuestamente no hay que configurar ningún jumper. Salvo, quizá, que el puerto USB no tenga la corriente necesaria para la programación (tal vez haya mas dispositivos tomando corriente en la placa y limita la corriente disponible para programar). Igual dudo que este sea el problema. Para asegurarse se puede usar la alimentación externa y no la del USB.

También puede darse el caso de que haya un problema en la linea de USB ¿ Cable roto tal vez ?. Por lo que veo, en la placa, el chip que controla la programación tiene dos LED: "USB Link" y "Program". Verificar con ellos si hay algún error.

También puede darse el caso de que los chip sean defectuosos y se haya comprado un lote de ellos. Primero yo me aseguraría de descartar todo lo anterior.
 
Y cómo sabes que se queman y quedan inutilizables si ni siquiera puedes programar nada?
A menos que lo hayas probado en otro programador a esos microcontroladores y realmente te serciores que otros microcontroladores se programen en él.
Y si fuese asi, entonces utiliza otro programador.
No se porque le das tantas vueltas, si hay voltaje de mas, invertido o donde no corresponde, entonces tienes proboemas con la placa, multimetro en mano y medir.
Si es problema de software, fusibles, programa simple (el tipico "blink"/"hola mundo") y probar, otra no hay
 

Daniel Lopes

Miembro Geconocido
Hola a todos, o ese lote de CIs son Truxos Chinos (cosa muy conmum actualmente) , o hay algun equivoco fatidico que cuando hecho estropea los puebres CIs o falta conocimento especifico en lo tema para saper identificar lo que realmente si pasa .
Yo pararia todo proceso de trabajo cuando a lo cuarto CI estropiado y estudiaria mas detenidamente para puder identificar lo que se pasa .
Att,
Daniel Lopes.
 
En las opiniones nunca se debe de afirmar cosas sin confirmar, la placa Easy_V6 si no configuras bien los fuses , se quedan inutilizados y no pueden volver a grabarse, puedo afirmarlo porque tengo varias placas de Mikroelektronika y conozco sus puntos débiles y este es uno de ellos, pues llevo con mensajes varios meses para encontrar una solución y no acaban de dármela.
Mensaje automáticamente combinado:

Y cómo sabes que se queman y quedan inutilizables si ni siquiera puedes programar nada?
A menos que lo hayas probado en otro programador a esos microcontroladores y realmente te serciores que otros microcontroladores se programen en él.
Y si fuese asi, entonces utiliza otro programador.
No se porque le das tantas vueltas, si hay voltaje de mas, invertido o donde no corresponde, entonces tienes proboemas con la placa, multimetro en mano y medir.
Si es problema de software, fusibles, programa simple (el tipico "blink"/"hola mundo") y probar, otra no hay
Bien pues lo se fácilmente, acompaño una captura con el mensaje de que la aplicación flash program no puede sincronizar con el microcontrolador porque esta inutilizado - fuera de servicio , estoy tratando de configurar los fuses desde el compilador , siguiendo las instrucciones de Mikroelektronika y saber si están fuera de servicio permanentemente.
 
Última edición:

Daniel Lopes

Miembro Geconocido
Bueno por lo que puedo veer esa placa Easy_V6 NO es tan Easy asi , hay que estudiarla muy bien para no "quedarse con los burros en la agua" !
!Suerte!
Att,
Daniel Lopes.
 
Bien pues lo se fácilmente, acompaño una captura con el mensaje de que la aplicación flash program no puede sincronizar con el microcontrolador porque esta inutilizado - fuera de servicio , estoy tratando de configurar los fuses desde el compilador , siguiendo las instrucciones de Mikroelektronika y saber si están fuera de servicio permanentemente.

¿ Cual es la configuración de "fuses" que usas ?
 
Una consulta @juanje no has alguno de esos microcontroladores que te dan falla en la placa de Mikroelectronika de borrarlos con el Software Pony Prog y un adaptador del tipo JDM?


Saludos, JuanKa.-
 
Arriba