Problema con ruido

El foro es para cualquiera que quiera/necesite consultar algo, pero DEBE brindar información y no tener a mucha gente pensando en solucionar un problema que nace por un diseño incorrecto desde su inicio.
Si hubieras dicho que usabas un protoboard, no hubieras dejado que deliraran buscando el motivo de tu problema y ya te hubieran ayudado a diseñar un PCB que minimize los efectos...entre otras cosas.
En fin....si aparte de no dar información te sentís ofendido...ya es tu problema.
Chauuuuuuu
No me sentí ofendido para nada. Realmente no sabía que elnprotoboard podía ser un problema. De hecho todavía no se porque el peotoboard puede llegar a ser un problema. Vuelvo a repetir, estoy aprendiendo y me gusta aprender. Nunca me imaginé que hacer un circuito en una proto antes de hacer la placa podría ser ofensivo para alguien. No conozco los códigos que manejan. Por eso es que digo que si este no es un lugar para aprendices entonces pido disculpas y trataré de saca del foro lo mejor que pueda. Lo único que pretendía era entender que estoy haciendo mal y aprender. Si me pudieran ayudar a hacer un diseño de pcb que funcione y en el camino aprender estaría más que agradecido
Mensaje automáticamente combinado:

El adc lo tienes corriendo todo el tiempo? A que velocidad tienes configurado el reloj del adc?

Te sugiero hacer que el adc comience a medir al encender el mosfet con la bandera de cambio de estado del puerto de salida, esperar a que termine la conversión y así sucesivamente para que la medición sea uniforme.
Estoy investigando ese tema porque configure el reloj para el PWM pero no me fijé en el ADC. Voy a leer más del tema a ver si puedo responderte. El programa toma la lectura en dos momentos. Cuando está corriendo sin el PWM encendido ( ahí no hay problema) y cuando el PWM está encendido ( las variaciones se ven ahí)
 
Como te han dicho es probable que el fet este errático porque lo disparas con 3V3 y es de 5, además a 30kHz

Prueba a bajar la frecuencia y subir la tensión.

Lo que yo decía no era otra batería, eran dos baterías, una para la carga y otra para alimentar el μc

Si el circuito va bien cuando le pones un led de carga puede que no dispare e bien el fet o puede que la alimentación no de.

Si sigues usando los leds sin resistencia puede que su exceso en solicitar corriente desequilibre al micro.

Si sigues usando el protoboard todo M

Si sigues sin hacer caso a lo que te dicen me parece muy bien, mucha suerte, pero no preguntes.
 
Como te han dicho es probable que el fet este errático porque lo disparas con 3V3 y es de 5, además a 30kHz

Prueba a bajar la frecuencia y subir la tensión.

Lo que yo decía no era otra batería, eran dos baterías, una para la carga y otra para alimentar el μc

Si el circuito va bien cuando le pones un led de carga puede que no dispare e bien el fet o puede que la alimentación no de.

Si sigues usando los leds sin resistencia puede que su exceso en solicitar corriente desequilibre al micro.

Si sigues usando el protoboard todo M

Si sigues sin hacer caso a lo que te dicen me parece muy bien, mucha suerte, pero no preguntes.
No entiendo a qué dicen no estoy haciendo caso? El fet lo probé a 5V y a 3.3v y el resultado es el mismo.
Probé con una batería para la carga y otra fuente para el micro unidas por la masa y el resultado es el mismo.
Los leds que figuran en el diagrama no los puse en la proto, use esos pines del micro para conectarlo al serial y leer las mediciones
Use un transistor para alimentar el gate del Fer con 8v y el resultado es el mismo.

Mañana voy a hace una placa para no usar más la proto (sigo sin entender por qué esta mal usar un protoboard, creí que eran para eso)

Si alguien tiene algún consejo para hacer la placa se los agradecería
 
La placa la puedes hacer incluso en una de prototipos universal, la diferencia entre conexiones soldadas o conexiones de protoboard es muy grande.
 

Pinchavalvulas

Well-Unknown member
Buenas, como aclaración a lo que te dicen los compañeros.
Las placas de prueba o prototipos (protoboard), al igual que los zócalos para circuito integrados, pueden generar falsos contactos y capacidades perjudiciales para los microprocesadores y demás semiconductores sensibles a éstas.
Y, claro está, el mal funcionamiento del circuito en prueba.
 
Arriba