Problema Dimmer digital Motor AC

#1
Un saludo a toda la comunidad. no soy de los que escriben mucho ... pero el foro me a sacado de mas de un apuro.

Ahora tengo un problema con un motor este motor:

http://www.grainger.com/Grainger/ww...h&Ntt=4M078D&N=0&GlobalSearch=true&sst=subset

Anteriormente los controlabamos con un dimmer sencillo como este:

sin ningun problema.

Pero se nos ocurrio digitalizar y automatizar este aparato, despues de investigar un ratito llegamos a una tarjeta prototipo, con sincronizacion de cruce por cero y todo.

Ahora... el problema es que el motor trabaja bien a baja velocidad unos 5 minutos y se dispara la velocidad, como si el triac perdiera el control.
La etapa de potencia es la siguiente:


Ya hemos probado triac desde el 2N6078, un BTA8, BTA12, MAC12 y MAC15, de MOCs hemos probado el 3010 y el 3051 y 3052,
tambien con las configuraciones recomendadas para el moc 3052 que vienen en el datasheet.

Hemos estado monitorenado los pulsos del pic al moc y JAMAS se disparan, respecto a la sincronizacion.

Ojala me puedan ayudar, agradesco su atencion y ayuda.

si necesitan informacion extra con gusto se las prporcionare ...
 
#2
Te hace falta un detector de paso por cero para sincronizar el disparo del triac.
También necesitarás ajustar la red snubber a la reactancia inductiva de tu motor.

Por cierto que no va el enlace del motor y que los motores AC no se pueden controlar correctamente con ningún control de fase, necesitas un variador de frecuencia. Si tu motor es un motor universal de colector entonces si.
 
#3
No sera que tenes un triac con gate sensible, si es asi debes cambiar los valores de la red entre el moc y el triac segun la hoja de datos del MOC3021, revisala chauuuuuuuuuu
 
#4
La liga no va adjunto una imagen el motor es a 120 VAC 1.08 Amps. Scooter tendras las formulas para ajustar la red snubber?
Si tengo un circuito para sincronizar los disparos, hice prubas con un foco incandecente y va hermoso el dimmer pero al meter el motor ya no.

fdesergio es verdad, no cheque la imagen antes de adjuntarala pero los valores son 180, 2k2 y el cap es de 100n.

el motor es uno como este


Muchas gracias por la pronta respuesta y su colaboracion
 

Fogonazo

Exorcista & Moderador eventual
#5
Ese es un motor de "Polos sombreados" responde muy mal a la regulación por dimmer, o directamente no responde.

. . . .Por cierto que no va el enlace del motor y que los motores AC no se pueden controlar correctamente con ningún control de fase, necesitas un variador de frecuencia. Si tu motor es un motor universal de colector entonces si.
 
#6
Gracias fogonazo.

Para este tipo de motor me recomiendan un variador de frecuencia?
En linea y aqui en el foro e visto varios diseños.. todos son trifasicos, conoseran algun diagrama para uno monofasico?
 
#7
Por ahi lei que determinar los valores de la red snubber es algo verdaderamente complicado si se quiere hacer por un metodo matematico.

Lo malo es que no recuerdo como lo hacian o donde lo leí, pero era un metodo experimental donde se colocaba un capacitor para alta frecuencua "tipo ceramico" y luego se media el perido de la primera oscilacion, luego ese valor se escalaba por 3 para finalmente calcular la resistencia, el problema es que no recuerdo la formula, creo que era 1/(2*pi*f*c) donde f era 1/T, el T se refiere al periodo que previamente habias multiplicado por 3.

Probablemente sea problema de ruidos electricos prodicido por el motor. Esta bien filtrado el ruido en tu micro

Haaam mejor no me hagas caso, de todos modos no me acuerdo de la fuente jajaja
 
#8
Tu motor es de 120Vac y tu grafica es de 220Vac , puedes aclarar y poner todo en limpio estamos un poco cansados de hacerla de adivinos!!!
 
#12
suena interesante eso Gudino Roberto, algun diagrama.. o textos para ayudarme?
Sinceramente no tengo muy claro como controlar el variador de frecuencia
 
#13
si tenes la placa aun hace una prueba, es simple ( y si funcionaba como decias bien ) :

proba ese motor con tu dimmer digital y todo el chiche pero en paralelo al motor ponele una lampara o una resisntecia de 200w , o de ultima de 100w .

y me contas-.
 
#15
Amigo, sucede que la resistencia NO tiene comportamiento inductivo, por lo tanto no tendras analogia con el motor.
Como te comente, necesitas un puente H, alimentado con tension continua, de magnitud de valor eficaz de 120VAC utilizado en tu caso, es decir 85VDC. aprox.
Ahora bien, la funcion del PIC es la de gobernar al puente H, en cuanto a fcia. se refiere.
Recuerda tambien, de utilizar etapas optoacopladas entre el PIC y el puente en mencion.
 
Última edición:
#16
podria decir que la carga resistiva en palarelo con el motor crea una corriente espasmodica que fluctua en el campo magnetico de la sumatoria de todo el sistema, las corrientes de maxwel seguro no se ven en este sistema por que se habran ido con el en su momento , eso sin decir que si integro segun el teorema de gabi, fofo y miliki me da un resultado optimo cuando se tiende al infinito. y mis simulaciones con el "simulator NASA 300 " dieron ok .

pero no , solo dire que una vez tuve un problema similar y hice eso y funciono .
ademas, la prueba es tan simple, que el termino "probar no cuesta anda " se aplica perfectamente .
 
#18
Si el problema es que el triac no va bien por tener una carga inductiva tiene sentido que poniendo una resistencia desinductivadora funcione mejor
 
#19
claro, en su momento me dije:
si es resistiva ok :
entonces si pongo una resistiva en // con la inductiva (siendo la resistiva mas grande o sea dominante ) deberia andar bien .
y me di cuenta que No necesitaba ser mayor que la inductiva, bastante menos.
igual, claro esta , es energia desperdiciada .

pero quizas le sirva ese concepto a alguien ducho con la teoria para seguir esa linea mas seriamente y no tan empirico como el mio .

No me anime a probar poniendole un C . en // (o no recuerdo ) , por que si bien el C. compensa ciertas cosas , pero en la practica mas de una vez me dio sorpresas malas .
 
Última edición:

Temas similares

Arriba