Problemas al simular con multisim 11

#61
Que tal gente, tengo un problema, resulta que he realizado una prueba de laboratorio de una amplificador clase B, resulta que en la practica determinamos que el amplificador cortaba en baja frecuencia a 43Hz a causa del capacitor de salida, y cortaba en alta a causa del capacitor de realimentacion a 16,7Khz, el valor del capacitor de salida es de 470uf con una resistencia de salida de 8 ohms con lo que teoricamente daria una frecuencia de corte en baja de 42,3 Hz y el capacitor de realimentacion es de 500pF en paralelo con una resistencia de 18K que da teoricamente una frecuancia de corte en alta de 17,68kHz, todos los valores fueron consistentes, los de la teoria con los de la practica, pero aqui es donde viene el problema, cuando se realizo la simulacion y se grafico su bode, este no concuerda con lo esperado. La ganacia del amplificador debe ser de 19 teorica, con lo que da 25,57dB, eso en el grafico mas o menos esta bien pero no asi las frecuencias de corte, alguien sabe cual es el problema, adjunto el archivo de simulacion y unas imagenes para que vean, desde ya gracias y espero alguien me pueda brindar una respuesta favorable. saludos
 

Adjuntos

Última edición:
#62
A mí me parece que la curva está correcta. Y coincide con lo calculado. Tanto en los 42.3 Hz como los 17.68 kHz están 3 dB por debajo de la ganancia, que es lo que se define como frecuencia de corte.
 
#63
Hola estoy haciendo un pseudorandom number generator y necesito ver la salida por el osciloscopio un cierto tiempo hasta ver si se repite una forma de onda, pero cada cierto la pantalla del osciloscopio se me resetea y se vuelve a dibujar la onda.... alguien me puede decir como puedo hacer para que no se me borre???

Gracias y un saludo
 

Adjuntos

#64
hola me gustaría ayudarte. pero nos tendrías que decir con el programa que lo haces y si pudieses subir un esquema seria de gran ayuda:)
saludos :)
 
#65
Hola utilizo el multisim 11, ahora mismo tengo 7 FF y es facil ver que efectivamente se repite la secuencia porque no tarda mucho, pero cuandos mas FF tarda mas en repetirse y al final llega un momento que el osciloscopio que las formas de la salida del oscilocopio se me borran y no puedo verficar
 

Adjuntos

#67
Es porque tengo que añadir mas FF con mas salidas 127 bits, 267, 522.... Si error no hay, funiona bien, el problema es el oscilador...supongo que sera alguna cuestion de memoria, pero no se como cambiar
 
#68
En la simulacion aqui como vemos que el circuito es un buck converter es decir el voltaje de salida es menor al voltaje de entrada
En el circuito tenemos condensadores transistor de conmutacion irf9540 diodo mur de alta velocidad bobina de 200H un capacitor final de 50 uF y la carga
Estoy simulando con una frecuencia de 50 KHertz
vemos que el factor de trabajo duty cycle es de 12% por tanto el tiempo de encendido sera de 2us
el voltaje de la carga es para este caso es de 11.852
pero cuando vario el factor de trabajo se supone el voltaje debe variar pero esto no sucede
espero sus comentarios gracias.
 

Adjuntos

#71
Si ponés la entrada del osciloscopio a la compuerta del transistor, vas a ver que no hay pulsos. Esto se debe a que el 7406 a la salida tiene un transistor que conmuta a tierra solamente (esto se llama colector abierto). La resistencia pull-up es la que alimenta ese transistor para que cuando esté abierto, haya tensión a la salida. Debe ir entre el positivo y la salida del 7406 (o la compuerta del FET).
Te recomiendo que bajes las hojas de datos de los componentes que usás, así ves como se deben implementar.
 
#72
Hermano sos un erudito en esto la simulacion salio de maravilla. Porfavor si podes sube el archivo de una simulacion des este circuito modificado.



Pibe el problema continua se supone que al ir variando el duty cycle debe variar el voltaje de salida pero siempre sale lo mismo
 
Última edición:
#73
Gracias por lo de pibe. Ahora revisá si a la salida del MOSFET realmente hay conmutación. Probablemente veas que no. La tensión de la compuerta debe ir del valor de la alimentación a 0 volts, si no llega al valor de la alimentación en el pico "alto", el transistor siempre conduce.
 
#75
Estás usando un MOSFET canal P. Ese transistor conduce cuando la tensión de la compuerta (gate) es menor que la de la fuente (source). Como la fuente (source) está conectada directamente a la alimentación, para que no conduzca, la compuerta debe tener la misma tensión que la fuente (source), o sea, la misma tensión que la alimentación.
 
#76
Hola resulta que encontre un circuito de 100w que es igual a este

Entonces lo quise simular con multisim y me da 0w de salida, nose que estare haciendo mal, recien me estoy iniciando en electronica y quiero hacer algo acercandose a mi propio circuito aunque este es copiado, abajo les dejo la simulacion, saludos gente, agradeceria su ayuda :)
 

Adjuntos

DOSMETROS

High 2m Modereitor
#77
Pusiste una resistencia de 8 Ohms como parlante ?

Le conectaste el Watímetro , el Amperímetro en serie y el Voltímetro en paralelo ?

Conectaste un generador de funciones senoidal , unos 400 mV ?
 

DOSMETROS

High 2m Modereitor
#79
El Wattimetro tiene 4 conecciones , dos Amperométricas que van en serie con la resistencia-parlante y dos Voltimétricas que van en paralelo.

Tengo el Multisim 11 y no puedo verlo
 
Arriba