Problemas con CD4052 en selector de audio

que tal muchachos. este es mi primer tema en el foro.

me encamine en fabricar un selector de fuentes de audio con un CD4052 y me aparecieron varios inconvenientes.

primeramente conecte VDD a 12v y VSS y VEE a GND. cuando se encontraba alguna de sos llaves conmutadas el sonido pasaba perfecto, pero al abrirse el swich quedaba pasando sonido a menos volumen y distorcionado. luego de investigar en circuitos de equipos que trabajan con este integrado, di con el circuito de un aiwa nsx330 que trabaja con 12v en VDD, GND en VSS y -2,7v en VEE. con esta configuración al abrir la llave desapareció la distorcion y casi por completo la señal de audio, pero al subir el volumen del amplificador por mas de la mitad se sigue escuchando como pasa sonido... mas agudo de lo normal pero pasa. probe variando los voltajes sin superar los 18vpp.

conocen algún secreto para subsanar este inconveniente? me estoy pasando algo por alto?

coloque resistencias en serie. atenue la señal también. y de todas maneras siempre queda pasando sonido. necesito grabar de estas fuentes de sonido y no puedo permitirme dejar pasar sonido a bajo nivel porque seria muy perjudicial.

saludos y muchas gracias!
 
Hola, quizás en lugar de añadir una resistencia serie, deberías conectar una resistencia a pull-down en la salida del selector.
Corrobora que VEE sea únicamente de -2.7V o pueda ser menor.
 
Hola, quizás en lugar de añadir una resistencia serie, deberías conectar una resistencia a pull-down en la salida del selector.
Corrobora que VEE sea únicamente de -2.7V o pueda ser menor.
que tal amigo. lo he hecho sin resultados. solo con una resistencia de 1k me quito el resto de sonido, pero también me quita mucha señal de audio.
 
Cómo accionas la llave? Tipo de señal?
La señal de control tiene que tener una lógica definida, 0V o 12V., no debe quedar en alta impedancia.
Prueba con otro CI, sino añade un op-amps a la salida con la ganancia compensadora que veas necesaria.
 
Última edición:

pandacba

Rocker Bear
Tampoco sabemos con que niveles de tensión en la señal estas trabajando, brinda toda la información, lo que tu hiciste esta delante tuyo, en tus esquemas y demás, aqui no tenemos nada.....
 

Daniel Lopes

Miembro Geconocido
Hola a todos , coincido plenamente con Don Fogo , sin lo diagrama esquemactico de que fue armado es casi inpossible opinar sobre lo tema.
Att,
Daniel Lopes.
 

Fogonazo

"Qualified exorcist approved by the Vatican"
Polariza las entradas a Vcc/2 mediante 2 resistencias de por ejemplo de 100 KΩ
 
básicamente ese fue el circuito que use. es un integrado que no lleva electrónica asociada, solo alimentación y conexiones de control y entrada y salida. las modificaciones que le hice y dio mejoras, fue poner la tensión de VEE a -5v. con esto se quito la distorcion. la señal a conmutar es de 1v proveniente de un cd player, que es con la que estoy realizando las pruebas.
Polariza las entradas a Vcc/2 mediante 2 resistencias de por ejemplo de 100 KΩ
si, le he hecho justamente con resistencias de 100k para lograr pones las entradas a 2,5v y no obtuve resultados. lo único beneficioso fue poner el pin VEE a un voltaje negativo superior a 1,5v. desde -1,5 a -9v que probe no hay diferencias.

lo único que sirvió fue atenuar el nivel de entrada con un divisor resistivo, pero quita demaciada señal quedando a un nivel poco aceptable.

he experimentado con el 4066 obteniendo resultados parecidos. siempre me queda un pequeño pasaje de audio.
 
Última edición:

Fogonazo

"Qualified exorcist approved by the Vatican"
Para que los conmutadores trabajen correctamente con señales analógicas, esta se debe "Montar" sobre una polarización continua.
Para aumentar el rango dinámico puedes aumentar la tensión de alimentación, si no mal recuerdo hasta unos 18V, lo que te permite manejar señales de ese valor de pico, incluso algo mas.

Publica un dibujo/esquema de lo que armaste y no te funcionó correctamente.
 

pandacba

Rocker Bear
Tuviste que ponr Vee a -5V por lo que te comento fogonazo de polarizar la entrada y alimenta el CI con al menos 15V y si no utiliza circuitos que vienen ya diseñados para cumplir esa función y tienen un mejor desempeño.
Como ejemplo tenes el TDA1028 y TDA1029, TDA7313, PT2313, PT2314 y muchos más
 
sugerí ese sin saber si aun estaba vigente lo conocí mientras reparaba un soundtrack con la ayuda del foro lo busque en la tienda de electrónica y por suerte encontré 1,lo probé en el amplificador y funciono,yo aun estoy en pruebas pero espero dure bastante ya que no e vuelto a encontrar otro y lo usare con un triamplificado que lleva 5 años en desarrollo ya casi esta listo para mis nietos:p
 

pandacba

Rocker Bear
No tan nuevos, quizas si hoy más conocidos, pero hay productos mencionado que tienen una antigüedad de entre más de 20 años y más de 30 años.
Para las necesidades habituales alcanzaban con los clásicos C-Mos pero el echo de manejar mayores valores de tensión aquellos que solucionaban el problema ya no lo hacen entonces se debe echar mano a aquellos circuitos más elaborados y de diseño específico
Por ejemplo los de Sanyo LC7818 ya mencionado y los 7815, 7821,7822,7823 y otros que ya estan discontinuados tienen aún mucho más años en el mercado.
De echo había muchos más CI´s especializados que lo que ofrecian los C-MOS y más adecuados
Los hay de toshiba como el TC9162/3/4 de alto voltaje()+-15V, una amplia línea de Maxim, tambien de BB entre otros
 

Temas similares


Arriba