Problemas con LCD en pic 16F877A en CCS

#1
Saludos! les queria pregruntar si alguien fuera capaz de darme ayuda.

el problema es el siguiente. tengo un pic 16f877A, el cual transforma los datos analogos a digitales de unos sensores hall, 4 en total. y luego por medio del programa calcula la orientacion geografica (norte, sur ,etc). Esto se visualiza en un lcd, o deberia mejor dicho, ya que solo se ve una linea de cuadros negra, tambien conecte el potenciometro para el contraste y puedo variar el contraste, pero nada del mensaje que quiero, solo la linea de cuadros. La verdad este es mi primer programa q hago y me ha dado bastantes dolores de cabeza ya que no hay caso que pueda inicializar bien el LCD. en proteus funciona perfecto pero en la practica no hay caso.

Se les ocurre que podría ser?? alguna ayuda comentario es bienvenido.

Les adijunto la imagen en proteus, y el codigo en ccs.
 

Adjuntos

#5
Hola felipegm88:
Si en Proteus funciona, debería estar funcionando en el prototipo.

cuando la primera línea del lcd aparece completamente llena de cuadraditos negros puede deberse a que el PIC no se grabó correctamente o no está fijado a la placa correctamente.

si quitas el Pic de la placa y enciendes el sistema hará lo mismo probablemente
ya nos contarás.
Saludos.
 
#6
En el código debes indicar o bien definir en que puerto vas a conectar el LCD según la librería LCD.C: deberías definirla de manera similar a esto "#define use_portb_lcd TRUE" en caso de conectar el LCD en el puerto B
 

Temas similares

Arriba