Programador de PICs (Solo Enigma)

En el MPLAB sale El pickit 2 en amarillo con ese PIC, no sé que significa, quizás lo grabe, pero no es seguro.

Saludos.
 
Ya que los PIC24 son relativamente nuevos las opciones de programadores no son muy amplificadoras, pero creo que el PICkit 2 es más conveniente, ya que, este posee debugger/programmer en el circuito y es un poco más economico.

Gracias Doniga y picrocker!
 
Hola Moyano Jonathan!

El clon del PICkit2 que posteaste no trabaja para dispositivos con alimentación de 3.3V. Mi inquietud es si, simplemente colocando una alimentación independiente de 3.3V al PIC a programar funcione.

Gracias!
 
Realmente no se, si colocandole alimentacion externa funcione con micros de 3.3v pienso que añadiendole un regulador de voltaje a 3.3v pueda llegar a funcionar , el tema es que tendriamos que sacar una linea de control del micro para que maneje la señal de programacion para 3.3v

espero que te sirva
 
fryck_80 dijo:
hola a todos porfavor eclipce ¿puedes agregar el micro 18f452 a tu sofware es que lo necesito? gracias a todos por la colaboracion
anexo el el archivo que diseño ANDRES D con una pequeña modificacion y la base sip como respuesta a la pregunta de DJ DRACO ya lo prove y me funciono muy bien

ola ....ya arme el diseño reducido pero dime algo en el zocalo zif no existe problemas cuando los pines que no se usan para la grabacion de los pic estan conectados a masa o vdd bueno lo del VPP lo comprendo por k es una tension alta .....otra cosa mas para que sirven j2 y j3 podrias detallar porfavor
 
Por lo que veo no hay en el foro ningún proyecto de armar un ICD2.
Es más, veo que existe la idea que se trata de algo que requiere inevitablemente
montaje superficial.
Yo tengo un proyecto bajado de la red donde se trabaja con componentes normales.
Usa un par de pics (16F877A y 18F4550) y algunos transistores.
Solo estoy teniendo unos problemitas de la comunicación USB con el MPLAB que
espero resolver pronto.
Saludos

Editado: era 18F4550 no 2550
 
La máquina es una dual core, comprada en marzo de este año. (Cansado de renegar rompí el chanchito). Memoria = 2GB de 200 MHz. Reloj = 2GHz. Y todavía con Win-XP, por desgracia.
El error lo tira al final del seteo del MPLAB para que use ICD2 como programador.
Según figura.

Prueba 1:
El error "dominante" es el primero, ICD0019. El otro (ICD0021) me manda al error anterior.
Haciendo doble click sobre el numero ICD0019 me lleva al ayuda, donde dice:
ICD0019: Communications: Failed to open port: (Windows::GetLastError() = WindowsErrorNum, 'WindowsErrorString')

Description: MPLAB ICD 2 failed to open the specified communications port. The windows error number and string are given for user reference.

Suggested Actions: See General Communication Error Actions

If the windows error is either "resource in use", "connection failure" or "access denied" it is possible that the port is already in use by another application. Ensure that this is not the case. If an application has failed to release the port on exit, a reboot should free the port for subsequent use.
Por las dudas desconecté otros dispositivos USB para no tener problemas de ancho de banda.
Y paso a rebootear ... por las dudas, porque el mensaje es:
"El sistema no puede hallar el archivo especificado" Qué archivo? Quién lo sabrá !

Prueba 2: Aparentemente debe haber algún problema de hardware, porque muevo un poco el conector de USB en la placa y WinXP detecta el dispositivo USB, incluso recién se rebuteó sola la máquina. Algo anda mal que no anda bien!

Prueba final: Repitiendo el procedimiento con el cable desconectado sale el mismo error.
No debe estar detectando correctamente el programador por algún falso contacto o algo parecido. Revisaré el hardware y les cuento.

Una vista del lado componentes de la placa está ACÁ
y la vista del lado soldaduras está ACÁ
 

Adjuntos

Como andás alegandro, mirá es muy posible que sea como vos decis , el problema puede llegar a estar en el cable USB, como en el conector. Tambíen se me ocurre que estés utilizando un driver y firmware de los pics a lo que a su vez puede dar un posible error de incompatibilidad con el hardware. Las placas se ven bien , las soldaduras las tendrías que revisar para descartar fallas por ese lado.

espero que te sirva. :)

pd: Con que programador programaste el PIC18F4550?
 
Creo que con un picstartplus.
Eso lo hizo un amigo cuando yo todavía no había actualizado el mío.
Se hicieron tres placas y todas han dado este tipo de falla.
Los hex son los bajados del sitio que señalaste.
Viene medio encriptada la cosa.
Este fin de semana veré si le doy una mirada a todo de nuevo.

Saludos.
 
Hola, les comento que he estado haciendo pruebas con un pic18f4550 y he notado que programa bien el hex que le cargo pero despues programa basura en direcciones aleatorias por lo que los programas corren bien en algunas ocasiones y en otras no.
Ojala se pueda corregir este error. Tambien me gustaria saber si eclipse aun seguira dando mantenimiento a este programador o si ya lo dejo por la paz, lo anterior lo comento por que ya no lo he visto por el foro.
Agradeceria que alguien me informaciónrmara si le sucede lo mismo con este pic.
Gracias ojala se pueda seguir mejorando el programador.
 
hola,
hace un par de dias construi el programador (version reducida), lo conecte al pc y fue detectado correctamente.
haciendo algunas pruebas obtube los siguientes errores:
1- colocando el jumper para alimentear el vdd del pic(a programar) desde vcc(usb) funciono correctamente.pero al conectar el jumper para que utilice el vdd controlado por el 18f2550 (pin 17 y 2n3906) no funciona la programacion. Durante la programacion(y cunado no se esta programnado) no tengo voltaje de vdd en ningun momento. esto ultimo lo verifique con voltimetro y osciloscopio, sin embargo al entrar a la utilidad "pruebas del hardware" aparece voltaje (5v) y si marco la cajita VDD el mismo desaparece. Al salir de la utilidad el voltaje vdd desaparece nuevamnete.

2- si utilizo la herramienta "identificar dispositivo" luego de darle ok aparce el siguiente error

"eclipse. exe ha generado un errores será y cerrado por windows"

no se si a alguien mas le dio estos errores o si tienen idea que puede ser.
 

Adjuntos

Efectivamente a mi ocurrio lo mismo con la version completa por lo que tengo que alimentar al pic directamente del usb. Tambien ocurrio el mismo error cuando puse identificar dispositivo, pero solo la primera vez que lo use, ya despues funciono correctamente.
La verdad no se a que se deba el error, eso tendria que explicarnoslo eclipse.
Gracias.
 
puma_oro dijo:
Hola, les comento que he estado haciendo pruebas con un pic18f4550 y he notado que programa bien el hex que le cargo pero despues programa basura en direcciones aleatorias por lo que los programas corren bien en algunas ocasiones y en otras no.
Ojala se pueda corregir este error. Tambien me gustaria saber si eclipse aun seguira dando mantenimiento a este programador o si ya lo dejo por la paz, lo anterior lo comento por que ya no lo he visto por el foro.
Agradeceria que alguien me informaciónrmara si le sucede lo mismo con este pic.
Gracias ojala se pueda seguir mejorando el programador.
a mi tambien me paso lo mismo todo corre hasta que cargo el hex pero cuando programo y luego leo el pic veo que hay partes del hex que faltan y en su lugar hay 000 000 000 esto esta en manera aleatoria igual que tu caso espero que eclipse pueda ayudarnos.................
 
Hola a todos,

Les cuento que yo hice mi propio circuito en eagle y me resultó perfecto, el único error que tenía es que el conector USB tipo B lo conecté al revés.

Hace un tiempo subí ese archivo en eagle, así que búsquenlo por ahí por la página 55. Quedé en arreglar ese error, pero no he tenido tiempo para dedicarle.

Si alguien lo puede hacer por mi, sería genial porque así tendríamos una versión que seguro funciona. Yo hice todo tipo de pruebas y ha respondido impecable.

Saludos.
 
Hola doniga, el problema que comentamos no es con el circuito ya que yo tome el PCB hecho en protel y de ahi lo imprimi y funciona correctamente. El problema es con la programacion del pic18f4550 ya que escribe bien el archivo .hex que le queremos cargar pero tambien escribe basura en direcciones aleatorias por lo que hay ocasiones en que el programa no funciona bien o hace cosas raras y hay que estarlo grabando varias veces hasta que lo programa bien.
Yo creo que eclipse podria ayudarnos en eso ya que en paginas anteriores lei que pasaba lo mismo con el pic18f2550 y esclipse lo corrigo, pero hace mucho tiempo que no veo a eclipse por aquie entonces no se si seguira dandole mantenimiento al programador.
 

Temas similares

Arriba