Programador de PICs (Solo Enigma)

crrcjob, como estás

Mirá el programador eclipse es un proyecto que no se actualizó más y tiene muchos bugs. Te recomiendo ampliamente que armes alguno de los clones del pickit2 que se encuentran en el foro.
 
Moyano Jonathan porfin posteaste tu version del clon del pickit2 o es la misma de felixls... o donde esta posteada...
 
LING dijo:
Exelente aporte felix esta de arranque ...
una pregunta que de Version tiene que ser el mplab para el debug y como se consigue la palca header boart
para esta funcion debug

graciass att
Uso la versión 8.20, pero nunca probé el debug por ahora, pero imagino igualmente que se necesitaría una placa ICD para hacerlo.
 
buenas me gusto mucho el programador de eclipse y me preguntaba si al final esta funcionando?. yo solo lo necesito para programar la familia de los pics. el circuito este q adjunto esta listo para cargar el programa del pic y funcionar?. me confundi un poco si esta version anda o no disculpen si no entendi.
y si me pueden decir q placa aparte deberia diseñar para poner un zocalo zif para cualquier pic. ¿esta placa deberia ir conectada a icsp cierto? que diseño deberia usar

espero q me ayuden

muchas gracias!
 

Adjuntos

ok me parece bien. me podrias hacer un favor? podrias subir todo lo necesario para el pickit? yo encontre varias cosas pero tienen muchas modificaciones. yo solo lo quiero para los pics.

si sos tan amable jaja.....

muchas gracias!
 
Hola Eclipse, genial tu programador, basandome en los posts aqui presentes me anime a armarlo, y las primeras pruebas del hardware son exitosas, lo quiero poner a funcionar de inmediato, pero el curso de DSP que recibo pide que use los dsPIC 30f3014 y 30f4013, los cuales aun no estan en las librerias, me gustaria saber si los puedes agregar.
Mil gracias
 
Muchas Gracias, no lo habia visto por que estaba algo engomado con el programador de Eclipse, me parece muy versatil para mis estudios, voy a montar este entonces ya que usa las librerias que necesito
 
Hola , necesito comprobar el hard de mi programador eclipse.
Co el programa logro encender y apagar los tres leds pero solo obtengo voltages en el icsp de 5v.
en ningun momento de 13v.
Ya se que este programador esta obsoleto gracias al pickit2 ,pero lo he hecho para programar el atmega de arduino.
Gracias por todo y seguir adelante con los proyectos.
Por cierto creo que mi problema puede estar en los transistores ya que me dieron equivalentes y no se si el patillaje correspondera con los originales.
 
Hola Moyano gracias por contestar.
Pues nada que arme el eclipse version reducida y compre los componentes de la primera version y me falto algun componente ya que no son los mismos. Volvi a comprar los componentes que me faltaban y vi que los transistores eran equivalentes. He mirado el patillaje en un software de transistores y resulta que no corresponde con el dibujo de la placa en cuanto a orientacion, quizas pueda ser eso.
me refiero a los transistores 2N3904 , me dieron los BC546 y veo que no corresponden con las el orden de las patillas. Ya me direis algo antes de que me ponga a desoldar esos transistores.
Gracias de nuevo y una pregunta.
Se podra algun dia programar ATMEGA con el pickit2?
 
Los BC546, no funcionan con ese programador tienen que ser los 2n3904. ATMEGA se podría programar pero alguien se tendría que encargar de modificar el firmware original del pickit2
 
hola de nuevo.
Segun un link que encontre de equivalencias, los bc174 bc182 bc190 y bc546 son equivalentes al 2n3904 a ver si me lo podeis confirmar ya que el 2n3904 no lo encuentro.
 

Temas similares

Arriba