Proyecto de un Decodificador

#1
Hola a todos.... Espero se encuentren muy bien..
Soy nuevo en esto y Estoy realizando un proyecto de un decodificador y quiero que me funcione ya tengo semanas dandole y dandole y nada...lo estoy simulando en circuit maker 2000... el problema es qUE no logro qUE funcione... si me pueden ayudar se los agradeceria alli le dejos los archivos ajuntos del programa...

Por favor hechenle un vistaso........... se los agradeceria mucho...
 

Adjuntos

Última edición por un moderador:
#2
Hola jhonnysystem

Notaste que los segmentos que deben encender permanecen apagados y viceversa?

Para corregir eso Utiliza NOR en Lugar De OR. Ó probablemente un Display de cátodo común.

Las letras de identificación en los conmutadores están al revez, tienes “A, B, C, D” pero debe ser “D, C, B, A”
Esto lo deberías cambiar pues, aunque esto es convencional, para entendernos llevan un orden y un valor.
D=8, C=4, B=2, A=1, como lo tienes, cuando cambio el interruptor “A” Prendería el 8 en lugar del Número 1.

Al cambiar los interruptores C y B aparece el 6 Pero invertido, girado horizontalmente.

¡ Ya casi, ya casi ¡...Adelante.

saludos
a sus ordenes
PD: Di nó al lenguaje SMS
 
Última edición:
#3
Hola MrCarlos oye Gracias por responder....

bueno hice lo me me dijiste y aun no me funciona, incluso me sale esto

Warning: singular matrix: check nodes v1#branch and v1#branch

Note: starting Gmin stepping
Warning: Gmin step failed
Warning: Gmin stepping failed
Note: starting source stepping
Warning: source stepping failed
doAnalyses: Matrix is singular

run simulation(s) aborted
Circuit: *Spice netlist for Circuit: C:\CM60S\CIRCUITS\UNTITLED.CKT
Date: Sun Jan 31 01:07:54 2010


Total elapsed time: 0.046 seconds.


el problema es eso y no prende ningún segmento....

no se pero e llegado a pensar que el circuit maker que tengo esta incompleto...
le e preguntado a 2 profesores uno me dice q hay q programarlo con assembler y el otro me dice q no me meta con eso...

me dijiste que lo probaste, y prenden como no deben ser pero usaste circuit maker?, pero a mi ni eso....

No hay un link donde pueda descargar el software completo?.. o que software usaste vos?....
 
#4
jhony aqui esta tu circuito con unas correcciones:
1. parece que lo simulabas como circuito analogo.
2. utilizabas el display equivocado.
3. ingresabas 5v en los interruptores.
4. el programa no acepta las resistencias de los leds( claro que en la realidad si debes ponerlas).

te queda de tarea corregir el problema de que el 6 sale invertido, los demas numeros si estan bien. felicitaciones y sigue adelante.:)
 

Adjuntos

#5
Mil Gracias roberto... ya estaba desilusionado porque no me funcionaba gracias por el apollo a MrCarlos y a ti mil gracias... voy a corregir eso... y pasare al mi otro proyecto de un contador...
 

Temas similares

Arriba