Tacómetro digital + Shift Light + Limitador de RPM + Pcbs

Jeje si, es un capacitor de bastante tensión, pero ahí van 47[nF] un simple disco cerámico de 50[V] era suficiente.

Respecto al pin 9, ezavalla ya que estás por acá tal vez puedas iluminarnos... tenés idea de cómo podría solucionarse? Colocar una resistencia en paralelo al led correspondiente a dicho pin podría servir? Para semana santa me vuelvo a mi ciudad, si puedo hago pruebas con ese pin ya que no me había sucedido como había comentado antes...
La cuestión es que al parecer, usando ese led como disparador, activa inmediatamente el pnp asociado, encendiendo el shift o activando el relay según sea.

Saludos
 
Última edición:

Dr. Zoidberg

Well-known-Papá Pitufo
Respecto al pin 9, ezavalla ya que estás por acá tal vez puedas iluminarnos... tenés idea de cómo podría solucionarse? Colocar una resistencia en paralelo al led correspondiente a dicho pin podría servir? Para semana santa me vuelvo a mi ciudad, si puedo hago pruebas con ese pin ya que no me había sucedido como había comentado antes...
La cuestión es que al parecer, usando ese led como disparador, activa inmediatamente el pnp asociado, encendiendo el shift o activando el relay según sea.
Es que el pin 9 es el pin de MODO, no un pin de un LED. Que es lo que están conectando ahí?
El pin 9 está polarizado a 200mV por debajo de Vcc para que si lo dejás abierto opere en modo punto.
 
Última edición:

Dr. Zoidberg

Well-known-Papá Pitufo
no es el pin 9, es el led 9
Ahhh...es el pin 11. El bardo es que ese pin se usa para polarizar el comparador interno que fija el acarreo en modo punto cuando se usan mas de un LM3914 en cascada. Mirá este esquema del datasheet:

Pin11-LM3914.GIF

La tensión resultante en el pin 11 es inferior a Vled-0.6V y es probable que sea lo que dispara el PNP que activa el relay. A LED no lo molesta por que para que encienda necesita 1.8V o más de caída de tensión, así que con 0.6V ni se mosquea, pero por lo que veo, no hay una forma directa de zafar del problema.

Saludos!

EDITO:
Podés probar con poner una resistencia de 22K o 18K en paralelo con el LED 9, pero no creo que tire ese punto mas cerca de Vcc...pero como no hay ningún esquema detallado, nada se pierde con probar...
 
Última edición:

Dr. Zoidberg

Well-known-Papá Pitufo
No sabía eso... gracias por la info Eduardo. Voy a tratar de hacer pruebas y les comento qué tal.
De nada!
Estaba pensando mientras dormía :eek: y se me ocurrió que tal vez con un zenner entre el pin 11 del LM3914 y la base del PNP - y conservando la resistencia de polarización de la base a Vcc - sea posible desvincular la caída de tensión del LED driver, pero es una idea que no tiene mucho análisis :unsure:, y quizás no sea necesario un zenner sino un par de diodos comunes, tipo 1N4148 o algo así....hay que estudiarlo.

PNP-Tacometro.gif

Saludos!

PD: Donde está el esquemático de este circuito? Por que no lo encontré aún y hay varias cosas queme estoy imaginando...
 
Última edición:
Es que el pin 9 es el pin de MODO, no un pin de un LED. Que es lo que están conectando ahí?
El pin 9 está polarizado a 200mV por debajo de Vcc para que si lo dejás abierto opere en modo punto.
Al pin 9 se refieren al la hilera de pines... no al pin del IC

EDIT: :oops:No me había fijado que ya se respondió
 
Última edición:
PD: Donde está el esquemático de este circuito? Por que no lo encontré aún y hay varias cosas queme estoy imaginando...
Al esquema completo no lo tengo por acá, pero rescaté la etapa del 3914 que sería lo importante en este caso, te la adjunto. Lo del diodo era otra de las pruebas que quería hacer, en simulador (si bien no presenta ese problema en dicho pin) se nota un aumento en el nivel de tensión gracias al diodo, veremos que pasa (y).

Saludos
 

Adjuntos

Dr. Zoidberg

Well-known-Papá Pitufo
Al esquema completo no lo tengo por acá, pero rescaté la etapa del 3914 que sería lo importante en este caso, te la adjunto. Lo del diodo era otra de las pruebas que quería hacer, en simulador (si bien no presenta ese problema en dicho pin) se nota un aumento en el nivel de tensión gracias al diodo, veremos que pasa (y).
OK. Lo de la resistencia en paralelo al LED9 es inútil, por que ya tenés el divisor R6/R1 haciendo eso y el relay se activa igual, así que creo que hay que ir por el lado de los diodos. La idea de los diodos es simple: si Vcc-[la tensión en el pin 11 del LM3914] es menor que la suma de las caídas de los diodos (que van en serie con R1), la base está desconectada del pin 11 (o de cualquier pin, por esto sirve para todos) y el transistor está al corte por la polarización de R6. Si la tensión del pin 11 respecto a Vcc baja más de 1.4V, el transistor se satura y el relay se activa.
Creo que vale la pena probarlo...aunque hay que poner un par de diodos por cada transistor.

Por otra parte, cuando tenga un tiempito te voy a escanear un esquema de un tacómetro publicado en un libro de RCA mmuyyy viejo, pero que tiene una etapa de entrada muy simple y aparentemente efectiva que te puede hacer zafar de todas esas consultas por problemas de ajuste de los trimpots y todo el bardo ese...

Saludos!
 
Por otra parte, cuando tenga un tiempito te voy a escanear un esquema de un tacómetro publicado en un libro de RCA mmuyyy viejo, pero que tiene una etapa de entrada muy simple y aparentemente efectiva que te puede hacer zafar de todas esas consultas por problemas de ajuste de los trimpots y todo el bardo ese...

Saludos!
Creo que el problema de los trimpots es que una gran parte de los foreros no lee antes de montar algo, y ahí viene la repetición de preguntas cansadoras...
No hay mucho que comprender a la hora de ajustar:

Trimpot horizontal izquierda ajusta la sensibilidad al inicio de la escala
Trimpot horizontal derecho ajusta la sensibilidad de final de escala
Con estos dos logramos que prenda toda la escala de leds

Trimpot vertical ajusta la reacción del shift light, nada mas fácil que conectar una carga ( lampara led lo que se quiera ) y medir con el multímetro la tensión de salida cuando no debe prender el shift light, y luego medir cuando debe estar activado el shift light...

No es algo complicado, sino de prueba ir avanzando de a poco en el ajuste para tener el ajuste más fino posible.

Yo no tuve problema a la hora de ajustar.
 

Dr. Zoidberg

Well-known-Papá Pitufo
Creo que el problema de los trimpots es que una gran parte de los foreros no lee antes de montar algo, y ahí viene la repetición de preguntas cansadoras...
No hay mucho que comprender a la hora de ajustar:

No es algo complicado, sino de prueba ir avanzando de a poco en el ajuste para tener el ajuste más fino posible.
No es que sea complicado, pero si podés eliminar por completo los ajustes, sería mucho más simple y sin preguntas...

El problema de ajuste de escalas se debe a que la tensión de entrada al LM3914 varía entre límites que no son muy previsibles. Si fuera posible fijar los valores máximos y mínimos independientemente del "auto" y de la "instalación" seguramente sería factible eliminar el ajuste de escala y la necesidad de andar cambiando un trimpot por otro y esas cosas...

PD: Yo ni siquiera lo he armado...
 
Última edición:
Muy cierto lo que comenta bebeto sobre el ajuste y agrego que en mi caso, me parece muy interesante el poder ajustar la escala a gusto, ya que a veces la configuro como escala de shift completa (como utilizan en los autos de Fórmula 1, cuando vean la cámara que muestra el volante van a poder apreciarlo). Incluso se podría configurar para que parpadee la escala al llegar al final, en fin.. son distintas posiblidades que permite la regulación.

Igualmente te encargo ese esquema Eduardo cuando hagas un tiempo libre... sería muy interesante ver cómo lo implementaron, de hecho así surgió este circuito, sacando ideas de varios lados, modificando y juntando todo.

Saludos!
 
Regulá el trimpot vertical hasta conseguir que se apague, y que encienda cuando es debido...

Vamos que con leer un poquito nomas no hacía falta la pregunta:

bebeto dijo:
Trimpot vertical ajusta la reacción del shift light, nada mas fácil que conectar una carga ( lampara led lo que se quiera ) y medir con el multímetro la tensión de salida cuando no debe prender el shift light, y luego medir cuando debe estar activado el shift light...
De nuevo por acá...

Me tomé el atrevimiento de desglosar el PCB y así levantar el circuito y armar el esquema, el cual lo dividí en partes así es mas fácil de comprender...

Espero no haberme equivocado y si lo hice y alguien se da cuenta que me pase el dato así lo modifico.

PD: Dejé de lado la parte del regulador que la reemplacé con una batería de 9V porque en el livewire no hay reguladores para este voltaje.

Saludos.
 

Adjuntos

Última edición:
nahuelb,, hola ,, tenia el mismo problema q vos ,,cuando le daba tencion siempre se prendia ese led,, pienso q es por el precet ya q tenia uno de 2.2 enves de uno de 22,, ahora recien lo compre y el lunes lo voy a colocar a ver q pasa ,, por hai tenes roto el precet ,, por q yo de solo girar voy rompiendo unos cuantos ,, fijat si encontras una solucion,,
salu2:unsure: