tension alimentacion AO de potencia

#1
Hola,estoy usando un amplificador operacional de potencia TCA0372DP1, me descarge su hoja de caracteristicas para poder saber entre que valores de tension de alimentacion trabaja,
y solo me dá los valores maximos de alimentacion a 40V, como puedo saber el minimo?

gracias
 
#5
estoy usando la fuente con la salida a 2.5V,no ha +-2.5V,aunque tambien podria hacerlo
por lo que deberia subir esa tension hasta los 5V?
o podria conectar 2.5V a Vcc y -2.5V a Vee,segun los pines que me indica la hoja de caracteristicas?
 
#7
ok gracias,esto lo queria saber porque tengo la siguiente duda:

no puedo aumentar la Vcc del AO a mas de Vcc=+3V porque sino a la salida tengo mas de I=200ma y quemo un motor que tengo coloccado de la siguiente forma :

http://imageshack.us/photo/my-images/685/duda2d.jpg/


como podria conseguir poder aumentar esta Vcc hasta los 5V que necesito, para que el AO trabaje en su rango de alimentacion y no superar estos 200mA a la salida

pd:el AO tiene a la entrada una señal pwm de amplitud 3V
 
#8
Acá cambian las cosas. Si tu entrada es de 3V, obligatoriamente tu alimentación tiene que ser de más que eso, no puede ser de 2.5V. En general, y este ampli no es la excepción, las entradas no pueden superar a la alimentación. Además, las salidas llegan como máximo a 1V del riel. Por eso, quizá hasta te conviene poner +- 5V, la tensión de salida del AO en esta configuración no la dicta su alimentación sino su entrada, si la entrada está a 3V, como es un seguidor de tensión, a la salida también tenés 3V. Y por otro lado, si usás -5 en la alimentación negativa garantizás que la salida llegue a cero, si le ponés cero de alimentación negativa, con entrada 0 te va a sacar más o menos un voltio a la salida.
 
Última edición:
#9
si,ya llegue a poner a la entrada + del AO 5V,pero aun asi cuando la alimentacion del AO era superior a 3V, seguia teniendo el problema de que a la salida tenia mas de I=200mA y no puedo superar este valor de corriente
como podria conseguir alimentar el AO con al menos 5V y asi no superar esta corriente??

lo unico que se me ocurre seria poner una resistencia en paralelo con el motor, pero creo que esto evitaria el funcionamiento correcto del motor segun la señal pwm
 
#11
entre 1.5V y 3V
trabajar a 2 o 2.5 ya me valdria, pero claro necesito alimentar el AO con al menos 5V y no superar la corriente de 200mA que le dije



se me olvido indicar una cosa,el diodo en paralelo con el motor va en sentido contrario al de la imagen!!
 
Última edición:
#12
Lo que podés hacer es conectarlo en una configuración con ganancia menor que uno. O sea, manteniendo la alimentación en 5V, variar la ganancia para que la salida sea, digamos, 2V, cuando el PWM saca 3.
 
#13
esque no deberia cambiar la ganacia, porque cuando genero la señal PWM con un 555 todo funciona correctamente
pero al sustituir el 555 por un compact rio es cuando aparecen los problemas
 
#14
esque no deberia cambiar la ganacia, porque cuando genero la señal PWM con un 555 todo funciona correctamente
pero al sustituir el 555 por un compact rio es cuando aparecen los problemas
Si el amplificador tiene ganancia 1, y el voltaje del motor es N voltios; entonces debe aplicar una señal igual o ligeramente superior a N voltios, en la entrada del operacional.

.
 
#15
eso el lo que estoy haciendo,aplicando 3V a la entrada del AO, pero a la salida no tengo los 3 que debo al tener el ao con ganancia 1,
esto es debido como ya dije, a que el AO no puedo alimentarlo hasta los 4V que necesita como minimo para funcionar correctamente, ya que al alimentarlo con 3V ya supero a su salida la corriente maxima que puede soportar mi motor
lo unico que necesito es poder alcanzar estos 4v de alimentacion al ao, para asi poder tambien tener 3v a la salida del ao, pero esta el problema de la corriente a la salida y no se como solucionarlo



que pasaria si le meto directamente la señal pwm al motor a 3V y quito el AO?
 
Última edición:
#16
mario, me parece que estás mezclando varias cosas juntas.

Primero, el AO tiene que tener como mínimo alimentación de 5V.
Segundo, tenés que averiguar por qué el motor consume mucha corriente al alimentarlo con 3V. Te recomiendo hacerle pruebas de tensión y corriente al motor en forma separada, con una fuente de tensión y midiendo la corriente.
Tercero, no podés conectar el motor directamente al PWM. En el mejor de los casos el motor ni se moverá, en el peor se quemará la salida del micro por exigirle tanta corriente.

Por último, una vez que sepas que tensión aplicarle al motor, podrás adaptar la ganancia del amplificador para que con una entrada de 3V, te entregue exactamente la salida que necesitás. Con respecto al 555, habría que ver que tensión entrega el 555 con respecto al PWM, para ver si entendés por qué en un caso funciona y en el otro no. Idealmente, tenés que tener un osciloscopio a mano, para ver si no hay "cosas raras" en la forma de onda, que expliquen las diferencias.

Tené siempre presente que si hay diferencias, hay una causa. No siempre es fácil encontrarla, pero en nuestro campo, nada ocurre sin una causa. Y buscar las causas de las diferencias que vos ves es la manera de aprender. Para eso (es fácil decirlo, no siempre hacerlo) tenés que ser muy metódico, anotar cada experimento que hacés, y cambiar el mínimo de variables en cada prueba. Idealmente, para cada experimento que hacés tenés que cambiar sólo una variable.
 
#17
Cuando lo hice con el 555, la tension de alimentacion para el 555 y el ao era de 6V, y la señal pwm que tenia a la salida del 555 era de 5V, por lo que con un divisor de tension hacia que entraran 3v al ao.
para hacer las prubas de tensión y corriente al motor, que hago lo conecto a una fuente de tension directamente en paralelo?

hola,acabo de ver que tengo el mismo problema para el caso de generar la misma señal pwm(igual frecuencia y ciclo de trabajo) con el 555 que con el compactrio

Asique el problema es electronico no sobre compacrio

Con que circuito podria ver el comportamiento de mi motor segun la alimentacion que le este dando?
 
Última edición por un moderador:
#19
ok,hice lo siguiente:

http://img684.imageshack.us/img684/3065/ensayon.jpg

y los resultados que obtengo son:

V=2V I=200mA
V=1.7V I=180mA
V=1.5V I=170mA
V=1.3V I=160mA

La pregunta es: si el rango de trabajo de mi motor es entre 1.5V y 3V,porque no puedo alimentarlo con mas de +2V con mi fuente de alimentacion?



aparte de esto, podría probar a poner una resistencia en el lazo de realimentacion del AO?, de ser así de que valor de magnitud deberia ser y porque?
 
Última edición:
#20
Bueno, la verdad es que no sé quien te dictó la limitación de 200mA para el motor, y por qué. Y ya que estamos, la corriente del motor es una función de la carga. Cuando el motor gira, desarrolla una tensión que es la fuerza contra electromotriz. Si de repente y en forma forzosa frenamos el eje, la corriente sube un montón porque desaparece la fuerza contra...bla bla. Del mismo modo, a igual tensión, la corriente será distinta dependiendo de la carga mecánica del motor.
 
Arriba