¿Optoacoplador o transistor?

#41
Voy a revisar todo desde el principio haber ahora porque es asi esto?
muy raro, raro...

si colocas o comentas que fuente estas usando y pones el circuito tal y como lo tienes podriamos darte opiniones....

recuerda que nosotros no vemos como lo tienes al final...
 
#42
Esto es exactamente lo que tengo, la fuente externa es una fuente de esas de pc portatil 12V 2A.
Hay alguna manera de esos 2V. que me da el pin 1 del pc amplificarlos a 5V.?
Es que tengo un opto que lo mismo podia utilizarlo como rele pero necesito aplicarle 5V para que cierre.
Salu2
 

Adjuntos

Última edición:
#43
Hay alguna manera de esos 2V. que me da el pin 1 del pc amplificarlos a 5V.?
ya con el transistor lo estas amplificando a 12v... pon 5v en lugar de 12v y lo amplificas a 5v( con una resistencia limitadora de corriente, hablamos del colector!!...)

con el opto no es necesario amplificarlo.... pero igual el opto tiene un limite de corriente y voltaje....

tengo una duda quita todo del puerto y mide el voltaje con el pin 2 en alto, debe medir 4.5v mas o menos....
 
Última edición:
#44
He medido el pin 1 (es el que utilizo) sin conectar nada activo 5V. con lo cual el puerto esta bien? Pero al utilizar el programa que me activa y desactiva el electroiman se me va a 2V.

El opto no me lo activa porque necesito mas voltaje, con 5V si funciona

Si el programa que me activa el pin no me bajara el voltaje a 2V. no tendria problemas.
Por eso necesito algo que funcione con esos 2V. o amplificarlos.

Lo mismo el problema lo tengo en el puerto, por que he probado a alimentar la base del TR con una pila de 1,5V y va bien. El pin1 lo testeo sin nada conectado y da 5V y al conectarle el TR parece ser que se viene abajo?¿ es raro esto
 
Última edición:
#45
He medido el pin 1 (es el que utilizo) sin conectar nada activo 5V
mmmm el pin1????

puede ser del 2-9... cual es el codigo ahi esta algo raro.... pero no mal.... depende

sin conectar nada activo 5V. con lo cual el puerto esta bien?
si el puerto eso debe medir esta bien...

El opto no me lo activa porque necesito mas voltaje, con 5V si funciona
debe funcionarien..., ¿pones una resisencia de 220 ohms en serie con el pin1 o 2 del opto????

Lo mismo el problema lo tengo en el puerto, por que he probado a alimentar la base del TR con una pila de 1,5V y va bien. El pin1 lo testeo sin nada conectado y da 5V y al conectarle el TR parece ser que se viene abajo?¿ es raro esto
los transistores no funcionan con voltaje funcionan con corriente por lo que deberia funciona bien...

prueba con el pin dos, y te preparo varias opciones... pero dame chance ando un poco ocupado...
 
#46
He visto que cuando activo el programa solo me manda el pin una señal de 0.2 o 0.3V aprox.
a la base del transistor, lo mismo esa señal es muy debil para saturar
 
Última edición:
#47
He visto que cuando activo el programa solo me manda el pin una señal de 0.2 o 0.3V aprox.
a la base del transistor, lo mismo esa señal es muy debil para saturar
los transistores BJT funcionan con corriente NO con voltaje!!!!!! ya olvidate del voltaje..... en todo caso mide la corriente...

Intenta Probar este diseño para un selenoide de 24v hasta de unos 3A...
si llegas con el selenoide a los 3A debes cambiar el diodo 1n4148 al 1n5400 y procura dejar un poco de margen, digamos que el selenoide sea no mayor de 2,5A o mide su resistencia interna debe ser menor a 10 ohms.(si es menor aumenta su valor ohmico o sea mas de 10ohms ejem 20ohms o mas...)

(Mel olvide de cambiar en el dibujo los 12v del rele por 24v, perdon!!!! me dio fiaca correjirlo :D)
 

Adjuntos

Última edición:
#48
Meto la cuchara para un pequeño aporte:
Hay al menos 2 normas para el puerto paralelo, una para nivel 1 y otra para nivel 2.
Para el nivel 1:
d) The high-level output voltage shall be at least 2.4 V at a source current of 0.32 mA.
Para el nivel 2:
c) The dc steady-state, high-level output voltage shall be at least 2.4 V at a source current of 14 mA.
No me llama la atención que baje la tensión. Si tu puerto pertenece a los definidos como nivel 1, quizás sería mejor hacer que la activación sea usando su nivel bajo, ya que la corriente para es de 14 mA en ambos casos.
 
#49
Buenas tardes,
Necesito que alguien me asesore en un problemilla que tengo,
Necesito accionar un electroiman que se alimenta de 12V, pero el problema es que la señal que tengo de accionamiento es de 1V DC aproximadamente, que solucion me veis mas eficaz.
Yo he pensado en utilizar un optoacoplador en forma de rele, que me corte una fase de una fuente externa de 12V y otra forma seria con transistor amplificador.
Necesito altavelocidad de accionamiento, ¿como veis el tema?
Saludos y gracias de antemano
ahorrate trabajo y utiliza un uln2003 y ay obtienes lo que necesitas,, pues consta es de transistores y es muy útil en estos tipos de caos que nombras

He medido el pin 1 (es el que utilizo) sin conectar nada activo 5V. con lo cual el puerto esta bien? Pero al utilizar el programa que me activa y desactiva el electroiman se me va a 2V.

El opto no me lo activa porque necesito mas voltaje, con 5V si funciona

Si el programa que me activa el pin no me bajara el voltaje a 2V. no tendria problemas.
Por eso necesito algo que funcione con esos 2V. o amplificarlos.

Lo mismo el problema lo tengo en el puerto, por que he probado a alimentar la base del TR con una pila de 1,5V y va bien. El pin1 lo testeo sin nada conectado y da 5V y al conectarle el TR parece ser que se viene abajo?¿ es raro esto

solucionaron con uln2003 este te sera util
 
Última edición:
#50
los transistores BJT funcionan con corriente NO con voltaje!!!!!! ya olvidate del voltaje..... en todo caso mide la corriente...

Intenta Probar este diseño para un selenoide de 24v hasta de unos 3A...
si llegas con el selenoide a los 3A debes cambiar el diodo 1n4148 al 1n5400 y procura dejar un poco de margen, digamos que el selenoide sea no mayor de 2,5A o mide su resistencia interna debe ser menor a 10 ohms.(si es menor aumenta su valor ohmico o sea mas de 10ohms ejem 20ohms o mas...)

(Mel olvide de cambiar en el dibujo los 12v del rele por 24v, perdon!!!! me dio fiaca correjirlo :D)

Para fuente externa de 12V3A y selenoide de 12V7W me valdria estos compomentes?

ahorrate trabajo y utiliza un uln2003 y ay obtienes lo que necesitas,, pues consta es de transistores y es muy útil en estos tipos de caos que nombras




solucionaron con uln2003 este te sera util
Podrias decirme algun esquema de conexion de este componente?
 
Última edición:
#51
Buenas,
He probado el circuito y saturando la base del TR con una pila de 1,5V y va perfectamente.
El problema esta en el pc que me manda una señal tan debil de corriente que no llega a saturarlo, he probado en 2 pcs por si fuera el puerto que este roto y hace lo mismo en los 2.
La conclusion que he llegado es que el puerto me manda una señal de corriente muy debil.
 
#54
Supongo que en algún punto de tu placa tenés 5 volts. Entonces ponés una resistencia (de 1000 Ohms) conectada entre los 5 volts y el pin 1 (o el que uses para control) del puerto paralelo. El resto todo igual a como lo tenés conectado ahora.
 
#55
Entonces cojo 5V externos al puerto paralelo, y los conecto a una resistencia y al pin del puerto? y este a la base del TR?

la resistencia es para no dejar pasar corriente hasta que no le entre la otra cantidad del puerto?¿
 
Última edición:
#56
En tu circuito tenés una resistencia en serie con la base del BC548, esa dejala, o sea dejá todo tal como está, solo el agregado de la resistencia entre 5 volts y el pin 1.
Por supuesto el negativo de los 5 volts deberá estar conectado al negativo de tu circuito (pin 25).
 
#57
Ya parece ser que esto va.
No se si habre hecho una chapuza pero el caso es que va, he consegido que trabaje el selenoide mas o menos bien. Lo unico que noto es que se calientan bastante los transistores, ¿es normal? Este es el esquema

Tambien he pensado de montar primero el TR con la fuente de 5V y este saturar un opto 4n25, y utilizar este para cerrar o abrir una fase de la fuente 12V, como lo veis?
 

Adjuntos

Última edición:

Temas similares

Arriba