Amplificador HighEnd Clase D de 25W a 1250Wrms sólo con 2 MosFets N

En teoría si bajas la frecuencia la tensión no cambia, bueno en realidad si baja por el tema de la transferencia de potencia, pero lo que realmente debes de hacer es modificar el ancho del pulso, si usa un 555 debería de ser facial, levanta el diagrama del oscilador y será mucho mas fácil. Mide la tensión de la fuente con carga y sin carga para ver que tanto baja la tensión, si no baja mucho debe de estar realimentada por algún lado, si baja 3-4 V es a lazo abierto y tienes que modificar el ancho de pulso.
 
Muchas gracias sebsjata, esa prueba ya la realicé, y la tensión permanece estable, no hay variación, entonces si hay realimentación.

Estoy buscando donde está, alguna idea??

Gracias por la opinión.
Saludos.
 
Buenas tardes a todos,

Por fin me anime a hacer la prueba de potencia sin la lampara (sugerencia de Fogonazo), esta trabajando muy bien sin ruidos, buenos bajos y agudos.

Estoy en la version 1250Wrms/4ohm (+/-100v) con el voltaje exedido en +/-7v es decir a +/-107v y al parecer todo va bien sin calentamientos excesivos en al amp. y la fuente. Agregue los fueses (sugerido por shevchenko) entre la salida de la fuente y la entrada del amp. como me suguirieron, y a la salida a parlantes la tarjeta de protección que ya tenia. Solo he subido el volumen a un 40% de acuerdo a la mezcadora, es muy fuerte el sonido se necesita otro espacio mas propicio para este efecto (hay vecinos alrededor) ademas de que mis parlantes solo soportan 400W.

No he olvidado los comentarios de sebsjata, estoy diagramando el ocilador (NE555), tengo avance de 60% de el, la tension en la fuente permanece estable con y sin carga (+/-107v), en cuanto lo tenga trerminado se los presento.

Agradezco al ing. ejtagle por compartir sus conocimiento de este gran amplificador, tambien agradezco a los compañeros; shevchenko, Diego German, Fogonazo y sebsjata por sus contribuciones a esta historia de exito (que ahora mismo mis oidos estan disfrutando) del proyecto del ingeniero Tagle.

Seguire en contacto.

Un cordial saludo.
 
Hola soy nuevo en la pagina queria sus opiniones queria voy a usarlo a 200wrms con impedancia de 8 ohms en la pdf dice que hay tener 57+- a 7.3amp lo mas cercano que tengo seria un trafo de 40-0-40 a 6amp rectificado da 56+- a 6amp servira?¿
 
Muchas gracias Diego German,

Te comento lo siguiente, hice una prueba con la fuente y el amplificador y está trabajando bien, sin señal de entrada medi voltaje y me está entregando +- 107.2V, después conecte un protector de salidas y le inyecte señal de audio, la música sonó clara y nítida con buenos bajos y agudos y sin ruido, cuando llegue a un aprox 60% del volumen de la mezcladora el foco en serie se iluminó con fuerza y el protector se salidas se desconecto, baje el volumen y se volvió a conectar y otra vez todo bien. Al parecer el protector detecto voltaje alto en la salida y se desconecto, pienso que se saturaron los IRFP450 y/o la bobina de salida del amplificador.

Ahora estoy revisando precisamente lo del lazo de control, tengo que desmontar la placa del disipador porque al parecer, si hay optoacoplador está en la cara de abajo. Esta fuente es diferente, las tipo LLC no las conocía la estoy estudiando. Alguien del foro sabe cómo trabajan las fuentes LLC? No he conseguido documentación aún.
Seguiré revisando y les comento mis hayazgos.

Muchas gracias por sus respuestas.

Saludos.

Cuidado, pusiste IRFP450 o IRFP250?
Si pusiste IRFP250 moriran en cualquier momento por exceso de tensión.
Si pusiste IRFP450 Van a hervir por disipación y que tienen 0.4 de RDS (a parte de explotar por cantidad de corriente a maxima potencia) y probablemente no funcione de manera óptima ya que tiene algunas diferencias con el IRFP250, principalmente la velocidad del diodo, que importa bastante en este caso.
Si es el primer caso, te recomiendo que antes de hacer volar todo cambies por algun otro mosfet como IRFB4229 o similar (y probablemente ajustes la RG) o, bajar la tensión.
Si es el segundo caso y pensas darle un uso continuo, DISIPALO BIEN, PERO MUY BIEN jaja.

Suerte
 
Buenas tardes djnanno,

Gracias por la opinión, te comento que estaba usando IRFP250 y previendo precisamente lo que comentas los cambie por IRFP4227, tenía un par en buen estado.

Tanto la fuente como amplificador tienen disipadores y ventilador, está todo bien refrigerado.

Esta trabajando bien y no he disminuido el voltaje de +/-107 hasta que termine el diagrama de la realimentación del NE555 de la fuente.

Muchas gracias por tus comentarios.

Saludos cordiales.
 
Buenos dias endryc1,

Gracias por la observación, sin embargo y con todo respeto me llama mucho la atención que en la tabla del diagrama esquematico del ing, ejtagle no propone un cambio de Mosfet para las potencias altas, hasta ahora en todas las lecturas que he tenido del foro y en particular las del ingeniero, no habla de un cambio de Mosfets para esa potencia "1250Wrms/4ohm +/-100v", todas las opiniones y observaciones del ingeniero me han resultado ciertas en todas las pruebas y cambios que he realizado.

En el foro existen recomendaciones del ingeniero ejtagle ej.

"Sobre el tema de variación de los tipos de componentes, com alguna vez ya dije... Los tipos recomendados en el esquema (originales!) son los únicos que garantizan la estabilidad en el tiempo del amplificador... Todas las demás modificaciones y/o sustituciones deberían analizarse desde muchos puntos de vista antes de poder asegurar que funcionen adecuadamente ... y tengo mis dudas..."
.
.
.
"4) Transistores grandes vs transistorcitos pequeños... Por algo uso tr pequeños.. Son MAS RAPIDOS, y eso es muy importante acá. Y que trabajen calientes NO es un problema... Están disipando MENOS de la mitad de la potencia máxima, según el fabricante... Están con un margen de seguridad ENORME"


Tambien existen varias pruebas y medicion sugieridas por el ingeniero, las cuales he relizado y se encuentran dentro de los parametros sugeridos.
En fin ya hice el cambio de IRFP250 por IRFP4227 y han trabajado bien ambos Mosfets.

Saludos Cordiales.
 
lo que dice @endryc1 es cierto, cambia esos mosfet o baja la alimentación, que esté funcionando bien así no es garantía que te vaya a durar toda una vida, estas trabajando fuera de los limites recomendados por el propio fabricante. La alimentacion debe de estar un 80% por debajo de VBdss y por seguridad VBdss debe de ser mucho mas alto.
Para IRFP(B)4227PBF=200Vx80%=160V= +-80V
Para IRFP(B)4229PBF=250Vx80%=200V= +-100V
 
Gracias sebsjata,

No tengo los IRFP4229 pero aquí en mi pais no son muy caros unos 12 o 13 dólares el par.
Si ya probé con IRFP250 y IRFP4227 nada pierdo con cambiar a los que me proponen, los cálculos que mencionas son correctos, haré los cambios y les comento como me fue.

Muchas gracias por su tiempo y observaciones.

Un cordial saludo.
 

shevchenko

Well-known-Ruso
Hola soy nuevo en la pagina queria sus opiniones queria voy a usarlo a 200wrms con impedancia de 8 ohms en la pdf dice que hay tener 57+- a 7.3amp lo mas cercano que tengo seria un trafo de 40-0-40 a 6amp rectificado da 56+- a 6amp servira?¿
Va a andar perfecto nomas no le exijas el 100% de volumen por que el trafo va a calentar.
 
Buenas noche compañeros del foro,

Busque en la tienda electronica de la CDMX Mosfets para el ampli de 1250Wrms/4ohm (+/-100v) y encontre los siguientes:

IRFP4229, Vds - 300V, Rds(on) - 38 M(ohms), 44A, USD - 5.00
IRFP4242PbF Vds - 360V, Rds(on) - 49 M(ohms), 46A USD - 4.00 (prod. descontinuado)
IRFP15N60L Vds - 600V, Rds(on) - 385 M(ohms), 15A USD - 2.50
IRFP4868PBF Vds - 300V, Rds(on) - 25.5 M(ohms), 70A USD - 9.00
IRFPS40N50LPBF Vds - 500V, Rds(on) - 0.087 (ohms), 46A USD - 15.00 (muy caro)
IRFP4137PBF Vds - 300V, Rds(on) - 69 M(ohms), 38A USD - 9.00


Atendiendo a las sugerencias de sebsjata y endryc1 que Mosfets recomiendan ustedes.

Saludos codiales.



 

shevchenko

Well-known-Ruso
A mi los irfp 450 me funcionaron perfecto, incluso los 18n60 (chiquitos) me funcionaron perfecto para cargas de 4 ohms, "cuidado con el irfp250" yo use el irfp 260n que es mas pesado aun, en este diseño y va perfecto, el ir2110 ES para eso! Y con esos mosfets lo use mas de 2 años sim dramas a +-60v incluso uso actualmente el irfp240n en el irs2092 a +-70v (que es mas quisquilloso con los mosfets) sin dramas sin temperatura ni nada a 250khz solo hay que calcular su R de gate, saludos.
 
Última edición:
Buenas tardes a todos,

Nuevamente recurro a ustedes para solicitar su ayuda.
Tengo un PCB armado y funcionando a la perfección, alimentado con +/-100v, el sonido es nitido, claro, sin ruidos ni zumbidos y el volumen es muy fuerte al 50%, no lo he subido a mas protestarian los vecinos.

Pues, resulta que arme otro nuevo PCB identico al que describo, he tenido siempre e invariablemente el mismo problema, pone en corto los 4 transistorcitos 2N5401 o tambien he usado MPSA92G con el mismo resultado, en alguna de mis intentos tambien daño el IR2110, el LM311 y el TIP31. Estoy usando lampara en serie y apenas le administro la tension inmediatamente sucede lo descrto anteriormente, no me da tiempo para hacer mediciones o revisiones.

Antes de cualquier intento reviso que todos y cada uno de los componentes (todos han sido nuevos) esten en perfectas estado.
Llevo 5 intentos con el mismo resultado y la verdad ya me desespere y ya no quiero gastar mas plata, las dos tarjetas son identicas y la Tar_A funciona a la perfeccion mientras que la Tar_B me da los problemas descritos.

He probado con dos Mosfet's diferentes IRFP4229 e IRP250N.

Anexo dos fotografias con las PCB's identificadas como Tar_A y Tar_B.
Tar_A:
funciona correctamente (actualmente con IRFP4229).
Tar_B: es mi problema, mi dolor de cabeza ( actualmente IRFP250N).

IMG_20201127_124027.jpgIMG_20201127_124052.jpgAgradezco sus futuras obervaciones y comentarios al respecto.

Nota: esto parece cosa del diablo.
 
Arriba