Ayuda con picos de corriente en inversor DC-AC.

#1
Tengo una duda respecto a un inversor de (12V a 220V-150W) que estoy montando. A la entrada del transformador elevador tengo esta señal tomada del osciloscopio digital (imagen adjunta). Supuestamente no debería tener picos y deberia ser una señal cuadrada sin picos (imagen adjunta). Estos picos podrían dañar la bateria de 12V que estoy usando, por ello quiero eliminar esos picos. Me recomendaron usar una bobina de choke entre el positivo de la bateria y el tap central del transformador. En este caso ¿cómo podria fabricar dicha bobina? o en general, ¿cómo podria eliminar esos picos de corriente que se generan?. Gracias de antemano a cualquier respuesta.
 

Adjuntos

#3
Yo tuve un problema con un inversor que realicé con unos mosfet BUZ10 (si la memoria no me falla) de 50V Los picos me reventaron los mosfet del primer prototipo. Entonces pude recortar los picos poniendo en paralelo con cada mosfet un zener de 35V (en realidad dos en serie, uno de 12V 5W y otro de 24V 5W). Los mosfet son los que me llaveaban al transformador. Si subes el circuito podemos ayudarte mejor
Saludos desde La Habana
 
Y

Yetrox

#4
Tengo una duda respecto a un inversor de (12V a 220V-150W) que estoy montando. A la entrada del transformador elevador tengo esta señal tomada del osciloscopio digital (imagen adjunta). Supuestamente no debería tener picos y deberia ser una señal cuadrada sin picos (imagen adjunta). Estos picos podrían dañar la bateria de 12V que estoy usando, por ello quiero eliminar esos picos. Me recomendaron usar una bobina de choke entre el positivo de la bateria y el tap central del transformador. En este caso ¿cómo podria fabricar dicha bobina? o en general, ¿cómo podria eliminar esos picos de corriente que se generan?. Gracias de antemano a cualquier respuesta.

@hp350j Que tal si lo implementas con un supresor de picos, también como te han recomendado con una bobina de choque puede que funcione mejor:unsure:



Bobina de Choque....

 
Última edición:
#5
Diodo switching entre Vbateria y bobinado, atenuan los picos de conmutacion. "Condes" en paralelo con los diodos, los diodos son de unos 10A.
Filtra tambien el secundario.
 
Y

Yetrox

#7
Yetrox la bobina de choke como la calculo? :)

@hp350j para los 12V te va bien una de 100µH a 200uH las hay de forma Radial y Toroidal, en cuanto al calibre de la bobina define la corriente que soportan no hay necesidad de hacerla, en placas de fuentes DC 12V como de impresoras o PC las encuentras a montones(y)
 
Última edición:
#11
Los diodos rápidos y los conensadores se ponen en paralelo con cada bobinado.
Ok opamp, esos diodos q codigo puedo encontrar aqui en lima (paruro) y que tipo de condensador y q valor me recomendarias. Si tuvieras un diagrama seria de mucha ayuda. Gracias. Ah, y si no es mucho pedir, me podrias explicar detalladamente por qué un choke entre la bateria y el tap central del transformador no suprime los picos de ON a OFF. Gracias :)
 

Adjuntos

Última edición:
#12
La teoria la encuentras en el Foro y en san google, hace mas de 15 años deje la docencia.

Lee sobre : diodo volante=diodo de circulacion libre=
Diodo freewheeling.
En Paruro encuentras muchos, fijate la DATA del NTE6086.
Los "condes" estan entre : 0.1u a 1u /100V , para tu P y Vbat.
 
#13
La teoria la encuentras en el Foro y en san google, hace mas de 15 años deje la docencia.

Lee sobre : diodo volante=diodo de circulacion libre=
Diodo freewheeling.
En Paruro encuentras muchos, fijate la DATA del NTE6086.
Los "condes" estan entre : 0.1u a 1u /100V , para tu P y Vbat.
Hola opamp, le puse los "condes" de 0.1u a 100V y se suprimieron los picos. Ahora ya tengo una señal de 220Vac en la salida del transformador sin muchos picos, pero al conectar una carga de un foco de 100W el voltaje en el secundario del trafo baja a 170Vac. Estoy usando una bateria de 12V de auto, asi q no creo q sea xq le falte potencia. por lo q creo q el problema seria mi transformador elevador... q caracteristicas debe tener? gracias
 

Adjuntos

#14
Supongo que estas midiendo con un tester TRUE-RMS.

Para estos inversores PWM de un solo pulso coloco 12V-0-12V /300V, algunos recurren a los comerciales : 9-0-9/220 , me parece que le falta espiras .

Estas realimentando tu control para que aumente o disminuya el ancho del pulso y regule la salida a 220 VRMS.
 
Última edición:
#15
Buenas tardes compañeros de la comunidad, como exprese en el titulo estoy desarrollando un inversor semicuadrado con puente H, tengo inversión pero al momento de realizarse el apagado de alguno de los mosfet, presento picos de voltaje, adjunto una imagen tomada del osciloscopio, como driver estoy usando el IR2110, he intentado con red snubber en paralelo a cada mosfet, cada mosfet tiene un diodo en antiparalelo, lo mejor que he podido lograr es colocando una red snubber en el primario del transformador, aun asi hay picos muy grandes de voltaje, que otra cosa podria hacer para desaparecer o atenuar esos picos, es para un laboratorio de la universidad y el profesor es muy exigente, no creo me deje presentar con esos picos, ademas algunas veces se me apaga el puente H, no entiendo que puede estar pasando, he verificado todo y esta bien, adjunto imagenes y planos.:confused:

Esos picos solo se presentan al colocar el transformador, con una carga resistiva no se presentan, la imagen adjunta es la salida del transformador.
 

Adjuntos

#17
DOSMETROS dijo:
Éste mismísimo problema ya ha sido consultado en el Foro ¿ No usaste el Buscador no ?
si lo use, pude leer lo de los diodos en anti paralelo y la red snubber por eso consulte por mi cuenta.

Podrías darme un hilo donde se halla logrado resolver este problema?
 
#18
Que valores de la red snubber utilizaste? Te recuerdo que esos valores se calculan a partir de los valores inductivos,resistivos y capacitivos que presenta tu transformador. Deberas reflejar lo que conectes en el secundario del transformador al primario y junto con los valores del transformador armar la red que se adecue a tu necesidad.
 
#19
La solucion para esos picos podria ser tambien cambiar los mosfets,tengo un inversor de 500w y en la salida tiene onda cuasisenoidal y cuando se cambio los mosfet aparecio los picos.
 
#20
pampas dijo:
La solucion para esos picos podria ser tambien cambiar los mosfets,tengo un inversor de 500w y en la salida tiene onda cuasisenoidal y cuando se cambio los mosfet aparecio los picos.
Eso es por que seguramente cambio la capacidad propia del mosfet, que en combinacion con el transformador cambio su transferencia y por lo tanto la red snubber que tenía ya no era la adecuada.
 
Arriba