Cálculo mosfet para PWM

#42
Martin en que vas a usar el motor?Estoy esperando tu post sobre el!no te olvides!. Saludos y suerte con la prueba.
 

DOSMETROS

High 2m Modereitor
#43
DOSMETROS todavía no los he leído bien a los PPS, pero les pegué una hojeada y estan excelentes, sobre todo el que tiene los cálculos de disipación, y cuanto eleva la temperatura, y demás. Excelente info gracias por compartirla, me podés decir en donde encuentrs este tipo de documentación? Saludos y gracias de nuevo


Hace unos años había arreglado un PWM con esos transistores que venía de otro lado con problemas , así que me informé un poco antes y los tenía en la PC ;)

Saludos !
 
#44
Voy a empezar diciendo: Chabgos, rayos, maldición. Empiezo descargando mi furia, porque le tenía muchisima fé a este intento. El PWM anda a la perfección, ya lo pude ver en el osciloscopio, probé que anduviese con un motor chiquito y andaba bien. Al probar con el motor grande, conecté todo, le empiezo a dar para que acelere y aproximadamente a un cuarto o menos de acelerador, todoavía no comenzaba ni a girar, salieron unas chispitas muy chiquitas entre unos mosfet y se acabó todo, medí y tres de los cuatro me daban continuidad, y calculo que el otro debe estar matado también. Alguien sabe porque puede haber pasado eso, el motor estaba en vacío.... y los mosfet lo deberían haber hecho girar por lo menos.... En uno de los intentos en el que usé los IRFP064N en vacío lo hice andar... Puede ser que le haya pasado algo al rotor y que por eso me rompa los mosfet? Los mosfet pueden haber sido truchos? Fue mala la eección de éstos? Haría un intento más con los IRFP064N, con el PWM optimizado al máximo como está ahora y si no a comprar los IGBT.....

PD: El motor es para un intento de auto eléctrico. Ahí me contesto este ingeniero que te dije y me baje un archivo de word sobre como elegir el motor, en breve lo subo.
 
#45
PD: El motor es para un intento de auto eléctrico
Si está dentro de tus posibilidades podrias usar 2 motores más chicos de 12V en serie y laburar con 24V para tener la mitad de corriente...
Es por eso que la mayoría de los scooters eléctricos y esas cosas trabajan hasta con 72V... 600A es un poco mucho no? ;)
 
#47
Bueno primero que nada, no he puesto una red snubber. Segundo, lo que he hecho es hacer pasar ua corriente de 0,51A por el rotor, medí la caída y es de 11,8mV. Por ende la resistencia del rotor es aproximadamente 0,023ohm. Con 12V/0,023ohm= 522A. Si bien no es un calculo esacto, es una aproximación, volví a probar con una corriente de 1A y la caída me da de 23mV lo que se traduciría a 0,023ohm, asi que alculo que esta mas o menos bien eso.... La red snubber es una muy buena idéa. No se que me recomiendan, si hacer un nuevo intento con mosfet o probar con algo así:
http://www.sindopower.com/en/Products-And-Shop/IGBT-MOSFET-Modules-oxid/SKM600GA12T4.html

No se quiero esquivarle lo más posible al terrible gasto, pero si va ha ser la única solución.....

PD: En caso de hacer una última prueba con mosfet. ¿Cuáles recomendarían?

Me acaba de surgir una duda: Recién mientras probaba la resistencia del motor estuve usando el PWM de 5KHz y hacía calentar bastante al mosfet por bastante me refiero a peligroso, casi no se podía apoyar el dedo en 2A, con el otro PWM que tengo, que funciona a 200Hz le hacía pasar 6A y ni calentaba. Es mosfet usado era un IRFP064N de 110A. Supongo que este mosfet esta preparado para trabajar a baja frecuencia, la duda es ¿En que parte del datasheet me tengo que fijar para saber que frecuencia usar? los IRF1404 con 5KHz estaban bien? no se me habrán roto por eso?
 
Última edición:
#49
Si es verdad lo de la red, pero no puedo poner el campo en serie con el rotor, porque cosinaría los campos, los bobiné yo y a lo sumo aguantan unos 10A, además si lo hago así, aumentaría la resistencia, la corriente sería mucho menor y empezaría a perder fuerza...., que no es lo que quiero....Gracias por la sugerencia y el pdf que esta en el enlace que pusiste es muy bueno.
 
#50
Los campos los conectaste directo a los 12V?o tambien al PWM?
Es raro que no llegara a girar en vacio, se me ocurre que la frecuencia fue demasiado alta.
 
Última edición:
#51
Ya lo probaste directo a 12V sin PWM?.. como dijo marcelo
Y comentaste que lo ibas a usar con un Pack de Baterías, Podrías decir las especificaciones de las baterías, que me imagino deben ser Monstruosas jeje
 
#52
Para los campos tengo otro circuito PWM con los que controlo mandarles 6A aproximadamente. La resistencia es demasiado baja como para ponerlo directo al motor, los libros dicen que tengo muchas posiblidades de quemarlo si hago eso, dicen que si o sí necesito un circuito de arranque. El libro es viejo y pone un gran reóstato que banque mucha potencia. La bateria que tengo por el momento es una batería óptima la de color rojo. Para hacer las pruebas es la que tengo si todo empieza a salir bien vere....

PD: Como ese día no tuve disponible dos baterías, a los campos los alimente con un cargador de batería largando 5A, eso puede haber hecho algo malo?. Todavía no entiendo la maldita falla de los mosfet. A poco menos de un cuarto de acelerador unas chispitas entre medio y puf.... Pense lo de la frecuencia pero la frecuanca estaba bien verdad? es la que habíamos venido charlando 5KHz... con menos hubiera sido mejor?
 
#53
Para mi por la masa del rotor, y los pulsos tan cortos(por la alta frecuencia) no llego ni a girar. Por eso te anduvo el motor pequeño.
Lo de la frecuencia es prueba y error, vos mismo habras visto PWM de 1000hz hasta los 20mz.
Eso es lo que pienso, no soy especialista en el tema.

PD: cuantas vueltas les diste a los campos y que diametro de alambre usaste?
Son 4 campos supongo, conectados en serie?
 
#54
Se llegaron a preguntar para que en mosfet pase los 210A, estos tienen que ser medidos en condiciones de laboratorio, es con temperatura controlada(a 25ºC), así que hay que aumentar el nro de mosfet para controlar el motor y cuatro mosfet no es suficiente, si mandamos solo 50A a cada mosfet tendriamos que usar 10 dispositivos ( navidad adelantada). Me encanta este tema, muy interesante, ya que los fabricantes de autos electricos escondieron todo lo relacionado con ello.
 
#56
Bueno de Motores se lo Básico, pero no creo que se pueda manejar un motor de 522A con un cargador de 5A, y me imagino que el cargador carga en DC y no en pulsos..
La Red snubber es buena colocarla, pero debería andar sin ella ya que el diodo interno del IRFP064N se encarga de deshacerse de la corriente almacenada en el motor..

Te recomiendo que busques una fuente que te provea la corriente necesaria para el motor, porque podrás hacer mil cambios ya sean circuitos PWM, Protección, Motor etc... Pero si no tienes lo principal que es La FUENTE de alimentación, no creo que llegues a nada...

Estuve pensando en la cantidad de Amperios-Hora que necesitaría tu motor..
Por ejemplo la Batería de mi carro es de 700A Max y 90Ah, si la usamos para mover tu motor y suponiendo que está en excelentes condiciones la batería.
Solo duraría:
90/600=0.15--- Ahora lo multiplicamos por 60 Minutos = 0.17x60 = 9 Minutos...
 
#57
Creo que interpretaste mal, al estator lo alimento con el cargador, al rotor con una bate.
Esos 9 minutos que calculaste son a plena carga, yo no creo que tu lleves el motor de tu auto siempre al 100%.
 
#58
Claro marcelo2112 tiene razón, el cargador era solo para mantener los amperes de los campos, la bat alimenta al rotor exclusivamente y ek consumo depende de la fuerza que haga...

Tengo la gran duda si la frecuancia fue muy alta ustedes que dicen?
 
Última edición:
#60
Hay alguna razón para bajar ten drásticamente la frecuencia, no quiero ser denso, pero nose... Se justifica de alguna forma o es solo al tanteo... Gracias Saludos
 

Temas similares

Arriba