Casio CZ-3000 - ¿Como controla el Key Split?

Hola a todos,

Esperó que tengan un feliz 2021!

Hace días me estoy rompiendo la cabeza con un sintetizador de los años 80, el Casio CZ-3000. A modo de introducción les cuento que el equipo no funcionaba, y después de varias horas de trabajo quedó funcionando casi por completo.

Somo me queda una falla que no puedo encontrar, y ojalá alguien con mas experiencia que yo me pueda orientar.

Les cuento los sintomas que pude aislar:

1- Cuando lo enciendo con los parametro como inicia, cuando presiono cualquier nota suena, pero solo durante 4 digitaciones (no importa la nota que presione). Después durante las 4 próximas digitaciones no suena, y el ciclo se repite indefinidamente. 4 suenan, y 4 no suenan. Este sintoma tiene una excepción, cuando tengo el preset 4 activo, el ciclo se da de 8 en 8. 8 suenan y 8 no seunan.

2- Key Split. Cuando activo el modo key split, la parte baja del teclado no suena. <-- Para mi este sientoma es clave, pero no se que HW (además de SW del micro) controla el key split.
1609436405901.png
3- Cuando lo pongo en modo monofonico (Boton "Solo" apretado) funciona bien.
1609436208358.png

Adjunto el manual de servicio del CZ-5000 que es prácticamente identico y el manual de operación del CZ.3000, tal vez a alguien le sirve.

Espero que alguien me pueda orientar.

Saludos.
 

Adjuntos

  • Casio Cz 3000 Manual.pdf
    34.6 KB · Visitas: 3
  • Casio-CZ-5000-Service-Manual.pdf
    9.6 MB · Visitas: 5
La verdad que todo lo controlan los microprocesadores, que son como 4 interconectados. Tienen algunos latch y mas circuitos, pero a menos que fallen en velocidad, no creo que sea eso.
Cuentanos qué fue lo que reparaste, y como habia llegado, para orientarnos mas.
Los sonidos se escuchan acordes a la realidad, o distorcionados, fuera de escala, etc?
Probaste cambiar el/los cristal/es?
 
Hola DJ, gracias por tu respuesta.

La placa estaba muy tocada, y llena de flux, un desastre:

1609705545924.png 1609705545755.png

Esas son las RAMs ROM y una de las CPUs, todas estaban igual.

Cuando la limpie, tenia la ROM de la sub CPU mal soldada, un MUX 74LS138 - Decoder 3- (El que hablita las RAMs, ROM de la SUB CPU) quemado, y uno de los flip Flops del generador de clock que no funcionaba.

1609703916919.png

La verdad llegue medio de suerte a las fallas.

Arranque por lo básico, lineas de tension, clock, soldaduras frias, y las pruebas que recomienda el manual de servicios (las que podía hacer con mis instrumentos básicos). La idea era aislar en que placa/s tenia la/s falla/s. Revisé las etapas de salida, desde el DAC que controlan los dos Music LSI hasta la salida de "potencia". Lo pongo entre comillas porque no trae una etapa de potencia este equipo.

El clock fue simple de encontrar, y cuando limpie la placa revisé las soldaduras con un microscopio y encontré mas de una dudosa. El Mux 74LS138 fue por descarte, una de las lineas de habilitación de las memorias nunca se activaba.

Dediqué bastante tiempo a analizar como funcionaba la placa y cambié varios integrados de control, solo porque no encontraba la falla, Cambie los 74ls74, el 74ls138 que habilita las memorias del la CPU principal, el 74ls08.

Solo como nota de color te cuento que también cambie unos TL082 de la etapa analógica y sonaba horrible, tuve que volver a poner los originales... lamentablemente la calidad de los componentes en Argentina comezó a ser un problema. Y eso que compré componentes de "primera línea" en una casa de renombre. En fin...

El estado actual es el que comenté en el post original,

El equipo suena, y suena bien, pero con las excepciones que conté . Cuando lo prendo y toco suena 4 veces, y 4 veces no. (Como si hubiera un contador en algún lado)

Analice todo el circuito del teclado, y la señal pude seguirla hasta que entra a la interfaz de las CPUs "MB64H173", después me es imposible con las intrumentos que tengo porque pasa mucha información por los mismos pines. El punto es que incluso cuando no suena, la señal del teclado viaja hasta la interfaz de las CPUs.

La verdad es que tampoco tengo tantos instrumentos como para seguir la señal mucho mas, solo me queda entender bien como funciona para acotar la busqueda. Por eso preguntaba si alguien tenía experiencia con estos equipos, tal vez se le ocurre alguna prueba.

Para mi la clave para encontrar la falla va por el key split, cuando lo activo la parte baja del teclado no funciona, por eso me gustaría entender como funciona.

1609706007085.png

Gracias por la ayuda.

Buen año.
 
La placa estaba muy tocada, y llena de flux, un desastre:
Lamentablemente, muchas veces hay "tecnicos" por ahi de los cuales tenemos que renegar.


lamentablemente la calidad de los componentes en Argentina comezó a ser un problema.
Si, si. Es lamentable. Los integrados y componentes en general son falsificados.
Pasate por la wiki del foro, para ver otros proveedores; witronica.com/tabla_proveedores

Mientras tanto, voy a tratar de entender el funcionamiento. La verdad me desconcerta la falla. Tambien puede ser que algun firmware o lo que lleve, esté corrupto, al tener componentes mal conectados, y anda a saber si no hicieron algun corto por ahi....
 
1- Cuando lo enciendo con los parametro como inicia, cuando presiono cualquier nota suena, pero solo durante 4 digitaciones (no importa la nota que presione). Después durante las 4 próximas digitaciones no suena, y el ciclo se repite indefinidamente. 4 suenan, y 4 no suenan. Este sintoma tiene una excepción, cuando tengo el preset 4 activo, el ciclo se da de 8 en 8. 8 suenan y 8 no seunan.
Me meto de curioso nomas... y porque estoy aburri... con algunas dudas :LOL:.

¿ Que es lo que hace el preset 4 ?

2- Key Split. Cuando activo el modo key split, la parte baja del teclado no suena. <-- Para mi este sientoma es clave, pero no se que HW (además de SW del micro) controla el key split.

¿ Que es lo que hace el key split ? Suena a que divide el teclado en dos instrumentos independientes.

3- Cuando lo pongo en modo monofonico (Boton "Solo" apretado) funciona bien.

Acá supongo que es como escribo en mi computadora, con un solo dedo y una nota a la vez, osea que si se pulsa un acorde solo suena una nota ¿ Es así ?

Perdón por las preguntas pero el manual de usuario subido es: como bajar el manual (y esos PDF con direcciones ya les tengo rechazo :LOL:).

Yo empezaría a medir continuidad entre el micro principal (uPD7811-180) y las señales de direcciones que van a las dos RAM (Main RAM 1 y 2). Ahí parece que se almacena las secuencias pulsadas.

Por lo que veo el micro principal (Main CPU) se encarga de leer las teclas y almacenarlas en la RAM principal. En tanto que el micro secundario (Sub-CPU) lee de la RAM principal y genera las melodías correspondientes (pasando por el intermediario -CPU interface SPI-).

Si una de las lineas que selecciona las RAM (Adress line) esta "muerta" creo que presentaría una falla como la que mencionas, mas aun cuando las secuencias faltantes son múltiplos de 2, (bit 3 de dirección, pero como una de las memorias esta partida y comparte datos con otras cosas puede ser cualquier linea).

Resumen: Hay 3 bloques que acceden a la RAM principal, yo revisaría que las conexiones a las lineas de direcciones (Adress line) estén todas bien (beep-beep jajaja).
 
¿ Que es lo que hace el preset 4 ?
La verdad que habria que consultarle cual es el preset 4 para el, porque segun el manual es una letra seguido de un numero
¿ Que es lo que hace el key split ? Suena a que divide el teclado en dos instrumentos independientes.
Exactamente. Puedes tener 2 instrumentos en cada parte del teclado, incluso se puede programa de donde a donde
Acá supongo que es como escribo en mi computadora, con un solo dedo y una nota a la vez, osea que si se pulsa un acorde solo suena una nota ¿ Es así ?
Exacto. Monofonico, solo una nota sin importar cuantas toques (modo "solo"), polifonico, mas fe una nota a la vez, con un limite de entre 8 y 16 notas, dependiendo del preset elegido.

Dejo el manual de usuario del 5000, que lo unico que agrega es el secuenciador
 

Adjuntos

  • Casio CZ-5000 Owners Manual.pdf
    5 MB · Visitas: 3
Lamentablemente, muchas veces hay "tecnicos" por ahi de los cuales tenemos que renegar.



Si, si. Es lamentable. Los integrados y componentes en general son falsificados.
Pasate por la wiki del foro, para ver otros proveedores; witronica.com/tabla_proveedores

Mientras tanto, voy a tratar de entender el funcionamiento. La verdad me desconcerta la falla. Tambien puede ser que algun firmware o lo que lleve, esté corrupto, al tener componentes mal conectados, y anda a saber si no hicieron algun corto por ahi....
Gracias DJ, les cuento los avances luego.
Mensaje automáticamente combinado:

Lamentablemente, muchas veces hay "tecnicos" por ahi de los cuales tenemos que renegar.



Si, si. Es lamentable. Los integrados y componentes en general son falsificados.
Pasate por la wiki del foro, para ver otros proveedores; witronica.com/tabla_proveedores

Mientras tanto, voy a tratar de entender el funcionamiento. La verdad me desconcerta la falla. Tambien puede ser que algun firmware o lo que lleve, esté corrupto, al tener componentes mal conectados, y anda a saber si no hicieron algun corto por ahi....
Gracias DJ, les cuento
¿ Que es lo que hace el preset 4 ?
Es uno de los tonos preseteados, trae 32 tipos de sonidos preseteados.
1609763201667.png
¿ Que es lo que hace el key split ? Suena a que divide el teclado en dos instrumentos independientes.
Si, tal cual.

Acá supongo que es como escribo en mi computadora, con un solo dedo y una nota a la vez, osea que si se pulsa un acorde solo suena una nota ¿ Es así ?
Andas bien con la intuición jajaja
Perdón por las preguntas pero el manual de usuario subido es: como bajar el manual (y esos PDF con direcciones ya les tengo rechazo :LOL:).
Al contrario, gracias por la ayuda.

Yo empezaría a medir continuidad entre el micro principal (uPD7811-180) y las señales de direcciones que van a las dos RAM (Main RAM 1 y 2). Ahí parece que se almacena las secuencias pulsadas.

Por lo que veo el micro principal (Main CPU) se encarga de leer las teclas y almacenarlas en la RAM principal. En tanto que el micro secundario (Sub-CPU) lee de la RAM principal y genera las melodías correspondientes (pasando por el intermediario -CPU interface SPI-).

Si una de las lineas que selecciona las RAM (Adress line) esta "muerta" creo que presentaría una falla como la que mencionas, mas aun cuando las secuencias faltantes son múltiplos de 2, (bit 3 de dirección, pero como una de las memorias esta partida y comparte datos con otras cosas puede ser cualquier linea).

Resumen: Hay 3 bloques que acceden a la RAM principal, yo revisaría que las conexiones a las lineas de direcciones (Adress line) estén todas bien (beep-beep jajaja).

Es un buen punto, de hecho una de las fallas mas importante estaba en el MUX que habilita las memorias "deco 3 - 74ls138". Voy a volver a probarlas. Las pistas no creo que sean, porque tiene un bus de datos y uno de direcciones compartido, pero podría ser alguna memoria que no está funcionando.

Gracias por la ayuda, por la tarde lo veo y a la note les comento los avances.
 
Última edición:
Es un buen punto, de hecho una de las fallas mas importante estaba en el MUX que habilita las memorias "deco 3 - 74ls138". Voy a volver a probarlas. Las pistas no creo que sean, porque tiene un bus de datos y uno de direcciones compartido, pero podría ser alguna memoria que no está funcionando.
Esos decoders habilitan las memorias completas y están atadas a las lineas de direcciones (para saber en que dirección habilitar que cosa, ya que cada bloque tiene su dirección específica).
El "deco 3" controla las memorias RAM del subsistema y la parte del DAC. Si todo un banco de memoria (un chip completo) estuviese andando mal porque el "deco" esta haciendo cosas raras a mi me sonaría que fallarían muchísimas cosas y no solo 4 notas intercaladas en una secuencia.

Ojo, puede que medir que las lineas de direcciones lleguen bien a todos lados no significa que no haya un problema, también puede pasar que una de las lineas este en corto y presentar una falla similar.
 
Esos decoders habilitan las memorias completas y están atadas a las lineas de direcciones (para saber en que dirección habilitar que cosa, ya que cada bloque tiene su dirección específica).
El "deco 3" controla las memorias RAM del subsistema y la parte del DAC. Si todo un banco de memoria (un chip completo) estuviese andando mal porque el "deco" esta haciendo cosas raras a mi me sonaría que fallarían muchísimas cosas y no solo 4 notas intercaladas en una secuencia.

Ojo, puede que medir que las lineas de direcciones lleguen bien a todos lados no significa que no haya un problema, también puede pasar que una de las lineas este en corto y presentar una falla similar.
Si, voy a volver a probar solo por impulso, la verdad es que no se como usa las RAMs. Me cuesta creer que pueda ser una pista, porque para formar un tono toma muchisimas direcciones de una o mas memorias y las integra a la salida del DAC. El BA9221 tiene 12bits y el sample rate es algo así como 44.1khz. Un montón de info por cada tono, si una pista estiviera mal sería un desastre.

Mas tarde pruebo...
 
Última edición:
para formar un tono toma muchisimas direcciones de una o mas memorias y las integra a la salida del DAC.

Se tienen 61 teclas, así que con 6 bits ya podes almacenar 1 tecla presionada por byte y te quedan 2 bits para alguna que otra cosa.

No confundas la tecla presionada con el sonido que sale. El micro secundario lee de la RAM que tecla se presionó, y puede o bien buscar en la ROM los datos para generar la melodía, o generarlo internamente junto con otros IC periféricos, o bien las dos cosas anteriores.

(Ojo que no estoy diciendo que así sea realmente, pero yo no tiraría tanta RAM para guardar el tono completo que hay que generar en vez de generarlo directamente a la salida).
 
Finalmente parece que encontré la falla en el circuito Sample/Hold, y pongo parece porque no tengo el TC4053. Mañana lo compraré para reemplazar.

1609816889802.png

La señal analogica generada por las etapas anteriores entra por los terminales 1,2,3,4, y debería salir por los terminales 5 y 12 para estimular a los operaciones, según la secuencia de activación enviada a los terminales A,B,C.

Según medí, esta señal de activación se repite en el tiempo activando una salida, las dos y luego la otra. Sinembargo en la salida 5 nunca tengo señal y en la 12 tengo señal durante 4 digitaciones y no tengo señal durante las 4 próximas.

Parece prometedor... mañana les cuento.
 
Finalmente parece que encontré la falla en el circuito Sample/Hold, y pongo parece porque no tengo el TC4053. Mañana lo compraré para reemplazar.

Ver el archivo adjunto 259905

La señal analogica generada por las etapas anteriores entra por los terminales 1,2,3,4, y debería salir por los terminales 5 y 12 para estimular a los operaciones, según la secuencia de activación enviada a los terminales A,B,C.

Según medí, esta señal de activación se repite en el tiempo activando una salida, las dos y luego la otra. Sinembargo en la salida 5 nunca tengo señal y en la 12 tengo señal durante 4 digitaciones y no tengo señal durante las 4 próximas.

Parece prometedor... mañana les cuento.
Confirmado, era el 4053 el que generaba esa falla, gracias por la ayuda.
 
Arriba