Comunicación serial con Visual Basic 2008

He estado probando su ejemplo, no funciona, al menos a mí si pulso teclas en el Virtual Terminal.
 
Hola META, tambien e mirado lo que ha puesto el compañero,lo unico que he podido habrir
es el ASM, pero como es en basic tampoco me aclaro mucho.
Y TU ADELANTE CON LO NUESTRO , saludos pepe
 
Meta que no te funciono, el circuito en Proteus o en sistema en Visual basic?

El Circuito de proteus cuando lo inicias automaticamente enciende el LED indicando que ya esta n funcionaminto, en el Bisual basic tienes que abri el archivo por defecto tiene el nombre de proyecto1.vbp y de igual forma cuando le das play te indica la hora del sistema y la fecha y te muestra en una textbox que el sistema esta iniciado.

El virtual terminal en proteus es solo para visualizar la letras que estan llegando de Visual Basic al pic por otra parte tiens que usar Configure Virtual Serial Port Driver utilizar com1 y com2 donde com1 es utilizado en proteus y com2 en visual basic.

Otra forma es de iniciar Visual basic y muetra el inicio del sistema y la hora y luego iniciar proteus este encendiendo el led y luego lo apaga y enviando un comando al visual basic lo recibe y muetra en una caja de texto "comunicacion establecida + la hora"


te envio el archivo nuevamente donde incluye en word codido de visual basic y el programa del pic.
 

Adjuntos

Se ve carácter raro.

Asegúrate que el COMPIN es de 9600 de baudios, lo tenías a 2400. El PIC tambiñen debe ser de 9600 baudios. Lo he probado y funciona con carácteres raros o ese es lo que meustra en el Virtual Terminal.
 
Hola willyfv:

He estado mirando el código fuente que me diste.
Código:
; C:\DOCUME~1\UBENCIO\ESCRIT~1\PIC\PICVIS~1\PROGRA~1.PBP    00020    IF SERIAL="S" THEN SONIDOS
    CMPEQ?BCL    _SERIAL, 053h, _SONIDOS

; C:\DOCUME~1\UBENCIO\ESCRIT~1\PIC\PICVIS~1\PROGRA~1.PBP    00021    IF SERIAL ="L" THEN LEDS
    CMPEQ?BCL    _SERIAL, 04Ch, _LEDS

; C:\DOCUME~1\UBENCIO\ESCRIT~1\PIC\PICVIS~1\PROGRA~1.PBP    00022    IF SERIAL ="R" THEN RELES
    CMPEQ?BCL    _SERIAL, 052h, _RELES

; C:\DOCUME~1\UBENCIO\ESCRIT~1\PIC\PICVIS~1\PROGRA~1.PBP    00023    IF SERIAL ="P" THEN APAGAR
    CMPEQ?BCL    _SERIAL, 050h, _APAGAR
Son letras que no me di cuenta.

Para los to@s. Pincha dos veces el componente del RS232 llamado COMPIM y deja los baudios a 9600 como muestra esta foto de abajo. Me lo han enviado a 2400 baudios, por eso no les funciona. Ahora me funciona.



He modificado el programa que puedes descargar y funciona. He comprobado que los tres primeros controla cada Led, el cuarto botón los apaga todos.

En cuanto a Depepee, dame las letras.
 

Adjuntos

Hola:

Te estaba esperando todo este tiempo para que me dieras una respuesta si te funciona como willyfv. Pon el COMPIM desde el proteus a 9600 baudios y prueba.

Letras que envía al PIC son el A, B, C y D. Puedes descargarlo.

El ejemplo que me envió willyfv funiona muy bien cuando los puse a 9600 baudios los dos, tanto C# como el COMPIM del proteus.

Saludo.
 

Adjuntos

Hola Meta,Este ultimo que pusiste a willyfv ni tan siquiera lo he abierto,no sabia que tenia que ver con lo nuestro ahora lo pongo en marcha com el pic y te digo algo,saludos pepe
 
Hola META,mientras me arreglan mi ordenador me he echo de otro, es un portatil y dispone de solo una salida DB9,lo que me pasa es que cuando habro la aplicacion me sale un letrero en el que me dice error IO
el COM2 no existe.saludos pepe
 
Hola META,este ultimo lo habia probado con el "trasto"ahora lo he probado con el portatil y con un tercer ordenador el asunto es que los pulsadores funcionan bien pero lo que son las luces,nada ni pestañean el
pic siempre lo chequeo co hyperterminal y con el PIC RS232-V2.15 BETA,y funciona ha la perfeccion.saludos
pepe
 
Hola meta el pic funciona bien tengo conectados 2 reles y por supuesto cada vez que se efectua un cambio
manda A ò a y B ò b eso lo tengo mas que probado pero las luces del texbox no hacen nada,saludos pepe
 
No baja nada de nada.

[SIZE=+1]File Not Found[/SIZE]

The file you have requested could not be accessed because the file could not be found.

Requested File: K8055_VM110 USB board.zip


http://www.robotsperu.org/foros/visualbasic-vp8392.html





Muy bueno, hay que verlo a fondo.

Estoy viendo los vídeos y tarda mucho, parece muy bueno al menos los primeros minutos.


Si te animas, acaba de instalar otra ves los Visual Studio Express ya que se fastidió Windows 7 y tuve que formatear todo otra vez.

Voy a intentar copiar lo que hace el vídeo a ver si me sale.
 
Última edición:
Arriba