Conexión IR2110 High and low driver Mosfet

#22
No, deja la resistencia de 5.6 y tambien deja la alimentacion de 12V de el gate
Ok. Gracias. Logre disparar el mosfet y que se active la bobina! Podria decir que la etapa de potencia esta lista!!! Pero el problema definitivamente esta en la etapa de control... Luego de colocar una resistencia para proteger el puerto la PC se me apaga igual. Pero algo muy curioso es que esto solo sucede cuando conecto el siguiente pin del puerto "D1" a otro opto del mismo circuito como en la figura (adjunto). Tenes idea de que puede estar pasando?

Ese circuito esta muy mal diseñando, primero el disparo estas haciendo un corto en el puerto paralelo, tambien un corto en la fuente de 12v. supondo por eso la switching de la pc se protege y se apaga.

saludos
Luego de colocar una resistencia para proteger el puerto la PC se me apaga igual. Pero algo muy curioso es que esto solo sucede cuando conecto el siguiente pin del puerto "D1" a otro opto del mismo circuito como en la figura (adjunto). Tenes idea de que puede estar pasando?
 

Adjuntos

Última edición:
#25
El punto actual puede darse por concluido hasta el dia de hoy... 24-dic-2010

P.D. Gracias por dar seguimiento hasta el término del tema.
 
Última edición:
#27
Eso es correcto amigo. Te comento ademas que yo diseñe un circuito similar, pero con la diferencia de que colocaba una resistencia en el surtidor del mosfet, de pequeño valor y potencia considerable. Esto lo hacia para reducir la corriente, ya que el consumo era elevado y producia el calentamiento del mismo. Un saludo
 
#28
Hola a todos,

este circuito estaría bien si quiero activar el mosfet por nivel alto a la salida del micro, verdad?

En principio si, pero en la práctica no, porque? porque seguira conduciendo un rato más, por la "capacidad" del gate, si actua como un capacitor y debe ser puesto efectivamente a masa, paraeso se utiiza dos transistores, o un optoacoplador para mosfet que ya los trae internamente

Asi es en el interior de un CI driver


Lo mismo echo en forma discreta para lo que vos necesitas
 
#29
En el diagrama de arriba, puede soportar 220v y unos 20A (Motor de 2HP), en VCC que voltaje pondria, tiene que ser +/-20v del voltaje de Source.
 
#31
Hola, me pudieras decir si esta bien mi diagrama, tengo varias preguntas cuales tierras tengo que aislar y como, donde faltan resistencias, en el voltaje de gate es 25v, debo poner eso o mas, ya que al mosfet le llegaran 40-47v, ya que el motor consume 80v, esta bien usar relevador de potencia para el control de giro, el driver es el ir2110 y no el ir2112. Por favor ayuda.

 
#32
Hola haks, estas seguro qUE el opto aguanta la corriente para mover el rele ese¿?
Conrespecto al driver ese es mas bien para medio puente o totempole, ya que utiliza el condensador boost para tener diferencia de potencial en el mosfet del lado alto. Bueno a lo que vamos vos por lo qUE veo soN dos motores que conectas a masa, entonces quita el condensadory el diodo de boost qUE pusiste el Vboost conectala a VC (esto hara qUE tengan la misma tension las dos salidas, que por cierto como max debe ser 15 V, sino te puedes cargar el gate) te digo el pinout final,
Pin2,5 a masa
Pin3,6 a VDD (15V)
Cada salida a un mosfet (las masas van juntas)
Para el cambio de giro puedes usar eso mecanico o hacer un puente H .
Que el motor sea de 80V no quiere decir que tenga una caida de tension de tal cantidad, esa es la tension max para el funcionamiento correcto. Mientras este el mosfet apagado en el drain va a haber 120V .
Primero te diria qUE si el motor es de 80 no le pongas 120 por qUE se va a recalentaR y terminara Rompiendo. Si lo modulas por ancho de pulso podrias a llegar a usarlo pero siempre teniendo en cuenta el Duty MAx para no pasarte. yo creo que habria que hacer unos cuantos cambios para ello tendrias qUE dar una explicacion mas detallada de lo que queres hacer.

Gracias por leer
 
Última edición por un moderador:
#33
Hola woutnm, eres la primera persona que me ayuda verdaderamente, voy a agregar como amigo y te envio un MP con mi correo para que me agreges al msn ya que este no es mi foro, jjaja me siento colado, regresando a lo que decia, estoy tratando de automatizar un toro mecanico, te comento mis avanzes por msn.
 
#35
Hola de nuevo.

Pandacba, tenias razón respecto a problemas de descarga de la capacidad de la puerta. Tuve que cambiar el esquema al sugerido por antiworldx ya que la velocidad de disparo necesaria era relativamente alta.

Resulta que he comprado otro optoacoplador para disparar el mosfet a 110kHz y me hace algo extraño que no llego a comprender.

El esquema y la captura en el osciloscopio es la siguiente (amarilla sonda 1, gris sonda 2, rosa sonda 3):



- Corriente en la entrada del opto tampoco, ya que el micro que utilizo entrega 50mA a 3.3V. He probado a meterle 1.4V desde una fuente y aparece el mismo ruido en la salida del opto, incluso sin mosfet.

- Este opto está pensado para entregar 2A, por lo que falta de corriente en la puerta del mosfet tampoco es. El problema creo que es del opto.

He probado metiéndo una resistencia de 15ohm entre la salida del opto y la puerta del mosfet pero tampoco. También a distintas frecuencias y nada. Se llega a encender el diodo led pero en el momento que lo substituyo por el motor (finalidad de la aplicación) no arranca ni metiéndole la PWM al 100%.

No se me ocurre qué puede ser. Aquí el datasheet del opto y el del mosfet

Gracias por la ayuda!
 
Última edición:
#36
Hola cerilet. Te recomiendo que coloques una resistencia de 100 ohm entre la salida del opto y el gate del mosfet, y una de 1 Kohm a masa desde la salida mencionada. Exitos.
 

Temas similares

Arriba