Conexiones para persiana motorizada en ventana

#1
Hola,
He puesto una persiana motorizada y quiero utilizar un sistema de relé o relés con un esp8266 para controlarla, pero no tengo claro como puedo hacer esto.

El motor tiene cuatro cables:
1. Masa (amarillo)
2. Neutro (Supongo que es el azul)
3. Fase (Supongo que es el marron)
4. Gris

He desmontado los pulsadores que accionan el motor para ver como está conectado y veo que la fase va a los dos pulsadores y el gris solamente a uno de ellos. Es decir la fase que sale del motor pasa por los dos pulsadores, y sale hacia el tendido eléctrico y el gris que sale del motor va solamente a uno de los dos pulsadores, como se aprecia en las imagenes.

Lo que quiero conseguir es que la persiana funcione tanto con los pulsadores como con el relé a través del esp8266 indistintamente.

No se si esto se puede hacer con un solo relé o hacen falta dos ni como sería la conexión.

¿Seriais tan amables de indicar como se puede hacer esto mediante algun dibujo?

NOTA: Había pensado utilizar los relés que aparecen en las imágenes.

La persiana pesa poco, es de una ventana de mi casa. Lo comento por si influye por las características del motor, del que desconozco marca y modelo.

Muchas gracias.
 

Adjuntos

capitanp

Miembro irreconocible
#2
fácil, con la fase al marrón sube y al gris baja



2-channel-5v-relay-module-for-arduino-dsp-avr-pic-arm.jpg



ino-dsp-avr-pic-arm.jpg
 
Última edición:
#3
Hola Capitanp,
Muchas gracias por tu pronta respuesta :)
A ver si lo he entendido.
He intentado "traducir" las conexiones y colores a la instalación que tengo en casa.
¿Estan bien así?
Un saludo.
 

Adjuntos

#6
Hola de nuevo,
Hoy por fin he podido realizar todas las conexiones según la imagen última que publique (la del mensaje número 3), pero por desgracia no me ha funcionado como se esperaba. Las he conectado siguiendo fielmente las indicaciones pero nada.

Las funciones subir y bajar si van con la activación de los relés, pero con los interruptores incrustados en la pared no funciona. La persiana no se mueve.

Parece que hay algo que no está conectado correctamente.

Podeis revisarlo a ver si encontrais donde está el problema?

El interruptor es ESTE

Muchas gracias
Un saludo
 
Última edición:
#10
Tengo una duda revisando la imagen que me pusiste y la que he puesto yo:
En la que pusiste tu los cuatro polos de los dos interruptores tienen conexión y en la imagen que he puesto queda libre una conexión, la que se aprecia en mi imagen a la izquierda de la conexión de los cables grises.
 
#14
Según se ve la imagen en el borne superior derecho recibe dos cables del tele el marrón y el negro y el borne de la izquierda tiene conectado el marrón que va al motor

Cuando llegue a casa a ver si lo pinto mejor
 
Última edición:

Pinchavalvulas

Well-Unknown member
#15
Antes de nada asegurarse de que las bornas 1 y 2 tienen continuidad y 3 y 4 tienen continuidad, ambas independientemente. Bornas de la plaquita y contando de izquierda a derecha.
Si es así, mi propuesta es la del adjunto.

Podrías quitar todo y símplemente poner los conmutadores (pulsadores+relés) en paralelo, pero... si le das a subir mediante la plaquita de control y alguien le da a bajar con lo pulsadores.... no sé si habría fuegos artificiales.
Por eso me inclino por mi solución, que es la que ya te habían proporcionado, pero modificada.

El cable rojo sería marrón, le he cambiado el color sólo para que lo veas mas claro.
 

Adjuntos

#17
Creo que lo mas conveniente para evitar que haya un corto, muestro el siguiente diagrama.

ino-dsp-avr-pic-arm.jpg

ino-dsp-avr-pic-arm_20171113184511209.jpg

por ejemplo, cuando el rele este activado para bajar, y se presione el pulsador de subir, esto puede conducir a un cortocircuito, ya que los pulsadores siempre estan alimentados.
Con esa modificacion se aseguran que los pulsadores se deshabiliten cuando se accionen los reles
 
Última edición:

Pinchavalvulas

Well-Unknown member
#18
En principio, si no me equivoco, según lo he propuesto pasa lo mismo.
Mientras no están activados los relés, los pulsadores alimentan el motor a traves de los contactos del relé.
Al activar los relés ya no pasa corriente para los pulsadores, por lo tanto evitamos cortos o derivaciones.

Rectifico, la propuesta de DJ T3 parece la indicada, la mía podría acarrear problemas, no sé por que me había empecinado en que los relés se activaban al mismo tiempo. :facepalm:
Cosa por otra parte imposible, siempre que se hayan programado bien lo que se tenga que programar.

Borren de la mente mi aporte fallido. :oops:
Saludos.
 
Última edición:

capitanp

Miembro irreconocible
#19
Creo que lo mas conveniente para evitar que haya un corto, muestro el siguiente diagrama.

https://www.forosdeelectronica.com/attachment.php?attachmentid=161498&stc=1&d=1510609704

https://www.forosdeelectronica.com/attachment.php?attachmentid=161497&stc=1&d=1510609678

por ejemplo, cuando el rele este activado para bajar, y se presione el pulsador de subir, esto puede conducir a un cortocircuito, ya que los pulsadores siempre estan alimentados.
Con esa modificacion se aseguran que los pulsadores se deshabiliten cuando se accionen los reles
Este tambien esta bueno pero aun ambos tendrían que funcionar, los pulsadores realmente estan funcionando bien?
 
#20
Hola, buenos días,
Efectivamente capitanp, los pulsadores funcionan correctamente sin conectarle los relés.

Esta tarde intento probar con vuestras indicaciones.

Un saludo ;-)
 

Temas similares