Control de Temperatura con PIC y tarjeta atenuadora de carga

#1
Hola, buen día.

Estoy intentando realizar la simulación del siguiente circuito en proteus, (aqui anexo archivos) pero me arroja errores en los componentes, en el caso de resistencias y capacitores, lo solucione seleccionando componentes de algún fabricante y no “genéricos”, pero me marca error por ejemplo en el microcontrolador, en el lcd, etc a pesar de estar especificando el modelo. ¿Alguien que me pueda apoyar diciéndome donde esta mi error?:confused:, se lo agradecería bastante.”
 

Adjuntos

#2
Hola Lalo Orozco
[/COLOR]
Dame un poco de tiempo para analizar lo que adjuntaste

saludos
a sus ordenes
 
Última edición:
#3
Hola Lalo Orozco

Tu esquema es muy parecido al de ramiroabrego(En Monterrey), Tú Lalo Orozco(En Nuevo León, México).
Él está Indagando algo parecido por acá.
https://www.forosdeelectronica.com/f13/simulacion-error-alimentacion-proteus-86962/#post737784

En fin ve las imágenes que te adjunto y decide qué hacer.
En tu esquema faltan algunas cosas por mejorar.
Por alguna razón el transistor 2N2369 no funciona en la simulación sin embargo el TIP41 si lo hace.
Faltan unas resistencias llamadas Pull-Up en cada botón hacia el Vcc.

Los dispositivos que no son simulables márcalos como excluidos para que no te marque error al correr la simulación.

Date una vuelta por el enlace que te adjunte para que veas otras recomendaciones que se le hacen a ramiroabrego.
Quien copió a quien ??

saludos
a sus ordenes
 

Adjuntos

#4
Que tal MrCarlos

ya eche a andar la simulacion, pero al juntar los dos circuitos el del control de temperatura y la tarjeta atenuadora de carga, no me genera errores pero me marca unas advertencias y no se donde es la falla, me podrian ayudar.

adjunto circuito y codigo y una foto de lo que me genera.

Quedo en espera de sus comentarios, saludos!
 

Adjuntos

#5
Hola Lalo Orozco

Ese error que aparece (Ver AA.PNG En el .ZIP) es porque te falta una tierra al MOC3021 U6 PIN 4 y todo lo conectado a ese PIN.

saludos
a sus ordenes
 
#6
Que tal Mr Carlos

en el circuito de temperatura el que no lleva aun la tarjeta atenuadora de carga, al momento de correrlo no me genera errores, pero ya cuando le presiono a los push button me arroja unas advertencias y no se que signifiquen, me podrias ayudar, anexo una fotos de lo que me arroja

Espero tus comentarios
 

Adjuntos

#7
Agrego la simulacion, codigo en hexadecimal y ensamblador, haber si me puden ayudar y decirme porque no estan jalando los botones, se supone que estos me deben variar la temperatura pero no lo hacen.



Quedo en espera de sus comentarios.
 

Adjuntos

Arriba