Descarga de capacitor

#1
Hola a todos, este es mi primer mensaje en el foro. Tengo la siguiente duda, Que manera tengo de tener un tiempo de descarga de un capacitor, mas chico que el de carga? Es decir, en mi caso particular tengo que el capacitor se me carga en 20ms pero se me descarga en mas de 150 ms,y es inadmmisible en mi sistema. He probado cambiar la resistencia para que se descar, osea mas chica, pero no soluciona nada. Se que vienen circuitos de descaga de capacitores con algun transistor pero no conozco ni encuentro ninguno. Cualquier opion sera agradecida.
Muchas gracias!

Saludos
 
#2
Estoy en viaje astral rumbo a Cordoba para ver que corno es lo que tenes armado. Ni bien vuelva, hago 20 minutos de OM y te contesto.
 
#3
Aqui adjunto una imagen del circuito, en la entrada tengo (Lo) tengo una señal cuadrada de 50Hz que es la señal de voltaje de linea de 220V que sendso y acondiciono. A la salida del opto (Hi) deseo tener 5V continuos cuando hay presencia de 220V y 0V cuando no hay, por eso pongo el capacitor. El problema es que el capacitor se carga bastante bien (rapido), pero se descarga muy lento. Esto lo arme en un protoboard y lo observe con el osciloscopio. Los valores que pongo no son los reales, Prove con muchos. Se entiende?

Saludos
 

Adjuntos

#4
Si tenes cuadrada la señal de 50Hz y queres 5V estables a la salida ==> forzosamente el capacitor va tener que descargarse poco durante medio (10ms)

Eso hace que el producto de RC deba andar necesariamente por los 20ms o mayor (ej: C=1uF, R=22k)

Si quisieras menos caida durante los 10ms de '0' , tendrias que agrandar el capacitor o la R y eso significara tambien un mayor tiempo de descarga.

Para el tipo de salida que buscas, lo que se hace es usar un monoestable redisparable. -> El periodo del monoestable es un poco mayor que 10ms y el opto lo va reseteando.
Busca con Google: 555 monostable retriggerable o 555 missing pulse detector
 
#5
Hola eduardo, primero gracias por responder. Segundo te comento que hice lo que me dijiste pero el monoestable no funciona como espero, es decir, siempre tengo una cuadrada a la salida. No logro que sea una continua. El ciruito que uso es el que adjunto y he probado con varios tiempos de RC como dijiste y otros tambien, pero no logro el objetivo. Solo queria ver si podes ver si el circuito es el que planteaste o es otro. Te comento tambien que oprobe poner tambien el Reset junto con la pata 2, pero no hubo caso. Disculpa la molestias y gracias!

Saludos.-
 

Adjuntos

#6
Hola eduardo, primero gracias por responder. Segundo te comento que hice lo que me dijiste pero el monoestable no funciona como espero,
Es que el circuito que mostrás no es redisparable.

Con el 555 hay que actuar directamente sobre el capacitor, algo como en la imagen.

R1 se debe ajustar de manera que alcance la tensión de disparo cuando se cumpla el tiempo en el cual ya se considera falta de tensión (un ciclo, dos... depende de la aplicación)
 

Adjuntos

Temas similares

Arriba