Detectar apertura de puerta y hacer sonar chicharra después de X tiempo

#1
Hola.
Les cuento que tengo la puerta del edificio con uno de esos sensores que detectan cuando se abre, y hacen sonar una chicharra.
La cuestion es que quiero agregarle un temporizador, para que despues de x segundos, si sigue abierta la puerta, recien ahi empiece a sonar.
Alguien recuerda si ya hay algo similar posteado? Mis busquedas no dieron resultado hasta ahora.
Pensé en un detector de distancia tipo HC04 conectado a un Arduino, pero supongo que debe haber algo mas simple.
Espero sus consejos, gracias!
 
#3
Gracias. Bueno, estuve viendo que en éste hilo Temporizador 555
aparece la funcion monoestable del 555.
A partir de ahí, me puse a buscar y encontré este modo de monostable:
Mi idea es ver si se puede interponer entre el sensor y la chicharra este modo del monostable.
El sensor haría de interruptor (SW1) en el diagrama, con lo cual al abrirse la puerta, y cerrarse el circuito del sensor magnético, se activa el monostable y al término del tiempo programado por la combinación R C daría tensión a la chicharra para que suene.
Mi duda es si al cabo de un rato, la salida vuelve a caer, o se mantiene hasta que se vuelva a cerrar la puerta.
 

Adjuntos

Última edición por un moderador:
#6
Bueno, les consulto porque estuve probando y no lo puedo hacer funcionar.
Primero armé el monostable "clásico" con una combinación R C de 10 Megaohms y 2.2 microfaradios, y funcionó, con un tiempo de 35 segundos. Screenshot_20180901-183821.png
Después intenté hacer funcionar el otro, que es el que realmente me serviría: Screenshot_20180828-150124.png
Con la misma combinación R C, pero en este caso, apenas activo el switch que da tensión al circuito, se prende el LED ( la salida se pone en alto) y se queda así indefinidamente.
Se supone que en este caso, debería es esperar los 35 segundos y recién ahí poner la salida en alto. Alguien se da cuenta donde estaría la falla?
Lo alimento con una batería de 9 V, y lo tengo armado en un protoboard.
 

pandacba

Rocker Bear
#7
Ese esquema no funciona ya lo simule y también lo arme y nada
Pero se puede hacer, yo hice algo similar para una alarma de movimiento hace años.
Los esquemas estan en mi taller de la city pero puedo volver a recrearlo
 
#12
Bueno, lo probé con los valores de R1 en 10 Megaohms y C1 en 2.2 microfaradios (son los valores que con el monostable daban 35 segundos de timer), y no me está funcionando.
Probé de poner R1 en 10K para ver si encendía enseguida pero nada, no prende.
Alguien podría guiarme sobre cómo hacer otras pruebas para hacerlo funcionar?
:cry:
 
Última edición:
#15
proba con un valor de 100k en el primer resistor y uno de 220k en el que esta al lado del diodo
Antes de cambiar la primera aumenta a 220K la resistenia en paralelo con el diodo
 
#18
Primero lleva R2 220k y proba
Bueno, hice las pruebas:
Primero llevando R2 a 220K.
El resultado fue que prendió el LED apenas doy alimentación, y ya no se apaga (esperé más de 1 minuto y seguía prendido)
Segundo, pongo R3 a 100K, y no enciende el LED.
Pero pongo el voltimetro entre pata2 del 555 y masa, y prende el LED por 45 segundos y se apaga.
Alguna idea de cómo seguir?
Estoy un poco perdido.

EDITO Y AGREGO:
Encontré este otro circuito:
Circuitos temporizadores sencillos

Screenshot_20180911-125318.png

Lo hice reemplazando el bleeper por una R de 1K, y la R entre pata 6/7 y 8/4 de 100K.
El resultado fue que prende el LED verde durante 25 segundos al darle alimentación, y después se apaga, pero no prende el rojo.
Cómo no tengo bleeper ahora para probar, puse una R de 1K. Estará mal ese valor?
Y qué tipo de buzzer tendré que poner para hacerlo funcionar?
Gracias por sus futuras respuestas :)
 
Última edición:
#19
Puede deberse al tipo de 555, tal como te lo pasado hice muchos y todos funcionaron.
Si no tenes que hacer una forma para que pase un schich y produzca un pulso
 

Temas similares


Arriba