Detectar apertura de puerta y hacer sonar chicharra después de X tiempo

pandacba

Rocker Bear
hay que ver cuanto consume el Zumbador.
Los 555 de buena factura pueden entregar en modo sumidero hasta unos 200mA pero hay muchos que no pasan de los 30-50mA.
Muchos 555 son funcionalmente equivalentes pero internamente tienen sustanciales diferencias con los originales
 
A ver si entendí bien: si consigo un buen 555 debería funcionar el circuito que posteaste?
Y si así fuera, como pido en CABA, Argentina, un 555 "de buena factura"?
Perdón por lo básico de mis dudas, pero soy un aficionado. Y gracias por la paciencia.
 

pandacba

Rocker Bear
Tiene que ser de un fabricante conocido y de ultima comprar varios de distintos fabricantes y probar
Los de ST son buenos y si no poner ese final que te mostre que al habrir pasa por una elevación
con este swich

Este produce pulso en un sentido necesitas uno así para electricidad(el de la figura es neumático)
 
Sigo con mis pruebas y consultas.
Hice el circuito del video de arriba (adjunto un dibujo del circuito), que se alimenta de bateria de 9V y al cerrar el interruptor (por ahora lo hago así, pienso reemplazarlo despues por un reed switch N/C) dispara el timer que a los 10 seg aprox pone la pata 3 en alto.
Hice la prueba de conectar directamente el buzzer (adjunto foto del buzzer abierto, es de los que se ponen a sonar cuando se aleja el iman porque se abre el reed switch), y el timer funciona (lo verifico porque el led prende), pero la señal que entrega el 555 no llega a alimentar el buzzer.
Entonces se me ocurrió hacer que esa pata maneje un transistor bc548b y que así se active el circuito del buzzer (como figura en el dibujo adjunto).
Acá vienen las consultas:
Cuando cierro el interruptor del 555 y a la vez alejo el iman del buzzer (es imitar que la puerta se abre) pasan los 10 seg, se prende el led y suena el buzzer. Pero al abrir otra vez el interruptor, el buzzer queda sonando mas bajo y el led queda prendido muy debil.
Como les dije, soy un aficionado sin grandes conocimientos, pero tenaz y con ganas de aprender y experimentar.
1 - ¿Alguien puede guiarme en lo que haya que modificar para que al abrir el interruptor deje de sonar el buzzer?
3 - ¿está bien elegido el BC548b? (lo usé porque es el que tenía a mano)
2 - ¿el valor de la resistencia R2 es correcto (la que comunica pata 3 del 555 con la base del transistor?

El buzzer se alimenta con tres pilas de tipo reloj que dan aprox 1.3 V cada una con el tester.
Las masas de ambos circuitos (555 y buzzer) las puse en comun.
Gracias por adelantado!:)circuito555conbc548b.jpgbuzzerabierto.jpg
 
Hola, seguramente la salida del 555, no toma un valor de 0V. cuándo debe. Así que la solución es reemplazar la resistencia de base de 1K por una de 4K7 ya que el buzzer consume algunos mA. Además entre base y emisor colocar una resistencia de 10K.
Yo quitaría el LED de ahí.
 
Muchas gracias. Lo voy a probar. Donde podrá ir el led? Necesito una señal luminosa que muestre que la pata 3 está en alto.
 

pandacba

Rocker Bear
Tu configuración tiene varias dificultades porque no estuvo pensado para lo que vos necesitas

El retardo a la conección se puede lograr de muchas maneras, ese no es el problema.
Tu problema es que se retee por completo cuando cerras la puerta y es lo que no ocurre en tu circuito.
Si es un buzzer piezo no debería haber problemas, pero si es de lo que tienen una bobina necesitan un diodo en antiparalelo y un transistor más grande, que maneje más corriente, y en lugar de un led en la base es preferible una resistencia a masa que asegure el apagado
 
Buenas. Sigo perseverando.
El circuito adjunto, les parece que puede sonar como una alarma?
Es una reconstrucción que hago de la plaqueta de unos posts más arriba de este hilo. El transistor es un S9014. La alimentación son tres pilitas de reloj.
 

Adjuntos

Y qué supones que es? Porque en realidad no lo copié. Lo reconstruí a partir de una plaqueta desarmada. Y me vendría bien una opinión experta.
 
Última edición:
No pasa por ahí el punto.
Si tienes la placa, corrobora el relevamiento que hiciste. No tienes que diseñar nada.
Es que la placa está desarmada. Lo hice de modo intuitivo. No se puede reconstruir tal cual era, porque hay partes que hay que deducir. Tenía como un círculo de un material oscuro en el centro que no dejaba ver el circuito. Al quitarlo quedó así, como se ve en la foto de este post. Por eso pregunto acá. Quizá otro pueda deducir lo que yo no.
 

Adjuntos

Claro, el círculo negro al que tú llamas.
Era el circuito integrado que se encargaba de generar el tono, y quizás algo más. El transistor, sólo amplificaba la señal.
Puedes descartar completamente ésta idea y recurrir a otro circuito.
 
Está bien. No se me había ocurrido. Pero cuando hablaste de realimentar la base del transistor, eso significa que si agrego algo al circuito que puse intuitivamente, podría resonar? En ese caso, como sería? O qué me recomiendan leer/buscar para aprenderlo por mi cuenta?
 
Busca, osciladores Hartley, te dará una idea de cómo llevarlo a cabo.
Recuerda que tiene que oscilar a un tono audible, digamos 1 o 2Khz. Digo esto, porque quizás los valores de elementos que encuentres estén calculados para fcias. altas.
 
Buenas!
Decidí hacer el sonido de alarma con 2 555, como leí por este foro. Lo armé y funcionó.
Ahora tengo este otro problema:
Como el circuito se activa cuando se abre la puerta, a través de un Reed switch magnético que se abre, pensé en poner un inversor RTL como disparador del timer 555. Después de un tiempo, ese timer alimenta al 556 que hace sonar el buzzer.
El circuito lo adjunto en foto. El tema es que al abrirse el switch, la tensión en el colector del transistor cae a 3.7 cuando el timer pasa a alto en la salida. Y resulta insuficiente para hacer sonar el 556 con el buzzer.
No me doy cuenta si están mal calculados los valores de resistencia del inversor, o si conviene alimentar con mayor tensión, o las dos cosas.
El transistor es un bc548.IMG_20181105_115448332.jpg
 
Perdón que haga doble post, pero no me deja editar, o yo no lo encuentro.
Me acabo de dar cuenta que está mal dibujado el circuito. En cuanto pueda lo vuelvo a subir corregido. Supongo que será por eso que no respondió nadie.
 

Arriba