Diseñar circuito electrónico output señal PWM.

Si modificar la frecuencia del PWM de Arduino a 100Hz es un problema, entonces no te va a quedar otra que trabajar con la función millis() o la función micros() para una mayor resolución.
 

Dr. Zoidberg

Well-known-Papá Pitufo
Yo he asesorado un alumno que generaba PWM de 100Hz para controlar un servo.
Solo hay que configurar un timer y escribir la ISR asociada a la interrupcion del mismo.
Dependiendo de la resolucion que sea necesaria será mas o menos simple, pero no es gran cosa. Por supuesto, hay que configurar registros de los timers y programar la ISR, por que la API de Arduino no te ayuda en nada
 
Es demasiado lento para pwm, los normales van sobre el kHz pero se puede hacer por software hasta con delays precisamente por lo lento que es.
Con interrupciones se hace con la gorra, 100Hz es lo mismo que el control de fase de la red ya que hay una por cada semiciclo.
Si buscáis por ahí hice un aporte de un dimmer que va con interrupciones y el código es muy pequeñito.
Hay librerias para usar los tienes cómodamente. FlexitimerX donde X es el tóner que quieres emplear. Seguramente existan otras.
 
Buenas de nuevo, aqui vengo con fotos y algun dato más, a ver que os parece.

Lo primero que veais foto del integrado que lleva el motorcillo.

1580741082363.png

1580741122949.png

Por otro lado, viendo que la frecuencia de 100 Hz puede ser complicada para arduino, he pensado en comprar algo ya hecho (ya empezamos con prueba y error...) De este tipo y así nos ahorramos el diseño del arduino y la gestion del mismo:


Mi pregunta es, funcionará? Ya se que nadie puede asegurar esto 100% pero creo que intercalando un regulador de voltaje de este tipo (por ejemplo)


Y por lo tanto el circuito quedaría así:

1580741968367.png

Perdonad por la calidad del circuito, se que es un poco penoso... He tomado como referencia, la parte izquierda y superior como entradas y partes bajas y derechas como salidas.

He introducido un detalle del buzzer que está bajo estudio todavia, la intención es que cuando baje la presión pite, pero esto no me importa de momento...

Espero que me deis vuestra opinion, si veis que la idea "naufraga" como decia algun compañero seguimos con la idea arduino
 
100Hz es una frecuencia re contra hiper ultra baja. El arduino se duerme generando eso. He generado tramas a 400kHz, así que 4000 veces menos es muy lento. Si quieres comprar compra lo que quieras pero no hace falta.

Yo entiendo que te vale con un inversor o no inversor en colector abierto con la resistencia de pullup conectada a la tensión que necesites.
Si no encuentras un transistor tipo BC547 y dos resistencias, la de base y la del colector de pullup.

Con un alimentador de 24 a 5V 1A o menos para el arduino y otro que dé los 9V unos pocos mA basta
 
Buenas de nuevo, aqui vengo con fotos y algun dato más, a ver que os parece.

Lo primero que veais foto del integrado que lleva el motorcillo.

Ver el archivo adjunto 186378

Ver el archivo adjunto 186379

Por otro lado, viendo que la frecuencia de 100 Hz puede ser complicada para arduino, he pensado en comprar algo ya hecho (ya empezamos con prueba y error...) De este tipo y así nos ahorramos el diseño del arduino y la gestion del mismo:


Mi pregunta es, funcionará? Ya se que nadie puede asegurar esto 100% pero creo que intercalando un regulador de voltaje de este tipo (por ejemplo)


Y por lo tanto el circuito quedaría así:

Ver el archivo adjunto 186380

Perdonad por la calidad del circuito, se que es un poco penoso... He tomado como referencia, la parte izquierda y superior como entradas y partes bajas y derechas como salidas.

He introducido un detalle del buzzer que está bajo estudio todavia, la intención es que cuando baje la presión pite, pero esto no me importa de momento...

Espero que me deis vuestra opinion, si veis que la idea "naufraga" como decia algun compañero seguimos con la idea arduino
Las conexiones parecen estar bien. Una opción económica y que no dependa de Arduino sería utilizar un LM555 en modo PWM, lo difícil va a ser que consigas los 100Hz exactos que necesitas. Pero si no quieres dar más vueltas el generador que propones estaría bien, siempre y cuando te permita ajustar el valor de frecuencia.
 
Las conexiones parecen estar bien. Una opción económica y que no dependa de Arduino sería utilizar un LM555 en modo PWM, lo difícil va a ser que consigas los 100Hz exactos que necesitas. Pero si no quieres dar más vueltas el generador que propones estaría bien, siempre y cuando te permita ajustar el valor de frecuencia.
Al funcionar los reguladores de presión como PWM no harán ningún tipo de interferencia con la señal final? No necesito nada para eliminar posibles ruidos?
 
Pues no lo sabemos.

¿Vas a usar todo de golpe o por partes?

Yo empezaría poco a poco, primero una cosa y luego otra.
Pues la idea es probar la bomba solo (la parte de arriba), pero en adelante tendré que poner a funcionar la válvula y el sensor de presión.

Pero mi pregunta va más por la parte de la bomba, al conectar el regulador y el generador de PWM en serie no se si voy a tener algún tipo de conflicto/ruido.

Como comentario a parte deciros que estoy altamente agradecido por vuestra ayuda y por aguantar cualquier barbaridad/locura que haya podido decir. Intento enterarme un poco antes de decir nada, Pero se me pasan todo tipo ideas por la cabeza, del estilo, necesitaré instalar diodos para separar posibles interferencias?
 
¿Que significa el regulador y el generador de pwm en serie? No lo entiendo.
¿Que regulador? ¿El de tensión? ¿El de caudal de la bomba?
¿Que generador de pwm, el Arduino, por fin vas a comprar uno, el 555...?

Si es el regulador de tensión y el Arduino no van en serie, ni en paralelo. Van como van, el Arduino se alimenta de la salida del regulador y el pin de salida va al "driver" que va a la controladora de la bomba.
 
Si miras esquema he obviado el arduino y he insertado un generador de PWM que según descripción del vendedor la tensión del pulso pwm de salida será la misma que entra, pudiendo regular frecuencia y amplitud desde 1 Hz. Por eso entre este generador y la fuente de alimentación de 24v intervalo un regulador de voltaje. Esta configuración no se si me dará algún problema
 
Pues interferencias o ruido no debería haber en absoluto cuando pongas el generador y el regulador de tensión. Aun que vos veas el esquema y te parezcan que los elementos están en serie, en realidad no es una configuración del tipo serie o paralelo, simplemente son componentes que van dispuestos en un orden específico para cumplir una función determinada, pero no por eso decimos que están en serie. Para decir si algo está en serie o paralelo los elementos involucrados deben ser iguales, por ejemplo resistencias, capacitores o bobinas, en esos casos podemos agrupar esos elementos (mismo tipo) y obtener uno equivalente con su respectivo valor.
 
Buenos días!

Os comento que ya he realizado la compra, posiblemente esté un tiempo sin comentar el hilo porque me dan fecha de entrega el 28 de Febrero. En cualquier caso os iré comentando novedades y probaré los elementos y veremos si funciona.
 
Buenas tardes a todos, después de unos días de inactividad os actualizo como va el proyecto (aunque no tengo fotos porque todo lo que he montado es provisional)

Toda la parte hidráulica ha quedado montada, era muy sencilla...

Ahora estoy en proceso de montaje de todas las conexiones eléctricas. He recibido todos los componentes menos el generador de PWM.

Al principio empecé mal porque al recibir los reductores de voltaje probé a enchufar uno con un polimetro a la salida para comprobar que funcionaba. Cuál es mi sorpresa que a los 2 segundos de enchufarlo explota y sale volando... No se si por desconocimiento de lo que hice, juro que el positivo y el negativo estaban en su sitio...

Total que ya desconfié de esos reguladores de voltaje...

Hoy he terminado las conexiones a falta del PWM. Pero para intentar simular (Ya que es una señal a 9V) he comprado una pila de 9v y la he conectado al puerto de PWM, y no ha reaccionado.

Como tenía 2 reguladores de voltaje aún a sabiendas de que podía explotar, realicé todo el conexionado para el sensor de presión (Que funciona a 5v) y he podido comprobar que funciona correctamente.

Que opinion teneis respecto a la explosión del regulador? A que se ha podido deber?

Mañana hago unas fotos del cuasimontaje
 
Buenas tardes a todos, después de unos días de inactividad os actualizo como va el proyecto (aunque no tengo fotos porque todo lo que he montado es provisional)

Toda la parte hidráulica ha quedado montada, era muy sencilla...

Ahora estoy en proceso de montaje de todas las conexiones eléctricas. He recibido todos los componentes menos el generador de PWM.

Al principio empecé mal porque al recibir los reductores de voltaje probé a enchufar uno con un polimetro a la salida para comprobar que funcionaba. Cuál es mi sorpresa que a los 2 segundos de enchufarlo explota y sale volando... No se si por desconocimiento de lo que hice, juro que el positivo y el negativo estaban en su sitio...

Total que ya desconfié de esos reguladores de voltaje...

Hoy he terminado las conexiones a falta del PWM. Pero para intentar simular (Ya que es una señal a 9V) he comprado una pila de 9v y la he conectado al puerto de PWM, y no ha reaccionado.

Como tenía 2 reguladores de voltaje aún a sabiendas de que podía explotar, realicé todo el conexionado para el sensor de presión (Que funciona a 5v) y he podido comprobar que funciona correctamente.

Que opinion teneis respecto a la explosión del regulador? A que se ha podido deber?

Mañana hago unas fotos del cuasimontaje
Pues sin fotos de como lo has conectado el regulador no podemos adivinar, al menos un esquema de conexionado del componente.
 
Sin duda se debe a que ha explotado...
Pues ni idea, mala conexión, mal montaje, mal algo.
Yo compré unos reguladores que llevaban un diodo al revés...

A saber.
 
Arriba