Problema con temporizador mosfet

#1
Muy buenas tardes compañeros!

llevo unos dias loco a cuenta de un circuito.

la intencion es hacer que una carga permanezca activa durante unos 7seg aproximadamente tras accionar el pulsador, he numerado los componentes que utilizo para que lo entendais perfectamente.

mi pregunta es: segun un programa (liveware) tras accionar el pulsador el mosfet deriva por el drain corriente para accionar la carga durante 7seg aproximados.

en la practica mi problema es que tras pulsar, el voltaje va bajando poco a poco de 12v hasta 0v y no consigue que la carga permanezca activa durante el tiempo que quiero.

he comprobado todos los componentes y estan correctos, que puede suceder??

expongo el circuito a continuacion.

saludos!
 

Adjuntos

#2
Hola, sucede que ese circuito, polariza al transistor en una zona lineal, debes buscar algún comparador de tensión por rampa o utilizar el temporizador con el famoso 555.
 
#3
Reemplaza el MOSFET por un transistor BC548 y que accione un rele, y que la salida del rele accione la carga, va a ser más eficiente. En vez de poner una R fija, puedes poner un preset para ajustar el valor al tiempo que tu quieres.
 
#4
Es que lo raro es que he visto videos donde funciona el circuito de esta manera para la funcion que quiero. Pero en la practica la carga no aguanta los segundos que necesito. Dejo un ejemplo:

 
#7
Reitero, ese circuito NO sirve para esa aplicación, si quieres seguir dándote dolores de cabeza, continua así.
Sino, busca un temporizador con 555, que es lo más simple.
Einstein dijo "No pretendamos que las cosas cambien si seguimos haciendo lo mismo".
 
#8
he comprobado todos los componentes y estan correctos, que puede suceder??
Para mi lo que te está pasando es que el pulsador tiene rebotes. Es decir cuando vos soltás el pulsador el mismo rebota varias veces (activa y desactiva, esto se puede ver con un osciloscopio). Al rebotar, la carga del capacitor termina yendo a la carga y se mete por el drenador del mosfet. Entonces no te dura lo que tiene que durar.
 
#9
foso dijo:
Para mi lo que te está pasando es que el pulsador tiene rebotes. Es decir cuando vos soltás el pulsador el mismo rebota varias veces (activa y desactiva, esto se puede ver con un osciloscopio). Al rebotar, la carga del capacitor termina yendo a la carga y se mete por el drenador del mosfet. Entonces no te dura lo que tiene que durar.
Dudo que venga por dicho problema, pero si fuera asi colocando un diodo 1N4148 antes del pulsador en serie evitaría ese problema.
 
#10
Como te han dicho, cambia de diseño, los mosfet se comportan como resistencias variables, por eso a medida que baja la tensión se refleja en la salida.
 
#12
Reitero, ese circuito NO sirve para esa aplicación, si quieres seguir dándote dolores de cabeza, continua así.
Sino, busca un temporizador con 555, que es lo más simple.
Einstein dijo "No pretendamos que las cosas cambien si seguimos haciendo lo mismo".
podrias ayudarme con el esquema?? no doy con ello por mas que busco por internet...

la idea es transmitir una señal de -12v durante 10seg tras pulsar un pulsador de cerrar.

gracias!
 
#13
Te dejo este link donde muestra como es la configuracion de un monoestable con un 555. Con la ecuacion calculas el tiempo que necesitas a partir de los valores de los comoponentes. La salida es positiva +12V.
 
#15
Pues utiliza un transistor a la salida para tener lo que quieres. Es para un auto?? Aplicacion?
El primer esquema que propusiste no entrega -12V, solo pone a masa, o sea 0V, la carga. El que yo propuse junto con un transistor a la salida haria lo mismo.
 
Última edición:
#16
Pues utiliza un transistor a la salida para tener lo que quieres. Es para un auto?? Aplicacion?
El primer esquema que propusiste no entrega -12V, solo pone a masa, o sea 0V, la carga. El que yo propuse junto con un transistor a la salida haria lo mismo.
Una pregunta... 0v y -12v no es lo mismo?

Es para que el auto suba los vidrios al pulsar el botón de cerrar.
 
#17
Por supuesto que 0V y -12V no son lo mismo. Si es para el auto, nunca vas a tener -12V, o son +12V o 0V. La punta negra del tester va al chasis y con la roja mides, veras que esos son los 2 valores posibles que podras encontrar. Ahora si invertes las puntas si tendras los -12V, pero estarias midiendo mal. Como dije antes el circuito que te puse te sirve, utiliza el circuito ese y a la salida donde esta el led pon la pata gate del mosfet del circuito que tu publicaste, las demas patas drain y source van tal cual esta en tu esquema

 

Temas similares

Arriba