Problemas con el puerto paralelo

#1
hola!! estoy trabajando en un proyecto para la facultad en el cual deseo medir la velocidad de un movil mediante el uso de dos sensores pasivos de movimiento... la consigna es que se trabaje con el puerto paralelo (db25). todo lo que es software esta solucionado, al igual que el funcionamiento de los sensores. el problema surge de que los pines del registro de entrada que utilizamos (10, 11, 12, 13, 15) cuentan con una tensión de 5v por ende, no registra el ingreso del sensor (valor de i 379h: 7f, sin tener nada conectado!). podrian darme una mano?
 
#2
Tenes que subir el esquema para que te puedan dar una mano, de lo contrario hay que imaginar como son las conexiones y eso si que es difícil.
 
#3
el tema del esquema esta resuelto, el unico problema es que los pines de salida tienen tensión, ese es el tema que necesito solucionar--- igual voy a digitalizar el esquema asi lo subo tambien...
 
#4
el tema del esquema esta resuelto, el unico problema es que los pines de salida tienen tensión, ese es el tema que necesito solucionar--- igual voy a digitalizar el esquema asi lo subo tambien...
Tiro de cabeza pero recuerdo que los pines de entrada no tienen de polarización. si los pones a nivel alto o bajo no pasa nada de nada. Bueno si: que puedes leer el nivel alto o bajo.
 
#5
En verdad no entiendo muy bien cual es el problema.
Los pines de entrada tienen su estado "natural" en ALTO (5v), entonces la forma como se recoleta informacion es poniendolos en bajo.
Como te dicen, si subes un esquema se te puede dar una solucion mas facil a tu problema, la cosa de imaginarlo todo no es sencillo.
 
#8
Hola.
Estaba intentando leer por el puerto paralelo y funciono unas pocas veces,pero ahora ya no hace nada y los pines de entrada me dan 4.8v y los de salida 3.5v.
Se rompió o estoy haciendo algo mal?
 
#9
Hola, obviamente con tan poca información que brindas es difícil saber si rompiste algo o no...ya que puede ser una cuestión de software y que no especificas como lo estas haciendo.

así que de entrada, la pregunta obligada es:

¿como estas cambiando de estado los pines de entrada del puerto paralelo?

Con una fuente externa o tomado como referencia los propios pines del puerto paralelo, un pequeño diagrama ayudaría y también saber si ya has tomado en cuenta que un pin de entrada viene invertido (en su lógica electrónica) y es el pin de Busy.

Y por otro lado saber que metodo de lectura/escritura estas haciendo, me refiero a si ocupas una DLL y con que lenguaje de programacion y sistema operativo ocupas.

Saludos
 
#10
uso windows con java y la libreria jnpout32.
Descarto problemas del software porque funciono,lo deje abierto por un rato y ya no funciono mas.
para hacer las pruebas use una salida del lpt con una resistencia de 1.8khom y lo conecte en el pin 12 del lpt. (las salidas funcionan bien y dan 3.5v)
eso funciono unas 4 o 5 veces que pulse el switch.
Yo creo que se rompió el puerto porque no debería de tener tensión en los pines de entrada.
 

Temas similares

Arriba