Problemas de sobrecalentamiento en un 2xTDA2003

#1
he armado un amplificador de audio, esta provisto de 2 TDA2003, colocados en puente, para sumar sus portencias y acen un total de 18W. es estereo, tiene 2 amplificadores identicos, uno para cada canal.

el diagrama lo he cogido de esta hoja de datos:
http://www.datasheetcatalog.org/datasheet/unisonic/UTCTDA2003.pdf

el circuito en si es el que aparece en la pagina 6, la figura numero 20.

mi problema en definitiva es que uno de los amplificadores de sobrecalienta, lo he probado y es solo uno de los tda2003, de ally viene todo el calor mi teoria era que tenia oscilaciones en el chip, pero como arme 2 zonas identicas en cuanto al circuito, deverian ambos sobrecalentarse, y solo lo ace uno, por loq ue descarte esta teoria. tambien pense en que los fabricantes de los chip son diferentes, 2 son de la st y los otros de la uct, pero estan alternados, es decir uno de cada uno a cada amplificador, supongo que esta teoria es la mas posible, devido que encuanto al pcb, esta correcto, lo he revisado como 4 veces, y no he encontrado ningun error, sin embargo les dejo adjuntado el pcb.

desde ya muchas grasias, y porfabor ayudenme a solucionar este problema.

pues he solucionado el sobrecalentamiento, pero haora, el amplificador que no se sobrecalentaba ya no funciona, lo que ise fue aislar del radiador a los 2 tda de uno de los amplificadores y dejo de sobrecalentarse, pero haora lo unico que suena es un ruido estruendoroso en el parlante, y el otro simplemente no funciona, le coloco audio en la entrada y suena el ruido mas el sonido que le injecto (una cancion de mi pc), la ganacia es buena, la potencia igual, pero el ruido enegrese el sonido resultante, eto claro por uno de los parlantes, el otro ni reacciona... como se daran cuenta, estoy bastante liado... agradeceria un poco de ayuda...
desde ya grasias
 

Adjuntos

Última edición:
#2
creo que el problema lo tienes en el integrado de salida, a mi me paso lo mismo pero con un tda 2030 uno se calentaba mas de la cuenta y el otro no.
comprueva si tienes audio en el primer c.i,si tienes audio en este pero en el otro no pues lo mas provable es que este a pasado a mejor vida.los disipadores si puede montalos independiente,los del canal L por un lado y los del canal R por otro,lo del ruido es por el filtrado de la alimentacion o incluso de los propios integrados .comena resultados
 
#3
¿Con qué tensiones se están alimentando los TDA?. Comprueba que le esta llegando la tensión correcta directamente en las patas de cada integrado.

Que estén montados los 4 integrados en un mismo disipador no es problema, ya que sus chasís (pestaña disipadora) estan conectados a GND. Cuando se deben conectar aislados uno de otro es cuando se usa fuente simétrica, pero no es el caso aquí.

Eléctricamente el diseño del PCB está bien, mas no se si se encuentra de la misma forma tu tarjeta armada, revisa si no tienes algún corto o pista cortada.

El ruido generado seguramente se debe a tu mal ruteo de pistas y localización de componentes, hay demasiadas derivaciones de GND.
El capacitor de filtrado debe ser cuando menos de 2200uF, recomiendo 4700uF.

Lo más seguro es que uno de los TDA recibión un golpe de tensión o se hizo un corto circuito del que no te precataste, por lo cual seguramente está dañado. Una forma de hacer un simple dianóstico es midiendo el voltaje en la pata 4 de los TDA, debe haber cerca de la mitad de VCC.

Saludos.
 
#4
pues les cuento, he agregado una resistencia conectada al pin de entrada del amplificador, y el ruido se fue, bueno casi todo, me percate lo del ruido por la fuente que esta en la misma placa, y lo de las derivaciones, es cierto son muchas y una tras de otra, pero lo solucione cortando la pista que alimenta los tda, y lo puentie con un cable de unos 5 cm, y el ruido desaparecio, casi todo, pero almenos haora es aceptable, ha y otra cosa, en paralelo a la resistencia que agrege, le coloque un condensador, la resistencia es de 20k, el condensador es de 0.22 microfaradios, es ceramico.

pero, mientras acia las pruevas, el otro canal, el que estaba bueno, dejo de funcionar, sin mas, ya no anda, no hay voltaje en las patas 4 de cada tda con respecto a gnd, con o sin audio, por loq que pienso que se quemaron ambos, como no tengo idea, menosmal que el amplificador es para una impedancia de 4 ohm. pero estoy conforme con el ampli, ya di por perdidos esos tda que no andan, asiq ue los desconecte del +B.

grasias por su ayuda
 
#5
De nada, estamos al pendiente. ;)

PD: Revisaste que voltaje le estan llegando a los TDA, por que si sólo cambias y no revisas bien seguramente se dañarán los nuevos.
 
Última edición:

DOSMETROS

High 2m Modereitor
#7
Con 19 Vdc puede funcionar , de hecho yo he probado ese mismo circuito con 20 Vdc y funciona.

Lo que te aconsejo es que le cambies los dos capacitores de 0,1 uF que van de las patas 4 a masa , por dos electrolíticos de 1 uF y se sanseacabaron las oscilaciones (y) .


Saludos !
 
#8
Con 19 Vdc puede funcionar , de hecho yo he probado ese mismo circuito con 20 Vdc y funciona.
Yo he hecho un aplificador con unos TDA2030 y TDA2050 y los alimentaba con unos 30V, en reposo funciona bien, cuando les estoy metiendo potencia es cuendo se sobrecalientan y llegan a quemar el dedo. :LOL:

Sólo hacia la pregunta para saber si no te estabas excediendo demasiado con el voltaje.
Lo que te aconsejo es que le cambies los dos capacitores de 0,1 uF que van de las patas 4 a masa , por dos electrolíticos de 1 uF y se sanseacabaron las oscilaciones (y) .
Con esta solución no se estarían atenuando un poco los agudos??, ya que un cap mas grande actua como derivador a masa para altas frecuencias.
 

DOSMETROS

High 2m Modereitor
#9
Con ±30 Vdc :D ? tenía proyectado probar hacer un ampli con un TDA2050 a unos 70 Volts (±35V) , pero excitando un par de salida TIP35 - TIP36 , o sea que si se bancan la tensión , no les exigiría corriente . . . a ver si sale . . . o sale humo :LOL:

********************************************************

Lo de reemplazarlo por 1 uiF no es invento mio , lo he visto en equipos "profesionales" :unsure: jaja . Si se le bajan los agudos al TDA2003 en ese circuito , le agrega un pequeño capacitor en paralelo con la resistencia de 620 ohms y listo.

Tengo tirados por ahi un montonazo de esos TDA2003 , estoy por hacer un puente pero a 28 Vdc y poniendolos de a dos o tres en paralelo . . . a ver si sale algo :rolleyes:. Habrá que ponerle resistencias de 0,5 a las salidas ? A probar !

Y el otro proyecto es hacer una especie de clase G o H con ellos para aumentarles la tensión cuando van a batería (ya se que existe echo ;))

Sería un puente , seguramente de a dos en paralelo , y tengo dos opciones , o la salida de uno boostrapea la alimentación del otro , o armo otro puente amplificador para duplicar la tensión . . . veremos :LOL:.

Me voy a entretener torturando 2003's y mis oidos :rolleyes:

Saludos !
 
#10
Con ±30 Vdc :D ? tenía proyectado probar hacer un ampli con un TDA2050 a unos 70 Volts (±35V) , pero excitando un par de salida TIP35 - TIP36 , o sea que si se bancan la tensión , no les exigiría corriente . . . a ver si sale . . . o sale humo :LOL:
NO!!! :D, como crees que les voy a meter ±30V, los 2030 solo soportan ±18V. Los alimento con 30V, fuente normal, no simétrica, los ICs están en configuración en puente.

Con repecto al 2050; éste sólo soporta ±25V, ±35V es demasiado, creo que hasta sólamente en reposo van a calentar. :LOL:
A menos que pase como el video del ''Súper PIC'' que no se quemaba al subirle el voltaje y de ninguna otra manera; estoy seguro que lo viste. :LOL: :LOL:
Lo de los transistores casi no le veo el sentido, yo pienso que si se los pones sólo vas a tener al 2050 como un preamplificador o un driver; es mi opinión, je.

Lo de reemplazarlo por 1 uiF no es invento mio , lo he visto en equipos "profesionales" :unsure: jaja . Si se le bajan los agudos al TDA2003 en ese circuito , le agrega un pequeño capacitor en paralelo con la resistencia de 620 ohms y listo.
Qué nivel de ''profesionalismo tenía ese amplificador??????? :LOL: :LOL:

Lo más común que he visto es poner a la salida un capacitor de 0.1uF en serie con una resistencia de 2.7 Ohms a tierra. Según leí y recuerdo, sirven para evitar oscilaciones y que el amplificador vea a la bocina (parlante) como una carga lo más estable posible, ya que las respuestas de la bocina varían con la frecuencia y por lo tanto, su impedancia.

Tengo tirados por ahi un montonazo de esos TDA2003 , estoy por hacer un puente pero a 28 Vdc y poniendolos de a dos o tres en paralelo . . . a ver si sale algo :rolleyes:. Habrá que ponerle resistencias de 0,5 a las salidas ? A probar !
Pues yo creo que de potencia sólo aumentará ligeramente, lo que si lograrás es que no se calienten tanto con ese nivel de tensión. :LOL: :LOL: :LOL:
Yo creo conveniente poner resistencias a las salidas para poder poner en paralelo los TDAs, yo creo que de 0.22 Ohms estarían bien.
Ahhh, y una buena protección anti-DC a las salidas, por temas de quemar el parlante. :LOL:

Me voy a entretener torturando 2003's y mis oidos :rolleyes:
Suerte con tus prisioneros de guerra, recuerda que no puedes matarlos, o al menos, trata de no matarlos, jajajaja.
 

Temas similares

Arriba