Programador de microcontroladores PIC y memorias por puerto USB PICKIT2 CLONE

estuve viendo el diagrama del pickit2 y queria preguntar para que sirve el led de target?
Para indicar que la placa que estás programado está alimentada...acá de todas maneras sirve para indicar que hay alimentación.

por que en tu diseño de Moyano es un pushbotton y en el de felix es un switch que se queda conectado?
Lo del botón ya lo he explicado varias veces en el post...usá el buscador para entender mejor o google. Ahí aparece la función exacta del botón.

y
solo tengo que agragar una resistencia para agregar el pin "aux" para poder programar memorias 24c08 o 04??
Las resistencias son necesarias para el puerto I2C de las memorias.
 
Hola buen dia a todos, como andan ?, ayer estaba programando muy tranquilamente un pic 16f877a hasta que le llego la hora a mi programador ( pickit2 clone)... así de un momento al otro, me apareció en el software de pickit2 PICkit 2 not found. check USB connections and use tools....(imagen 1), pero lo raro que también me apareció arriba All protect, en ningún momento protegí el pic, así que probé con otro, al darle clic a read me intenta leer el pic y nuevamente misma pantalla... así que ahí saque la duda que no era el pic sino el programador.
Realice el Troubleshooting si conectarle ningún pic, el pin VPP= 11.4v VDD=4.8v y pasa la prueba joya, pero al conectarle un pic falla todo, no me da VPP ni VDD como en la imagen (3,4,5).
hace unos días le tuve que conectar una fuente externa de 5V con un lm7805, porque el VDD era bajo, así que saque el pin VDD del programador y lo puse directo al pic desde la fuente y ahí seguí grabando sin problemas hasta hoy :eek:
Ahora alimentado con la fuente externa me aparece como en la foto 1 y no puedo hacer nada :(, espero que alguien me pueda dar una mano, no la tengo muy clara con el circuito, les dejo una foto del programador, le tape por las dudas la marca del vendedor... muchas gracias, Saludos :)
 

Adjuntos

Buenas quisiera que me ayudaran con un problema con el Vdd de mi programador en mi caso utilizo un porgramador de Cana-Kit, me aparece un error de Vdd al solo conectar el programador y abrir el software pra pickit2
 
si es por problema es de hadware... puede ser que tengas algún problema de alimentación, prueba con alimentación externa (asumo que no estas teniendo reconocimiento del dispositivo después de abrir el
el pickit2)


ten en cuenta, si es usb el voltaje es de +5V (un cargador con ese voltaje puede servir )


saludos!
 
Última edición:
extrapalapaquetetl

Este thread lo comenzó Moyano Jonathan hace más de 5 años, y el PicKit2 Original ya tenia su tiempito en uso. Muchos de nosotros, y me incluyo, lo hemos realizado siguiendo este thread.

Por otra parte, mirando la Datasheet del PIC16F1824 en la web de Microchip veo una edición 2010 y Preliminar, creo que con eso esta todo muy dicho.

Aparte que hace años pusieron en venta el PicKit3!.



Saludos, JuanKa.-
 
Este thread lo comenzó Moyano Jonathan hace más de 5 años, y el PicKit2 Original ya tenia su tiempito en uso.
Como pasa el tiempo sinceramente....

El pickit2, de manera NO - Oficial, se le puede realizar actualización de los dispositivos soportados...siempre y cuando el dispositivo nuevo que se le quiera agregar..cumple con el protocolo
de programación de algún dispositivo preexistente. En mi caso por ejemplo le agregué soporte para
el PIC18F27J53 por que quería hacer algunas pruebas y los resultados fueron muy positivos.

En el siguiente enlace pueden encontrar más información relevante: http://www.microchip.com/forums/m559429.aspx
 
Lo tenés que conectar por ICSP, de la forma en que te pongo en la inmagen. La distribución de pines del clon es la misma que la del pickit2 original.
Hola Moyano excelente post, también quiero armar mi PICkit2 , pero tengo una duda en el esquema aquí adjunto en el conector J1 del Pickit la patita 5 clock va a masa esto está bien?
Saludos y felicitaciones.
 
Estimados compañeros
despues de conocer lo bueno del pickit2 me lance con todo lo aqui expuesto a montarme el propio. Bien todo listo montado, probado, todo bien hasta que al ponerlo en marcha me dice ¡No hai nada conectado¡ arranca bien ,listo para funcionar pero no device
He hecho todo lo aqui expuesto y nada de nada , lo que e llegado a ver es que en RA4 PGD y RB5 PGC no ai salida ninguna ,al comprobarlo
Pero con uno original todo esta bien. Algun caso parecido

Gracias .por esa ayuda que se no me vais a negar
 
Gracias Edonord .El esquema el de felix
Alimentaciòn propia (creo usb por lo menos aquì tengo toda la targeta) .Aclaro en la ventana de control VDD target solo se me activa el /mcrl lo activo y desactivo sin problemas ,pero check no me deja
esta ventana me dice Pickit2 found and connectect

ahora le digo leer y contesta con "No device detected" .Con cualquier pic que ponga
Y sigo sin tener ninguna señal en RA4 y RA5

Si pongo alimentaciòn exterior me salta el aviso de voltàge VDD2



Se me olvidaba tampoco tengo señal de target en el usb
ya no se que mas mirar
El circuito esta rebisadìsimo montado cinco beces con el combio correspondiente de componentes
a todos os a funcionad el pk2023200
 
Última edición: