Ruido en DC afecta a Pic's

Buen dia Compañeros

Tengo un Problema.

Diseñe una tarjeta con 2 microcontroladores PIC18F4550, estas tarjetas controlan un proceso de un producto alimenticio. el 90 % de las cargas son resistivas, y las controlo con salidas optoaisladas PC817 en Emisor común, esta salida va a un Relevador de Estado solido. hay otras 2 salidas las cuales llevan carga inductiva, son 2 motores de 1 HP 220 VCA monofásicos, los cuales a petición del cliente se controlan con contactor, este contactor lo controlo con el PC817 y un TIP41C en emisor común, la bobina es de 24VCD.

el problema es que, agregaron mas líneas de producción y agregaron mas cargas Inductivas y me esta generando ruido(como se muestra en las imágenes adjuntas) en la salida de la fuente de alimentación, el ruido solo se genera cuando se activan o desactivan los motores de 220 VAC.

este rudio provoca que los PICS se congelen y dejan de funcionar, tengo que reiniciarlos cada vez que se apaga y prende el motor.

la fuente de una Phoenix Contact 2902992 de 24VCD a 2.5 Amperes. y regulo con un LM338 para 5VCD.

Los pics tiene un capacitor de 22 pF justo abajo de las terminales de VSS y VDD. tengo capacitores de 47 uF a la entrada de VCD de cada PIC lo mas cerca posible de los pines.

la fuente de 24VCD es de buena calidad.

alguien tendrá alguna solución?

todo estaba bien hasta que llegaron las nuevas líneas, cabe aclarar que las nuevas líneas utilizan igualmente mi tarjeta para funcionar.

les agradezco su apoyo de antemano.
 

Adjuntos

  • VideoCapture_20210511-171826.jpg
    VideoCapture_20210511-171826.jpg
    54.5 KB · Visitas: 13
  • VideoCapture_20210511-171907.jpg
    VideoCapture_20210511-171907.jpg
    56.6 KB · Visitas: 13
Esas imagenes que compartiste son medidas en que punto de tu circuito?
Tendria que verse el layout para ver si hay ground loops. Colocar condensadores de bypass en el lugar correcto de 100nF previene este tipo de problemas. El pin de reset de los uC debe estar con una pullup y un condensador de 100nF lo más cerca al pin y con una buena conexion a VSS. Es curioso que tengas un problema de este tipo a pesar de los opto.

Primero prueba subir el de 22pf a 100nF, quizas eso baste.

saludos

Edito: En lugar de bajar el voltaje de 24 a 5 con el LM338 (mala jugada) , compra una buena fuente de 220VAC a 5VDC. :
Código:
https://www.mouser.com/ProductDetail/MEAN-WELL/MDR-10-5?qs=umBTOZqEewixAG46sNKJTA==
 
Última edición:

Dr. Zoidberg

Well-known-Papá Pitufo
alguien tendrá alguna solución?
Si: tirá ese sistema y usá un PLC. Es mas rápido eso a que aprendas a desarrollar un fuente de alimentación apta para entornos industriales.

PD: por algo todo el planeta usa PLCs en la industria, no?

PD2: Mirá esto por si te sirve, pero yo usaría un PLC.
 
Había en el foro un hilo con recomendaciones especiales de como evitar esos problemas con los PICs que al parecer son en exceso vulnerables a ese tipo de cosas, pero no logro encontrarlo, posiblemente el usuario/moderador D@rkbytes pueda ayudarte.

¿Qué tipos de filtros usaste? ¿prestaste atención al pin de reset que tenga un buen filtrado?, además de lo que ya se mencionó arriba.
 
Tengo una resistencia de 10K Ohms al pin de reset como PullUp.

Dr. Zoidberg este sistemas es demasiado para un PLC, es como matar una hormiga con un tanque.
Phoenix contact es mejor marca que MEANWELL kiwhilario
pero buscare una fuente ABB o ALLEN BRADLLEY para probar de 240 VCA a 5 VCD

Acabamos de terminar el mismo sistema pero con arduino Mega en vez de los pics. lo probamos y le pasa el mismo problema.

Como podría eliminar ese ruido?
 

Dr. Zoidberg

Well-known-Papá Pitufo
@Dr. Zoidberg este sistemas es demasiado para un PLC, es como matar una hormiga con un tanque.
No te entiendo el comentario: o es demasiado el sistema (difícil) o es demasiado el PLC, pero si considerás que funciona mal y sus fallas detienen la producción, el precio de un PLC es nada en comparación con lo que pierden de producir.
Hacé lo que quieras, pero ya empezaste mal...
 

DOSMETROS

High 2m Modereitor
Ya se trató quinientas mil veces en el foro que no se puede alimentar motores y pic's con la misma fuente , uses el filtrado que uses , aunque podés probar unos capacitores de 100nF y filtros de línea . . . no vendrían mal . . .

Acabamos de terminar el mismo sistema pero con arduino Mega en vez de los pics. lo probamos y le pasa el mismo problema.

Hasta que aprendas que no se usa profesionalmente ni industrialmente Pic's , ni Arduinos , ni ninguno de esos "juguetitos" , profesionalmente se usa PLC , como mínimo un LOGO. Suerte !
 
Esto se ha comentado muchas veces.
  • Fuentes separadas y de muy buena calidad
  • Bajar impedancias al máximo. 10k es aberrantemente grande, bájala a 470Ohms si puedes a 220Ohms
  • TODO optoacoplado TODO-TODO y con muy baja impedancia
  • Poner entradas diferenciales
  • Cableado de calidad y separado
  • Rezar
  • Poner fuentes de mejor calidad
  • Revisar el programa
  • Rezar mas
  • Poner watchdog por si se cuelga el programa
  • Rezar aún mas
  • Poner otro watchdog por si se para el oscilador
  • Quitar todos los delays
  • Poner varistores en todos los sitios L-N N-Pe L-Pe, en las salidas
  • Poner filtros
  • Orar
  • etc
No sé si me dejo algo
 

Daniel Lopes

Miembro Geconocido
Hola a todos , jo personalmente alen de tentar cercar la interferencia (EMP) proximo a la tarjeta Digital tanbien tentaria "matar" esa molestia directemente en la fuente donde son generadas , o sea buscaria saper onde é generado las chispas ( contactores , llaves ) y ay si tentar apagarlas o aomenos atenuarlas con lo uso de REDs Snubber ( capacitor + resistor).
!Suerte y saludos"
 
Mirá, en la empresa donde destoy usamos pic's y motores, pero no son monofásicos, sin trifásicos manejados por inverter, y nunca tuve problemas de ese tipo, y eso que todo lo meto dentro de un gabinete tanto los enverter's como los controladores con pic's.
Eso si, todo esta a tierra, es mas que fundamental este punto, filtro de linea de 220vac, y algun que otro toroide de ferrite para los cables de potencia, en algunos casos llegue a colocar 3 inverter's en un gabinete de 400x400mm sin problemas, pero claro, no manejo los armonicos de conexión y desconexión de contactores de potencia.
 

Daniel Lopes

Miembro Geconocido
Mirá, en la empresa donde destoy usamos pic's y motores, pero no son monofásicos, sin trifásicos manejados por inverter, y nunca tuve problemas de ese tipo, y eso que todo lo meto dentro de un gabinete tanto los enverter's como los controladores con pic's.
Eso si, todo esta a tierra, es mas que fundamental este punto, filtro de linea de 220vac, y algun que otro toroide de ferrite para los cables de potencia, en algunos casos llegue a colocar 3 inverter's en un gabinete de 400x400mm sin problemas, pero claro, no manejo los armonicos de conexión y desconexión de contactores de potencia.
Serias muy inportante poner un circuito "apaga chispas" ( Snubber ) en paralelo con los terminales de los contactores y llaves de potenzia , seguramente eso ayudaria en mucho a resolver o en peor de los casos atenuar lo problema de la EMP.
!Suerte!
 
Última edición:
Seguramente Daniel, tambien otra opción es alejar la parte de potencia de la parte de control, eso ayuda mucho tambien, y usar cables blindados para las tensiones que activan los contactores.
 
Tengo una resistencia de 10K Ohms al pin de reset como PullUp.

Dr. Zoidberg este sistemas es demasiado para un PLC, es como matar una hormiga con un tanque.
Phoenix contact es mejor marca que MEANWELL kiwhilario
pero buscare una fuente ABB o ALLEN BRADLLEY para probar de 240 VCA a 5 VCD

Acabamos de terminar el mismo sistema pero con arduino Mega en vez de los pics. lo probamos y le pasa el mismo problema.

Como podría eliminar ese ruido?
Yo me tomé el trabajo de desarmar la meanwell citada y doy fe que está construida bastante bien, no son muy caras y cumplen bien su trabajo. La marca Phoenix la conozco y quizas sea muy buena, pero el hecho de hacer un stepdown de 24 a 5v linealmente pues implica que tu conocimiento a nivel de diseño de circuitos es muy limitado.
Y bueno, dado a que no te tomaste la molestia de indicar en qué parte del circuito tomaste las capturas pues implica que, efectivamente, los colegas hacen bien en recomendarte usar PLC.

En mi humilde opinion no tiene nada de malo usar un pic o un atmega en un entorno industrial (ojo, sólo si sabes como hacerlo). Ahora, usar los módulos arduino uno/mega/etc en un ambiente de laboratorio para prueba de concepto es aceptable. Usarlos en un ambiente de trabajo es ingenuo e imprudente. La lista que puso scooter es muy buena, yo agregaría usar PTCs y/o fusibles slow blow para algunas partes críticas del circuito así como usar componentes de grado fireproof.
 
Ya se trató quinientas mil veces en el foro que no se puede alimentar motores y pic's con la misma fuente , uses el filtrado que uses , aunque podés probar unos capacitores de 100nF y filtros de línea . . . no vendrían mal . . .
Dosmetros aunque pienso como tu no lo termino de tener del todo claro, yo uso una fuente que me saca dos tensiones de 31vdc, la fuente la saque de la empresa que cuando se estropean no las reparan, directamente las tiran, solo tenia el MOSFET de potencia en corto, con esta fuente alimento también el pic, el GND es el mismo para todo, manejo 2 motores de 220v monofasicos y el único problema que tenia era en el teclado, hasta que me di cuenta que olvide poner condensadores de 100n y diodos en el teclados, el micro se volvía loco y la lcd sacaba datos rarísimos, aun así, resuelto el problema pude comprobar que de muy rara en rara vez hacia algo raro, cataba las interferencias, o eso creo yo. de los motores , solución, quite los relés y los puse de estado solido, los 2 motores son de 3/4 Hp, con su correspondiente varistor y se me acabaron todos los problemas, por lo menos hasta día de hoy jejejejeje.
 
Yo pienso que es como bien dice Scooter en un post mas arriba y que por cierto, una de las cosas que se me olvido decir es que también cambie todo el cableado y lo puse todo apantallado y valla cambiazo, osease todo lo que ha puesto Scooter es muy cierto pero sobre todo el cable apantallado.
A todo esto parece que el amigo SYEN1 se lo a tragado la tierra jeje.
 
Termine fabricando una placa con 4 piezas de arduino nano, coloque un capacitor de 2200 uF a la entrada de los 5V y coloque un capacitor de 100 nF en la entrada Vin y GND de cada arduino, ademas utilice cable blindado para todas las señales de entrada y salida de la tarjeta, coloque un varistor en paralelo con la bobina del relevador y otro en la salida en paralelo con los contactos.

se noto mucha mejoría en aplicar el cable blindado y los varistores terminaron por eliminar el problema.

DOSMETROS tienes mucha razon, en si el PLC es un microcontrolador, ademas yo repara muchisimas tarjetas industrailes con este mismo sistema.​


espero les haya servido de algo esta información, cualquier cosas estoy al pendiente.
Yo me tomé el trabajo de desarmar la meanwell citada y doy fe que está construida bastante bien, no son muy caras y cumplen bien su trabajo. La marca Phoenix la conozco y quizas sea muy buena, pero el hecho de hacer un stepdown de 24 a 5v linealmente pues implica que tu conocimiento a nivel de diseño de circuitos es muy limitado.
Y bueno, dado a que no te tomaste la molestia de indicar en qué parte del circuito tomaste las capturas pues implica que, efectivamente, los colegas hacen bien en recomendarte usar PLC.

En mi humilde opinion no tiene nada de malo usar un pic o un atmega en un entorno industrial (ojo, sólo si sabes como hacerlo). Ahora, usar los módulos arduino uno/mega/etc en un ambiente de laboratorio para prueba de concepto es aceptable. Usarlos en un ambiente de trabajo es ingenuo e imprudente. La lista que puso scooter es muy buena, yo agregaría usar PTCs y/o fusibles slow blow para algunas partes críticas del circuito así como usar componentes de grado fireproof.
el stepdown es porque se tenia a la mano, no por otra razón. Ademas cuando se trabaja con presupuestos ilimitados podemos comprar lo mejor de lo mejor, pero con presupuestos muy pero muy limitados como en este caso, no hay mucho de donde escoger, se tiene que trabajar con lo que se tiene.
 
Utiliza siempre condensadores de 0.1uF (como mínimo), para el desacople del Vcc. En las alimentaciones que vienen de la linea de fuerza puedes poner ferritas supresoras. y en la salidas de alimentación DC, para la parte de control utilizar filtros en PI.
Los vartistores no son filtros y no ayudan a filtrar nada, un varistor es una protección contra las puntas de voltaje, para que esa energía no se propague en el resto del circuito (en teoría) porque sus tiempos de reacción son demasiados lentos con respecto a otros tipos de protección.
Me alegra mucho que hayas logrado solucionar tu problema y con eso haber tomado experiencia para tus futuros desarrollos.
 
Arriba