Ruido en DC afecta a Pic's

Hola. Quiero aprovechar este post para hacer una consulta similar sobre la fuente DC. Tengo dos arduinos Nano con SN75176 para transmitir datos y comando por Rs485 a 150m de distancia. Utilizando UTP cat6 y con soft probado. Cuando los nano están a 10m la comunicación es perfecta y ambos conversan sin problemas (alimentados por la misma notebook). Cuando los instalo en sus ubicaciones utilizando fuentes de módem de 12V 1A ya 150m la comunicación falla. El maestro escucha al esclavo pero no le puede hablar. Y lo que escucha no es todo sino algunas cosas y otras no (aleatorias). Dije tengo ruido y puse una ferrita que estaba en la alimentacion de uan vieja unidad ZIP. Ahora el maestro escucha mejor pero sigue sin poder "hablar". La fuente de módem ingresa con 12V y la bajo con un 7805 más los capacitarse 0.1nf y 100uf. Desconecto todo. Llevo a 10m los Nano y con fuentes individuales y nuevamente conversan sin problemas. No tengo experiencia en comunicaciones y no tengo osciloscopio para ver el ruido. Pero el RS485 es justamente indicado para lugares con ruido. No debería funcionar hasta 1,2km? Leí de todo, creí haber elegido el método más seguro. Tengo las resistencias de 150ohm puestas en la terminaciones de cada lado. Quería sumar más esclavos y no logro que funcione el primero. No pretendo pedir soluciones a la distancia por la dificultad de tener que diagnosticar por acá, pero, qué debería estudiar? Dónde estoy mal parado? El cable está bien? El ruido de la fuente puede ser causal de fallos? Mil gracias por cualquier idea para probar. Pensé armar algun filtro para la fuente pero no sé si es la manera correcta de encara el fallo ya que como dije no tengo experiencia en este protocolo.
 
Gracias scooter, eso hice por eso puse la ferrita o el ferrite. Lo que no entiendo es por qué falla siendo supuestamente un protocolo para ambientes "industriales"? Será que la falla no es por ruido y estoy encarando mal la falla? A 10m funciona por lo que entiendo que si debería funcionar. Uso la uart del nano para evitar problemas. Puse cable UTP cat6 para que haya un buen vínculo. Lei en castellano y en inglés sin traducción para no caer en fallas de bots traductores. Use ejemplos de la hoja de datos del sn75176, en los foros de arduino copié ejemplos de códigos. Las fuentes son para equipos de comunicaciones a altas frecuencias (por si eso fuera bueno). Y hasta recé 1000 veces como dicen en el post sobre ruido...y cumplí con todas las normas del foro !! 🤣
Donde esta mi falla? Creo que no hay aprendizaje sin dolor como supo decir un gerente que conocí, pero no encuentro qué encaré mal. Solo quiero encender luces a 150m. No quiero navegar por Internet a 100MB...jajaja
 
Lo primero es fijar ambas alimentaciones y garantizarlas al 100%

Después mira por donde pasa el cable, si es trenzado...

Cambia de par, no todos los pares llevan la misma tasa de trenzado.
 
Si, es trenzado categoria 6. Ya probé los pares, fui cambiando de par en par. Como pruebo las alimentaciones? O sea, que pruebas deberia hacer?
 
Eso es cierto pero solo a velocidades de 100 mbps.... que dudo que estés usando.

A que velocidad estás trasmitiendo??

Subí el esquema de lo que has hecho.
Estoy a 4800 baudios. Para evitar las interferencias justamente tome una tasa baja.
En un rato subo el esquema que es básicamente un Nano con control en los pines DE/RE y salidas A-B con resistencia de 150ohms como terminación y los datos en Tx-Rx. Como comenté funciona bien a 10m por eso estoy seguro de que está bien cableado. Y el soft también funciona. Apenas pueda subo el esquema.
Gracias por leer y por las ideas!!!

Pd: algo que no comenté (no me acordaba hasta que probé lo que me decia scooter de cambiar pares) en el mismo UTP viaja señal de video de una cámara de vigilancia. Será eso lo que interfiere?
 

Dr. Zoidberg

Well-known-Papá Pitufo
Pd: algo que no comenté (no me acordaba hasta que probé lo que me decia scooter de cambiar pares) en el mismo UTP viaja señal de video de una cámara de vigilancia. Será eso lo que interfiere?
Puede ser que interfiera...sobre todo si no has conectado a tierra los apantallamientos de cada par.
Hacela fácil: apagá la camara y los dispositivos de red intermedios.
 
Pues es lo primero que se intenta. No preguntes. Prueba.
Jajaja. OBVIO!!! Tengo que ver si esta el vecino para que me preste la escalera para subir a desconectarla. No quiero cortar el cable para aislarla porque generar otro punto de conexión no es una buena idea.
Creo que tengo una sumatoria de situaciones contra mi circuitito. Todas "insignificantes" pero que sumadas tiran abajo mi proyectito personal...estoy abatido...en cuanto me preste la escalera desconecto y cuento si funciona.

GRACIAS MUCHACHOS!
Puede ser que interfiera...sobre todo si no has conectado a tierra los apantallamientos de cada par.
Hacela fácil: apagá la camara y los dispositivos de red intermedios.
Mi cable tiene una sola pantalla. No tiene una por par. Los UTP cat 6 tienen pantallas por cada par?
 
  • UTP (Unshielded Twisted Pair ? Par trenzado no apantallado): Es un cable sin apantallamiento. Esto lo sigue haciendo bueno para utilizar en casa, por ejemplo, para conectar tu ordenador, NAS o cualquier otro dispositivo al router. Pero es el menos indicado para ser utilizado en instalaciones que van por dentro de la pared y requieren de cables especialmente largos.
  • FTP (Foiled Twisted Pair- Par trenzado con pantalla global): Es un tipo de cable parecido al UTP, donde los pares de cables trenzados no están apantallados. Sin embargo, sí tienen una pantalla global, una especie de protección que envuelve todos a la vez para darles un poco de protección ante interferencias externas.
  • STP (Shielded Twisted Pair- Par trenzado apantallado): Los pares de cables trenzados van recubiertos cada uno por una malla conductora que actúa como una pantalla frente a las interferencias y el ruido eléctrico. Su protección es mayor que la la de los dos tipos anteriores, y los convierten en cables mejor preparados para las instalaciones eléctricas que van por dentro de la pared.
  • SFTP (Shield Foiled Twisted Pair - Par trenzado blindado y apantallado): Es un tipo de cable especial que combina las protecciones del FTP y STP. Los pares trenzados de cables van recubiertos cada uno por una malla protectora, pero a la vez todo el conjunto de pares también tiene un recubrimiento extra. Estos son los que mejor evitan las interferencias eléctricas y más idóneos para tiradas largas, aunque son más costosos.
 
Buenas gente.

Mañana me prestan la escalera para desconectar la camara y probar. Mientras voy subiendo mi esquema. El conector J1 es el que uso para indicar que se enciendan las luces que quiero controlar a la distancia. El receptor es igual. Solo que tiene reles conectados al conector J4. Está diseñado así para tener una sola placa para ambas cosas (maestro y esclavo). Solo evito perforar y poner los componentes que lleva uno y el otro no y viceversa.

Mi mayor duda es porqué funciona a 10m y no funciona a 150m. Creo que al desconectar la cámara que usa el mismo cableado UTP se podría solucionar (y por dentro espero que no sea eso porque no puedo tirar otros 150m de UTP para solucionar la falla).

Gracias totales. (como se verá no soy un gran genio del diseño, solo copié y lo hice lo más simple y directo posible con un solo fin, que funcione! :cry:).

1622249761928.png
 
Hola! Buenas noches. Pudiste solucionarno? De que tecnologia es el capacitor que tenes como bypass entre vdd y vss? Tantalio suele ir muy bien para ese ruido por que es capaz de entregar la energia muy rapidamente. Quizas intentaria poner capacitores de valor pequeño en paralelo, DE DIFERENTES TECNOLOGIAS, con las patas lo mas cortas posibles y volveria a tomar ese oscilograma.

Saludos y buena suerte.
 
Sería mejor si cualegas un esquema que se vea y de preferencia con los cables "peinados" porque hay un nudo ahí enmedio interesante.
Ver el circuito real también ayudaría; lo mismo están todos los cables ahí dando vueltas y tocandose unos con otros.

Baja las resistencias de 47k 4k7 y si puedes a 470
Pon una fuente "de verdad"; un 7805 es bastante "de juguete" en mi experiencia.

Revisa el datasheet del max a ver que dice, que el estandard rs485 diga tal y cual no quiere decir que los integrados lo cumplan al 100%. Por ejemplo los max233 max232 no generan +-12V generan del orden de +-8 u 8V lo cual es funcional en la mayoría de los casos pqeo no cumple el estándard al 100%

Si los circuitos están muy lejos alimentados por dos fuentes diferentes, no sabemos como de aislados están y que referencias de tensión tienen. Al ser balanceado sin masa común el max algo de inmunidad le da pero si es mucha la diferencia ya no irá.
Puedes usar los pares no usados como pantalla tirandolos a tierra en uno de los extremos.
 
Sería mejor si cualegas un esquema que se vea y de preferencia con los cables "peinados" porque hay un nudo ahí enmedio interesante.
Ver el circuito real también ayudaría; lo mismo están todos los cables ahí dando vueltas y tocandose unos con otros.

Baja las resistencias de 47k 4k7 y si puedes a 470
Pon una fuente "de verdad"; un 7805 es bastante "de juguete" en mi experiencia.

Revisa el datasheet del max a ver que dice, que el estandard rs485 diga tal y cual no quiere decir que los integrados lo cumplan al 100%. Por ejemplo los max233 max232 no generan +-12V generan del orden de +-8 u 8V lo cual es funcional en la mayoría de los casos pqeo no cumple el estándard al 100%

Si los circuitos están muy lejos alimentados por dos fuentes diferentes, no sabemos como de aislados están y que referencias de tensión tienen. Al ser balanceado sin masa común el max algo de inmunidad le da pero si es mucha la diferencia ya no irá.
Puedes usar los pares no usados como pantalla tirandolos a tierra en uno de los extremos.
Muchas gracias Scooter. No quise eliminar nada del circuito porque no quiero esconder nada. Pero voy a borrar lo no inherente a la comunicación para que sea más clara la vista. En un rato lo subo (estoy esperando al vecino y su escalera).

Las resistencias de 47k son altas para reducir la corriente. Desde mis épocas de estudiante las he usado así por consejos de un profe. Te parece que puedan inducir ruido? La verdad no lo había pensado.

Me gusto lo de poner a tierra un par. Voy a probar. Unir las tierras de las fuentes por la pantalla del UTP seria correcto? O seria una aberración del constructor del circuito? (O sea yo).

Gracias por tus aportes y tu ayuda!
 
Lo que no va en llantos va en suspiros.
Si la impedancia es alta consume poco y "cualquier cosa" mete ruido. Si la impedancia es baja, consume más y solo cosas muy serias son capaces de meter ruido.
Si funcionara a pilas habría que hilar fino entre una cosa y otra. Si va conectado que consuma lo que quiera y más. Estamos hablando de "mucho consumo" de unos pocos mA.
En principio no está ahí tu problema, o si. Como no se sabe que hay conectado ahí no se sabe que está pasando.
 
Arriba