¿Cómo se puede compilar en picbasic pro en windows de 64 bits?

#1
hola que tal,

quisiera saber si me pueden ayudar con el compilador picbasic pro 2.50C, ya que no me compila porque uso una versión de windows de 64 bits, no sé si exista alguna solución para que pueda compilar sin problemas en 64 bits, gracias saludos.:)
 
#2
Windows 64-bit compatibility requirements:

Users of 64-bit systems must instruct PBP to use the Microchip Assembler, MPASMWIN. In MicroCode Studio, this is a simple check box setting in the Compile and Program Options dialog. On the Compiler tab, check the box labeled "Use MPASM". MPLAB must be installed. It can be downloaded from the Microchip site or installed from your PBP install CD.

Es por que el sistema es de 64bits, ya que en un Windows 7 de 32bits corre normal.
Es problema del PBP y la posible solución lo indican ellos mismos:
Es decir, cambia el compilador por el del MPASMWIN desde "View > Compile and program options".
*sugerencia por "By Axel" y lo comprobo "truchapp"
 
Última edición:
#3
hola aldotronic

gracias por tu aporte me ha servido de mucho, ya puedo compilar sin problemas pero tuve que hacer otros cambios porque uso el pickit2 y necesito configurar los fuses desde el programa y lo dejo detallado por si otra persona tiene el mismo problema:

Primero bajamos el MPASMWIN de esta pagina: http://melabs.com/support/mpasm.htm
es un zip y lo extraemos en C: , no en la carpeta PBP, y entonces seguimos los pasos que nos indica aldotronic, cuando seleccionemos "use MPASWIN" damos click en find automatically.


Segundo si queremos por ejemplo compilar un programa para el pic16f628a necesitamos ir a la carpeta PBP y buscar el archivo pic16f628a.INC lo abrimos con el bloc de notas y nos aparecerá algo así:

;****************************************************************
;* 16F628A.INC *
;* *
;* By : Leonard Zerman, Jeff Schmoyer *
;* Notice : Copyright (c) 2003 microEngineering Labs, Inc. *
;* All Rights Reserved *
;* Date : 11/06/03 *
;* Version : 2.45 *
;* Notes : *
;****************************************************************
NOLIST
ifdef PM_USED
LIST
include 'M16F62xA.INC' ; PM header
device pic16F628A, xt_osc, wdt_on, mclr_on, lvp_off, protect_off
XALL
NOLIST
else
LIST
LIST p = 16F628A, r = dec, w = -302
INCLUDE "P16F628A.INC" ; MPASM Header
;__config _XT_OSC & _WDT_ON & _MCLRE_ON & _LVP_OFF & _CP_OFF
NOLIST
endif
LIST

noten que la línea ;__config _XT_OSC & _WDT_ON & _MCLRE_ON & _LVP_OFF & _CP_OFF está comentada porque la configuraré desde el programa

tercero en nuestro programa solo copiamos esa línea sin el ";" para que no este comentada, y cambiamos los fuses que nosotros queramos, ya que si usamos el MPASMWIN no existe el @ device, necesitamos configurarlo poniendo @ __config _XT_OSC & _WDT_ON & _MCLRE_ON & _LVP_OFF & _CP_OFF

y eso es todo, espero le sirva a otra persona que tenga el mismo problema para windows de 64 bits.
 
Última edición:
#4
Buenas noches, yo hago el paso que mencionan de cambiar el compilador, pero ya cuando va a trabajar, sale que el assembler solo permite 62 caracteres y que lo he excedido ???? q puedo hacer, el programa q realice es realmente muy pequeño.....
 
#5
Buenas noches, yo hago el paso que mencionan de cambiar el compilador, pero ya cuando va a trabajar, sale que el assembler solo permite 62 caracteres y que lo he excedido ???? q puedo hacer, el programa q realice es realmente muy pequeño.....
Los 62 caracteres se refieren a la ruta del archivo (C:\Program Files....etcccc). Pon tu programa lo mas cerca del compilador MPASMWIN, asi no te va a dar esos problemas.

Un saludo
 
#6
Hola como van compañeros !!


Mi consulta de hoy es la siguiente, realizo un programa en el microcode studio, lo simulo en el ISIS y funciona de maravilla, pero cuando lo paso al lic aparece la pantalla del lcd con cuadros blancos donde no se le nada, pero si presiono con los dedos el micro (16f877a) empieza a aparecer el programa !!!!!, retiro los dedos y vuelven a desaparecer las imagenes del programa !!! probe cargando un archivo .hex de otro programa (microbasic) y si funciona en el micro ??? no se si es un problema del compilador o algo x el estilo cualquier ayuda sera mas que bienvenida muchas gracias

Att Sebastián :unsure:
 
#7
Hola como van compañeros !!


Mi consulta de hoy es la siguiente, realizo un programa en el microcode studio, lo simulo en el ISIS y funciona de maravilla, pero cuando lo paso al lic aparece la pantalla del lcd con cuadros blancos donde no se le nada, pero si presiono con los dedos el micro (16f877a) empieza a aparecer el programa !!!!!, retiro los dedos y vuelven a desaparecer las imagenes del programa !!! probe cargando un archivo .hex de otro programa (microbasic) y si funciona en el micro ??? no se si es un problema del compilador o algo x el estilo cualquier ayuda sera mas que bienvenida muchas gracias

Att Sebastián :unsure:
¿Ya revisaste los fuses de tu programa, configuración de puertos, inicialización del LCD etc.?
Si no encuentras solución, adjunta tu proyecto completo dentro de un archivo comprimido.

Suerte.
 
#8
Hola !!!

Todo ha sido un desastre jeje al momento de soldar el cautin estuvo muy Cerca del display y lo daño un poco, pero lo en realidad causaba todo el problema era q usaba en oscilador de 8hz, en la programacion si lo definia pero no use {} para especificar el valor, sino q solo ponia DEFINE Osc 8 , y el microcode ponia un oscilador de 4 que es el q define siempre, bueno defiendo bien ya Se resolvio el problema muchas gracias
 
#9
Hola alguno de ustedes me puedo ayudar porfavor! tengo el problema con la compatibilidad debido a que mi maquina es de 64 bits, instale MPLAB pero en microcode no me aparece la opcion de MPASM. O me podrian pasar porfa el programa MPASMWIN :/Gracias!!
 
Última edición:
#10
Hola alguno de ustedes me puedo ayudar por favor! tengo el problema con la compatibilidad debido a que mi maquina es de 64 bits, instale MPLAB pero en microcode no me aparece la opción de MPASM. O me podrían pasar por favor el programa MPASMWIN :/Gracias!!
¿Si ya instalaste MPLAB para qué quieres el programa MPASMWIN?
Lo encuentras en la carpeta: C:\Archivos de programa\Microchip\MPASM Suite
Ve al menú View/Compile and Program Options.

Aquí se selecciona que se usará MPASM
Compile_&_Program_Options.jpg

Si tienes otro tipo de problema, por favor incluye mas detalles.
 
#11
aun estando instalado el MPLAB no me aparecía la casilla USE MPASM :/. Pero Baje el MPASMWIN lo copie al disco (C) y ya aparecio!! de todos modos muchas gracias la verdad me sirvió de mucho, ya que era una lata estar con la maquina virtual!!
 
Arriba